Blender 3D/Le Outliner

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche
Sommaire: Blender 3D
Page suivante: Un bipède animable
Page précédente: Les propriétés des objets

Le Outliner est un outil qui permet de visualiser rapidement la structure d'une scène. Il vous permet par exemple de voir quelles textures et matières sont reliées à quel objet. Dans Blender, l'Outliner présente aussi des fonction intéressantes d'affichage des objets et de gestions des librairies. Pour ouvrir l'Outliner, il suffit de charger la fenêtre Outliner dans l'une des séparations de votre interface.

Cet outil devenant très vite indispensable, il est conseillé de toujours créer une division dans laquelle on charge l'Outliner.

La hiérarchie d'une scène[modifier | modifier le wikicode]

L'outliner de la scène par défaut

Observons l'Outliner de la scène de base de Blender.

  • Le premier élément est la scène. En effet, Blender est capable de gérer plusieurs scènes dans un même fichier (comme si on mettait plusieurs fichiers en un). Dans notre cas, on travaille sur la scène nommée Scene.
  • Le second élément est une sorte de dossier qui contient les différents calques de rendus. Ces calques seront étudiés en détail dans la partie sur le rendu. Aussi, nous allons ignorer cet élément dans ce chapitre.
  • Ensuite, on a l'environnement. Cet élément contient les informations d'ambiance générale tels que la couleur/image d'arrière plan, les informations sur l'Occlusion (voir la partie sur le rendu)... L'environnement en cours d'utilisation est donc nommé ici World.
  • Les trois éléments suivant sont des Objets de la scène 3D (identifiables par leur icône commune).
    • Une Caméra nommée Camera. Notez qu'un petit icône juste à droite du nom permet d'identifier cet objet comme une caméra.
    • Un objet visible (en l'occurrence, ici un mesh nommé Cube).
    • Une source de lumière nommée Lamp

Le système de hiérarchie est donc visualisé comme une arborescence de répertoire. Les éléments dépendants d'un autre étant imbriqués en retrait par rapport à ce dernier. Ici, les éléments RenderLayers, World, Camera, Cube et Lamp dépendent de Scene qui est l'élément maître. En cliquant sur les petits + à gauche d'un élément, on peut visualiser alors quels sont ses dépendances.

La structure déroulée des objets

Cliquez sur le + à gauche de l'élément Cube. On constate alors qu'il contient un sous élément : Cube. Cela mérite quelques explications :

  • L'élément maître Cube est l'objet de la scène. Il pourrait être n'importe quoi : un objet visible, une caméra, une lampe...
  • Le sous-élément Cube est la géométrie de cet objet. Ici, c'est un Mesh.

Lorsqu'on fait des duplications en instance, un nouvel élément maître est créé mais il garde en dépendance le même sous-élément que l'objet dupliqué. Ainsi, les deux éléments maîtres partagent un sous-élément géométrique commun.

Si vous cliquez sur le + de l'objet Camera vous constaterez ici que c'est une autre type d'élément Camera. Pour savoir quel type d'objet c'est, il vous suffit de regarder le petit icône juste à droite des noms des éléments.

Continuons d'explorer la hiérarchie de notre cube de base. Vous constaterez que le sous-élément contient aussi un élément : Material qui lui même contient Texture.

  • Le mesh Cube est donc associé à une matière (nommée Material). Une matière contient les informations d'apparence de l'objet (sa couleur, sa transparence, sa brillance...).
  • La matière (Material) est associée à une texture (nommée Texture). Les textures permettent notamment d'établir un motif précis sur votre objet. Ça peut être une image externe à Blender ou une texture procédurale calculée dans le logiciel.

Voyons maintenant quelques raccourcis pour explorer une structure.

  • Pour dérouler l'arborescence complète d'un élément, il suffit de maintenir la touche SHIFT pendant que vous cliquez sur le +.
  • Pour dérouler l'arborescence complète de tous les éléments, rendez vous dans le menu View → Show/Hide all.
  • Vous pouvez aussi dérouler un niveau de la structure en entrant NUM+ (accessible aussi dans le menu View → Expend one level). La touche NUM- fera l'inverse.

Structure de parentage[modifier | modifier le wikicode]

Le système de parentage déroulé dans l'Outliner

Voyons maintenant comment visualiser une structure de parentage dans l'Outliner. Créez tout d'abord quelques objets : Un cube, une sphère, un cône, un cylindre. Créez ensuite le parentage suivant :

  • Le cube est parent de la sphère et du cône.
  • La sphère est parent du cylindre.

Rappel Pour créer rapidement un parentage, sélectionnez le/les enfant(s) puis le parent en utilisant la combinaison CTRL + P.

Une fois ce parentage effectué, observez la structure dans l'Outliner.

  • Le cube est élément maître.
  • Le cône et la sphère sont des sous-éléments du cube.
  • Le cylindre est sous-élément de la sphère et par extension, il dépend aussi du cube.

Vous pouvez aussi connaître le nombre de sous-éléments d'un élément-maître lorsque son arborescence est regroupée. En effet, des petits icônes apparaissent à coté du nom qui indiquent la présence de sous-éléments : Blender-outliner-cube-group.png

Sélection d'un élément[modifier | modifier le wikicode]

Ce qui est intéressant avec l'Outliner, c'est que lorsque vous sélectionnez un élément, la fenêtre permettant d'éditer cet élément est automatiquement chargée pour peu que vous ayez une fenêtre de boutons et une vue 3D ouverte dans l'interface :

  • Lorsque vous cliquez sur l'objet géométrique d'un élément (par exemple, un Mesh), le viewport sélectionne l'objet associé et passe automatiquement en mode édition (mode permettant d'éditer la géométrie spécifique de l'objet, nous l'étudierons sous peu).
  • Si vous cliquez sur une matière, le panneau des matières est chargé dans la fenêtre des boutons.
  • ...

Renommer un élément[modifier | modifier le wikicode]

La totalité des éléments présents dans l'outliner peuvent être renommés. Pour ce faire, il vous suffit de maintenir la touche CTRL en cliquant gauche sur le nom de l'élément. Cela permet de renommer plus rapidement les éléments qu'en passant par le panneau des propriétés des objets.

Rechercher[modifier | modifier le wikicode]

Sur les scènes complexes, il peut arriver que le nombre d'objets devienne très important (notamment lorsqu'on commence à faire des armatures complexes pour les personnages). La fonction recherche permet de retrouver rapidement un élément dans l'Outliner. Ces fonctions sont accessible dans le menu Search de l'outliner.

  • Search → Find : Recherche l'élément ayant le nom de plus proche de ce qui a été entré. Vous pouvez donc entrer une partie ou le nom complet de l'élément recherché.
  • Search → Find complete : Même fonction que la précédente à la différence qu'il faut entrer le nom complet de l'élément recherché.
  • Case sensitive : Les deux fonctions précédentes ont un double portant l'appellation Case sensitive. En fait, les fonctions précédentes ne différencient pas les majuscules des minuscules. Celles portant Case sensitive sont sensible à la casse.

Afficher/geler/masquer les objets[modifier | modifier le wikicode]

Vous avez peut être noté la présence de 3 colonnes à droite de l'outliner présentant 3 icônes en face de chaque objet : Blender-outliner-restriction.png. Ce sont les colonnes de restriction. Si vous ne les avez pas, rendez vous dans le menu View → Show Restriction Columns dans l'outliner.

  • Le premier icône permet de masquer/afficher l'objet dans le viewport.
  • Le second icône permet de (dé)geler l'objet dans le viewport. Cela veut dire que l'objet en question ne pourra plus être sélectionné jusqu'à ce qu'il soit dégelé.
  • Le dernier icône permet de masquer/afficher l'objet dans le rendu final.

Ces fonctions sont relativement pratiques pour soulager la carte graphique en masquant des objets lourds dans le viewport ou encore pour avoir un viewport plus clair, travailler sur des objets temporaires que l'on ne veut pas au rendu mais qu'on souhaite conserver dans le viewport...

Restreindre la structure de l'outliner[modifier | modifier le wikicode]

Le menu display

Notez qu'il est possible de limiter l'affichage dans l'outliner. Par exemple, pour n'afficher que les objets de type mesh. Pour ce faire, il existe le menu Outliner Display dans le header de l'outliner.

  • All Scenes : Affiche la structure complète de toutes les scènes présentes dans le fichier (au lancement de Blender, il n'y en qu'une).
  • Current Scene : Affiche uniquement la structure de la scène sur laquelle on travaille.
  • Visible Layers : N'affiche que les éléments des calques visibles.
  • Groups : N'affiche que les groupes d'objets créés.
  • Same Types : Affiche tous les objets du même type.
  • Selected : N'affiche que la structure des objets sélectionnés.
  • Active : N'affiche que la structure de l'objet actif (dernier objet sélectionné).
  • Sequence : Affiche les éléments du séquenceur (voir la partie sur le séquenceur de Blender).

Oops Shematic, un autre mode de visualisation[modifier | modifier le wikicode]

Oops Shematic de la scène de base

Il existe un autre mode de visualisation de la structure des scènes; le Oops Shematic. En fait, cet outil existait avant l'Outliner mais est de moins en moins utilisé depuis l'apparition de celui-ci. C'est une méthode de visualisation par un graphique relationnel. Pour y accéder, rendez vous dans le menu View de l'Outliner et cliquez sur Show Oops Shematic.

Observons le schéma de la scène de base de Blender.

  • On constate toujours la présence de lien entre les éléments mais cela se fait sous forme d'arbre. L'élément maître (Scene) étant à la racine. Les types d'éléments sont identifiables par des couleurs.
  • Les éléments ayant des connexions ont leur contour en tirets.

Manipuler les éléments du graphique[modifier | modifier le wikicode]

Les outils permettant de manipuler les éléments du graphique sont les mêmes que pour le viewport :

  • Clic droit : Sélectionne un élément. SHIFT permet la sélection multiple. Le dernier élément sélectionné est l'élément actif. Il est aussi possible de faire un cadre de sélection avec la touche B.
  • G : Permet de déplacer le(s) élément(s) sélectionné(s) dans le graphique. Accessible aussi via le menu Block → Grab/Move.
  • S : Permet d'étirer une sélection (lorsque vous avez deux éléments sélectionnés ou plus, cela les espacera). Accessible aussi via le menu Block → Scale.
  • La Molette permet de zoomer ou dé-zoomer dans le graphique. Le clic central permet de bouger dedans.
  • Home : Permet de tout voir. Accessible dans View → View all.
  • NUM. : Centre et zoom sur la sélection. Accessible dans View → View Selected.

Ce graphique peut rapidement être le bazar. Ainsi, SHIFT + S et ALT + S permettent de réorganiser automatiquement les éléments sélectionnés (accessible aussi dans le menu View → Shuffle Selected Blocks et View → Shrink Selected Blocks. Le premier réorganise de la manière la plus compacte possible, le second de la manière la plus claire possible.

Notez aussi la présence de deux fonctions de sélection intéressantes :

  • Sélectionner les éléments dépendants de celui déjà sélectionné : L ou Select → Linked to Selected.
  • Sélectionner l'élément maître de celui déjà sélectionné : SHIFT + L ou Select → User of Selected.

Limiter les éléments affichés[modifier | modifier le wikicode]

Tout comme dans l'Outliner, il est possible de limiter les éléments affichés dans le graphique. La fonction est cependant étudiée différemment car la sélection se fait par type d'objet. Une liste de petits icônes est présente au niveau de l'en-tête et permet d'afficher/masquer, selon qu'il sont cochés ou non, un type d'élément tel que :

  • Les scènes
  • Les objets
  • Les meshes
  • Les courbes
  • ...
Future fonctionnalité de Blender 2.50 .

L'outliner dans Blender 2.50

Le nouveau outliner de Blender 2.5

Le version 2.5 en développement de Blender devrait apporter son lot de nouveautés révolutionnaires sur tous les plans et notamment au niveau de l'Outliner. En effet, actuellement, l'outliner de Blender est relativement passif. Il permet de visualiser la structure, supprimer des objets, afficher ou masquer, geler les objets... Dans les séries 2.5 à venir, l'outliner sera un véritable centre de contrôle de la scène. Toutes les informations sur les éléments constituants la scènes pourront être édités par l'outliner tel que la couleur d'une matière, l'indice de réfraction, l'adresse d'une texture, la valeur d'un modificateur...

C'est une nouvelle partie de l'outliner qui le permet : le Datablock qui peut s'apparenter à la Channel Box de Maya mais en beaucoup plus évolué puisque toutes les valeurs y seront regroupées.

Encore mieux, les propriétés de chaque face ou arrête d'un objet pourront être modifiées directement via l'outliner. Les liens parents enfants seront directement créés à partir de l'outliner (comme c'est déjà le cas de Maya) par simple cliquer-glisser.

Mais la véritable révolution est sur l'animation. Il sera désormais possible de poser des clés sur toutes les valeurs existantes à la volée à partir de l'Outliner, qu'elle soit de type texte, oui/non, numérique... Pour les non initiés, cela veut dire que tout pourra être animable, même les informations qui ne paraitront pas au rendu (par exemple, passer en mode Wire dans le viewport au bout de 25 images). Jusqu'à maintenant, il n'était pas possible d'insérer des clés partout dans Blender. Avec la version 2.5, ça le sera. Ce mode de fonctionnement fait penser à celui de Maya, logiciel dans lequel tout est animable et inter-connectable.

Mais l'outliner ne s'arrêtera pas à la scène. Il permettra aussi d'éditer le comportement du logiciel (actuel panneau des préférences utilisateurs).

À ce titre, de nouveaux modes d'affichage de l'outliner sont créés pour pouvoir voir la structure de la scène en regroupant par type d'éléments (les matières ensemble, les meshes ensemble...


Sommaire: Blender 3D
Page suivante: Un bipède animable
Page précédente: Les propriétés des objets