Blender 3D/Manipuler les objets

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche
Sommaire: Blender 3D
Page précédente: Les primitives

Le curseur 3D[modifier | modifier le wikicode]

Le curseur 3D

Le curseur 3D est une notion qui n'existe que dans Blender. Il indique l'emplacement où sera ajouté le prochain objet. Il est comparable au curseur dans un éditeur de texte, à la différence qu'il peut se placer sur les axes X, Y et Z.

De plus, cet outil permet aussi de définir temporairement un point autour duquel s'effectueront les modifications. Il peut devenir ponctuellement le point de pivot d'un objet sans en affecter le centre réel.

Le curseur 3D ressemble à un croix cerclée d'une ligne rouge et blanche. Par défaut, il est à l'origine du repère (au centre de la scène).

Déplacer le curseur 3D[modifier | modifier le wikicode]

Peut-être ne voyez vous pas le curseur 3D dans votre scène. Cela veut dire qu'il est à l'extérieur de votre point de vue. Pour le placer à un endroit précis, il suffit de cliquer gauche dans la vue 3D et il viendra se placer automatiquement à l'emplacement du pointeur de votre souris.

Dans certains cas, on souhaitera placer le curseur 3D avec précision. Cela est possible via le panneau View Properties accessible dans le menu View → View Properties. Il suffit alors de modifier les valeurs X, Y et Z dans la colonne 3D Cursor de cette mini fenêtre.

SHIFT + C permet de replacer le curseur 3D à l'origine du repère. Notez que ce raccourci a aussi la fonction de recentrer votre point de vue de manière à voir toute votre scène à l'écran.

SHIFT + S puis Cursor -> Selection permet de placer le curseur 3D à l'intérieur d'une sélection.

Insérer un nouvel objet[modifier | modifier le wikicode]

Le menu Add via la barre des menus
Le menu Add via la barre d'espace

Comme toujours dans Blender, il existe plusieurs moyens pour réaliser une action et l'insertion de nouveaux objets ne déroge pas à la règle :

  • Le menu Add dans la barre des menus en haut de l'écran.
  • En ayant le curseur sur la vue 3D, utilisez la touche Espace pour faire apparaître le menu Add.
  • En maintenant appuyé le Clic gauche ou le Clic droit dans le viewport, le menu Add apparaît.

Dans tout les cas, les objets sont regroupés dans des sous-menus par type :

  • Mesh : Toutes les primitives avec un maillage polygonal.
  • Curve : Tous les objets de type courbe.
  • Surface : Tous les objets NURBS créés à base de courbes.
  • Meta : Tous les meta-objets.
  • Lamp : Toutes les sources lumineuses.

Ensuite, on trouve aussi à la racine du menu Add les objets spéciaux tel que :

  • La caméra (Camera)
  • Le texte (Text)
  • Les objets utilitaires (Empty, Armature, Lattice)

Vous trouverez aussi un sous-menu Group. Ce dernier contient les groupes d'objets existants dans le fichier ou importés en instance sous forme de librairie. Cela permet de créer des librairies d'objets qu'il est possible d'insérer par la suite rapidement. Comme nous ne savons pas encore créer des groupes d'objets, ce menu est pour l'instant vide.

Sélectionner un objet[modifier | modifier le wikicode]

NOTE
Sélection multiple

Dans le cas ou plusieurs objets sont sélectionnés, c'est le dernier objet à avoir été cliqué qui est l'objet actif. Les autres ne sont que des sélections. Cela est très important car les modifications s'appliqueront sur l'objet actif et non sur la sélection globale.


Les débutants sont souvent assez déroutés lorsqu'ils apprennent que dans Blender, la sélection se fait par Clic droit (cela pouvant être modifié dans les préférences utilisateur), le clic gauche servant à déplacer le curseur 3D.

Pour ajouter un objet à une sélection, utilisez la touche SHIFT et cliquez droit sur le second objet.

Il est aussi possible de faire rapidement un cadre de sélection. Pour cela, utilisez le raccourci B et faites un cliquer glisser gauche autour des objets pour créer votre sélection. Cet outil est aussi accessible via le menu Select → Border Select accessible dans l'en-tête de la vue 3D.

Dans certains cas, vous souhaiterez sélectionner tous les objets présents à l'écran ou vous assurer que tous les objets sont bien dé-sélectionnés avant une opération. Pour cela, utilisez la touche A qui sélectionnera tous les objets si aucun n'est sélectionné et qui dé-sélectionnera tous les objets si un ou plusieurs sont déjà sélectionnés. Vous retrouvez cette fonction dans le menu Select vu précédemment.

Supprimer une sélection[modifier | modifier le wikicode]

Après avoir sélectionné un ou plusieurs objets, utilisez la touche Suppr ou X pour supprimer définitivement la sélection. Cliquez sur le message pour valider. Vous pouvez aussi supprimer une sélection via le menu Object → Delete ou via la touche Espace Edit → Delete.

Notez que tant que Blender est ouvert, la géométrie de votre objet existe toujours. Elle n'est tout simplement pas affichée. Nous verrons plus tard comment la réutiliser.

Outils de déplacement[modifier | modifier le wikicode]

Manipulateur de translation
Activer l'outil de manipulation.

Il existe dans Blender 4 méthodes pour manipuler les objets :

  • Les manipulateurs (3D Transform Manipulator) : Cet outil existe dans Blender depuis la version 2.37 et permet de déplacer, tourner, redimensionner un objet à partir d'un repère visible sur l'objet. L'intérêt est de pouvoir sélectionner rapidement la modification sur l'objet dans sa globalité ou sur un axe en particulier (X, Y et Z).
  • Les raccourcis clavier : Que serait Blender sans ses raccourcis ? (Une main sur la souris, une autre sur le clavier). Donc naturellement, un raccourci clavier existe pour chaque outil de manipulation des objets. L'intérêt est qu'ils sont accessibles rapidement et qu'ils peuvent être cumulés avec d'autres raccourcis (par exemple, la contrainte sur 1 ou 2 axes).
  • Le tracé à la souris dans le viewport. C'est la vieille méthode de Blender, toujours existante mais plus trop utilisée (sauf avec les tablettes graphiques). Elle consiste à tracer une forme dans le viewport avec la souris pour déclencher une fonction de déplacement, de rotation ou de mise à l'échelle.
  • Par les menus : Très peu utilisé, mais lorsqu'on est perdu dans les raccourcis clavier, ça peut être intéressant.

Pour utiliser le manipulateur de translation il faut dans un premier temps que cet outil soit activé. Dans l'en-tête de la vue 3D, vérifiez que l'icône représentant une main est bien activée ainsi que le premier manipulateur (la flèche). A partir de là, le manipulateur est visible à l'origine de l'objet sélectionné. En cliquant gauche sur l'origine du manipulateur (cercle), vous déplacerez l'objet sur tous les axes. Pour déplacer l'objet sur un axe en particulier, cliquez gauche sur la flèche rouge (axe X), verte (axe Y) ou bleue (axe Z).

Le raccourci pour déplacer un objet est la touche G. L'objet est alors relié au curseur de la souris. Pour valider l'opération, il suffit de cliquer gauche, pour annuler cliquer droit. Nous verrons plus tard qu'il est possible aussi de contraindre le déplacement sur un axe ou deux.

En faisant un cliquer glisser gauche dans le viewport sur une zone vide (sans objet), vous constaterez qu'il est possible de dessiner des formes. Pour déplacer un objet, tracez une ligne droite.

La dernière méthode est assez lourde. Vous pouvez appeler la fonction de déplacement par les menus :

  • Dans l'en-tête du viewport : Menu Object → Transform → Grab/move
  • Via le raccourci Espace : Menu Transform → Grab/move

Vous connaissez maintenant toutes les méthodes pour déplacer un objet. En règle général, on utilise le plus souvent les manipulateurs ou les raccourcis claviers.

Outils de rotation[modifier | modifier le wikicode]

Nous allons plus rapidement voir comment utiliser les outils de rotation selon les méthodes suivantes :

  • Méthode des manipulateurs : Il vous suffit d'activer dans le header du viewport le second manipulateur (qui à la forme d'un cercle) (Voir le schéma dans la partie précédente). Le manipulateur de rotation affiche les axes sous forme de demi-cercles. En cliquant gauche sur un axe, vous réalisez une rotation contrainte sur cet axe. Pour réaliser un rotation libre, il vous suffit du cliquer sur la bordure extérieure du manipulateur (par défaut blanche).
  • Méthode des raccourcis clavier : Il vous suffit d'utiliser la touche R. La aussi, pour valider, utilisez le clic gauche et le clic droit pour annuler. Notez que la rotation s'effectue en mode libre et donc face à votre point de vue. Nous verrons comment contraindre la rotation autrement que par les manipulateurs plus loin.
  • Méthode par tracé à la souris : Il suffit de tracer un cercle autour de l'objet par le clic gauche pour activer le mode rotation. Pour les utilisateurs de Mac OS et certains utilisateurs de Linux, c'est un zigzag qu'il vous faudra tracer verticalement.
  • Méthode des menus : Menu Object → Transform → Rotate ou dans le menu Transform accessible via la barre d'espace.

Outils de mise à l'échelle[modifier | modifier le wikicode]

Vous pouvez redimensionner un objet selon les même procédés :

  • Par manipulateur : Le manipulateur d'échelle est le dernier de la liste dans le Header du viewport (son icône ressemble à un carré bleu). Son mode d'emploi est le même que pour le manipulateur de translation, les flèches étant remplacées par de carrés.
  • Par raccourcis clavier : La mise à l'échelle est accessible via la touche S.
  • Par tracé à la souris : Dessinez un V avec le clic gauche de la souris dans la vue 3D.
  • Par menus : Menu Object → Transform → Scale ou par le raccourci Espace menu Transform.

Contraindre une modification[modifier | modifier le wikicode]

Avec les manipulateurs, on a vu qu'il était possible de contraindre une modification de manière interactive sur un axe. Par exemple, si je veux déplacer l'objet uniquement sur l'axe X, il me suffit de cliquer sur l'axe en question du modificateur de translation. Cependant, avec les modificateurs, il n'est pas (encore) possible de contraindre sur deux axes (par exemple, grandir un objet sauf sur Z pour ne pas qu'il prenne en hauteur).

Par les raccourcis clavier, il est possible de réaliser de telles contraintes. Il s'agit des touches X, Y et Z pour contraindre sur les axes X, Y et Z. La condition est d'être déjà en cours de modification. Par exemple, je souhaite agrandir l'objet sur X, je vais d'abord utiliser la touche S puis la touche X (consécutivement et non en même temps). Il est naturellement possible de changer en cours de route l'axe de la contrainte en utilisant une des 3 touches de contraintes précédemment citées.

Pour le moment, la différence avec la méthode des manipulateurs est quasi nulle (deux raccourcis clavier au lieu d'un clic). Cependant, la touche SHIFT permet d'exclure un axe. Concrètement, la modification s'effectuera sur deux axes au lieu de 3 ou un seul. Donc, si je veux déplacer un objet sur X et Y uniquement, je vais entrer G puis SHIFT + Z (pour exclure l'axe Z et ne garder que X et Y). Cela fonctionne naturellement avec tous les types de modification : le déplacement, la rotation et la mise à l'échelle.

Dupliquer un objet[modifier | modifier le wikicode]

Il existe deux méthodes pour dupliquer un objet :

  • La duplication standard: On crée une copie conforme de l'objet. L'objet créé est alors indépendant de sa référence et peut être éditée comme un nouvel objet.
  • La duplication en instance. Là aussi, on crée une copie conforme de la référence. Cependant, l'objet nouvellement créé est lié au précédent. Si je souhaite éditer la géométrie de l'un, l'autre sera automatiquement modifié à l'identique. Cela s'avère très pratique dans la modélisation architecturale par exemple où des objets se répètent souvent.

Pour dupliquer un objet de manière standard, on emploiera les touches SHIFT + D, aussi accessible dans le menu Object → Duplicate de l'en-tête de la vue 3D. Pour dupliquer en instance, nous emploierons les touches ALT + D accessible dans le menu Object → Duplicate linked.

Vous noterez que lorsqu'on duplique un objet, nous sommes automatiquement basculés en mode déplacement.

Sommaire: Blender 3D
Page précédente: Les primitives