Discussion:MediaWiki pour débutants/Installer MediaWiki

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche

Et les autres SE ?[modifier le wikicode]

Bonjour,

vous auriez des solutions pour l'installation locale sur d'autres SE (en particulier MacOS X) ?

Merci

Cdang 22 décembre 2006 à 14:14 (CET)

Bon, en fouillant la page w:PHP: Hypertext Preprocessor, j'ai trouvé Mamp, je vais fouiller par là…
Cdang 22 décembre 2006 à 14:25 (CET)
Bon, j'ai installé MAMP 1.4.1, j'ai lancé mamp.app, j'ai cliqué sur démarrer les serveurs, j'ai tapé http://localhost:8888/mediawiki-XX/ dans mon explorateur et ça semble marcher.
Cdang 24 décembre 2006 à 12:49 (CET)
Bon, finalement, j'arrive pas à configurer MySQL, le serveur MySQL a bien voulu démarrer la première fois mais pas depuis )-:
Cdang 26 décembre 2006 à 19:59 (CET)


Pour ma part, j'ai tenté aussi l'installation sur mon mac, via MAMP, mais ce n'est guère plus probant... Ca serait pourtant pas mal de décrire la même procédure pour d'autres SE !

Problème de base de donnée[modifier le wikicode]

Bonjour,

j'ai suivi à la lettre la méthode d'installation du wiki sous windows. Le problème est qu'après validation, on me dit de revérifier DB username et DB password. J'ai testé avec 2 DB différentes, et 3 utilisateurs différents.

Merci d'avance

Les mots de passe et les utilisateurs sont valides ? Quel est l'environnement ? (versions de php et mysql) Tavernier 26 mars 2008 à 22:29 (CET)

La version de php est la 5.0, et celle de mysql 5.0.45 (fournis avec wampserver 2.0b), mais je destine le wiki à un serveur free (en php 4 je crois?). Les mots de passe et les utilisateurs devraient être valides, je les ai crées sur phpmyadmin.

Alors ca devrait fonctionner :) À moins que le problème vienne de windows. À tout hasard essaye une version de mediawiki certifiée compatible php4 comme la 1.6 : Dans le temps j'avais réussi à la faire tourner sur wamp. Tavernier 27 mars 2008 à 15:11 (CET)

J'ai oublié de préciser... J'ai essayé avec la 1.12 et la 1.6 (vu que je destine mon wiki à un serveur qui tourne en php4). Mais il est tout à fait possible que le problème vienne de mon windows. Je te remercie de ton aide.

cliquez sur le lien qui s'affiche en bas à droite[modifier le wikicode]

Bonjour, j'ai appuyé sur Intalle Wiki mais je ne vois pas où est le lien en bas à droite. Celui-ci : http://dev.mysql.com/doc/mysql/en/old-client.html for help.; enabling MySQL 4.1/5.0 charset mode ?????

De plus, j'ai aussi ce message souligné en rouge : You are using MySQL 4.1 server, but PHP is linked to old client libraries; if you have trouble with authentication, see

Je n'ai jamais vu ce message, tu as une vidéo ou une image plus parlante stp ? JackPotte ($) 19 septembre 2010 à 13:45 (CEST)

Installation sur support amovible (carte SD, USB)[modifier le wikicode]

Bonjour, j'essaye depuis quelques temps d'installer mon wiki en local sur une carte SD. Le problème étant que je n'arrive pas depuis mon navigateur à lancer mon wiki (localhost\wiki ne fonctionne pas).

J'ai changé le répertoire d'installation pour le mettre sur ma carte SD, le problème doit venir de là, mais comment rediriger le wiki sur ce nouveau support ?

Merci d'avance.

Je l'ai fait avec XAMPP. JackPotte ($) 31 juillet 2015 à 13:43 (CEST)