Du bon usage d'un traitement de texte/Utilisation des styles

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche

Les styles sont un élément important :

  • ils permettent la séparation du fond et de la forme (voir Tel écran, tel écrit… et Séparation du fond et de la forme) ;
  • ils assurent une homogénéité du document ;
  • ils facilitent la modification de la mise en forme du document ;
  • ils permettent la génération automatique de la table des matières ;
  • ils améliorent le confort de rédaction et font gagner beaucoup de temps.

Un style est en fait un choix de fonte et de composition. Il porte un nom qui reflète normalement la fonction du texte. En choisissant un style, cela met en forme directement le paragraphe ou les autres objets concernés (caractère, tableau, illustration, etc) ; si la mise en forme ne convient pas, il sera toujours possible de modifier le style plus tard.

Menu Styles

Dans la plupart des traitements de texte, le choix d'un style se fait avec une liste déroulante située en haut à gauche, à côté des listes permettant de définir la fonte (police et corps). Il faut justement éviter d'utiliser les autre listes déroulantes et n'utiliser que la liste de styles. Les raccourcis clavier pour accéder aux styles les plus fréquents sont identiques dans la plupart des traitements de texte, par exemple : Ctrl+1 pour Titre 1.

Avec AbiWord[modifier | modifier le wikicode]

Choix d'un style[modifier | modifier le wikicode]

Choix d'un style dans AbiWord : menu déroulant Style

Pour mettre un paragraphe dans un style donné, il faut placer le curseur à un endroit du paragraphe. Si l'on veut ne changer le style que d'une partie du texte, il suffit de sélectionner cette partie (la noircir).

Il y a normalement trois menus déroulants à gauche de la barre d'outils. Le choix d'un style se fait avec la liste déroulante située la plus à gauche, à gauche de la liste déroulante Police. Si les listes déroulantes ne font pas partie de la barre d'outil :

dans le menu Affichage, sélectionner Barres d'outils → Format.

Le style par défaut est Normal. C'est le style du corps de texte. Les styles proposés par défaut sont :

  • Titre 1, ou Titre de chapitre : pour les titres de chapitre ;
  • Titre 2, ou Titre de section : pour les titres de section ;
  • Titre 3 : pour les titres de sous-section.

Autres styles[modifier | modifier le wikicode]

Contrairement à certains autres traitements de texte, le menu déroulant Style d'AbiWord propose la totalité des styles disponibles.

Modifier un style[modifier | modifier le wikicode]

Une fois votre document terminé, et seulement à ce moment-là, vous pouvez peaufiner. Si la mise en forme imposée par les styles du traitement de texte ne vous conviennent pas, vous pouvez les modifier. Il faut pour cela afficher la boîte de dialogue « Styles ».

Pour modifier un style :

  • dans le menu déroulant Liste situé en bas à gauche de la boîte de dialogue, s'assurer que l'on a bien l'option Utilisé, ce qui permet de n'afficher que les styles utilisés dans le document ;
  • sélectionner le nom du style concerné dans la liste Styles disponibles, puis cliquer sur Modifier ; cela affiche la boîte de dialogue « Modifier les styles ».

Dans cette boîte de dialogue, si vous cliquez sur le menu déroulant Format en bas à droite, cela permet d'afficher d'autres pages, qui permettent de modifier tel ou tel aspect du style :

  • Police : tous les paramètres de la fonte ;
  • Paragraphe : permet de toucher aux retraits, blancs (sauts de ligne) et interlignes ;
  • Numérotation : permet de définir le style de numérotation d'une liste, mais aussi la puce d'une liste à puce (par exemple remplacer le • par un –).

Il faut « jouer un peu » avec tous ces paramètres pour se familiariser avec.

Par exemple pour la page Paragraphe :

  • composition en sommaire : dans la zone « Retrait », cliquer sur le menu déroulant Spécial et choisir l'option négatif :, puis mettre une valeur (par exemple 1 cm) dans le champ Par : ; mettre la même valeur dans le champ Gauche : ;
  • composition en alinéa : comme ci-dessus, mais choisir l'option Positif pour le menu Spécial, et mettre 0 dans le champ Gauche.

Pour la page Numérotation :

  • dans le menu déroulant Type, choisir s'il s'agit d'une liste numérotée ou non (à puces) ;
  • dans la liste Style, choisir le style de numérotation ou de puce (option Pointillés pour avoir des tirets à la française).

Pour modifier les styles de la table des matières, il faut afficher tous les styles : boîte de dialogue « Styles », menu déroulant Liste, option Tout. Puis, modifier les styles Tables des matières 1 à 4.

Avec LibreOffice Writer[modifier | modifier le wikicode]

Choix d'un style[modifier | modifier le wikicode]

Pour mettre un paragraphe dans un style donné, il faut placer le curseur à un endroit du paragraphe. Si l'on veut ne changer le style que d'une partie du texte d'un paragraphe, il suffit de sélectionner cette partie (la noircir), ce qui ne modifie que les propriétés des caractères et non celles attachées au paragraphe.

Bouton Styles et formatage et menu déroulant Appliquer le style

Il y a normalement trois menus déroulants à gauche de la barre d'outils. Le choix d'un style se fait avec la liste déroulante située la plus à gauche, à gauche de la liste déroulante Nom de police. Si les listes déroulantes ne font pas partie de la barre d'outil :

dans le menu Affichage, sélectionner Barres d'outils → Formatage.

Le style par défaut est Standard. C'est le style du corps de texte. Les styles proposés par défaut sont :

  • Corps de texte : texte d'un paragraphe ;
  • Titre 1 : pour les titres de chapitre ;
  • Titre 2 : pour les titres de section ;
  • Titre 3 : pour les titres de sous-section.

Autres styles[modifier | modifier le wikicode]

Boîte de dialogue « Styles et formattage »

Le menu déroulant Appliquer le style n'affiche que les style les plus courants ou bien ceux utilisés dans le document. Si l'on connaît le nom du style que l'on veut utiliser, on peut le taper à la place du style courant, le menu déroulant Appliquer le style se comportant comme une zone de texte.

Si vous choisissez l'option Autres… dans le menu, cela fait apparaître la boîte de dialogue « Styles et formatage » à droite de l'écran. Pour afficher cette boîte de dialogue, on peut aussi :

  • utiliser le menu Format → Styles et formatage ;
  • cliquer sur le bouton graphique Styles et formatage (doigt pointant une feuille) à gauche du menu déroulant Appliquer le style.

Pour afficher tous les styles disponibles, il faut cliquer sur le menu déroulant situé en bas de cette boîte et choisir Tous les styles, mais l'option par défaut Automatique convient en général.

Pour mettre un paragraphe ou une partie de texte dans un style donné, il suffit de double-cliquer sur ce style dans la liste de la boîte de dialogue.

Les styles les plus utiles sont :

  • Citation : marges plus grandes, pour les citations longues ;
  • Destinataire, Expéditeur, Formule finale, Signature : pour un courrier ;
  • Illustration : pour insérer une image
  • Légende : légende d'une image ou d'un tableau ;
  • Numérotation 1, Numérotation 1 2, Numérotation 1 3, … : pour des listes numérotées, par défaut composée en sommaire ;
  • Puce 1, Puce 2, … : comme leur nom l'indique, composée par défaut en sommaire ;
  • Titre : titre du document.

De nombreux styles ne sont pas destinés à être choisis par l'utilisateur, mais sont utilisés automatiquement par le traitement de texte, comme par exemple Pied de page.

Avec Microsoft Office Word 2003[modifier | modifier le wikicode]

Choix d'un style[modifier | modifier le wikicode]

Pour mettre un paragraphe dans un style donné, il faut placer le curseur à un endroit du paragraphe. Si l'on veut ne changer le style que d'une partie du texte, il suffit de sélectionner cette partie (la noircir).

Bouton et menu Style dans MS Word 2003

Il y a normalement trois menus déroulants à gauche de la barre d'outils. Le choix d'un style se fait avec la liste déroulante située la plus à gauche, à gauche de la liste déroulante Police. Si les listes déroulantes ne font pas partie de la barre d'outil :

dans le menu Affichage, sélectionner Barres d'outils → Mise en forme.

Le style par défaut est Normal. C'est le style du corps de texte. Les styles proposés par défaut sont :

  • Titre 1 : pour les titres de chapitre ;
  • Titre 2 : pour les titres de section ;
  • Titre 3 : pour les titres de sous-section.

Autres styles[modifier | modifier le wikicode]

Le menu déroulant Style n'affiche que les style les plus courants ou bien ceux utilisés dans le document. Si l'on connaît le nom du style que l'on veut utiliser, on peut le taper à la place du style courant, le menu déroulant Style se comportant comme une zone de texte.

Si vous choisissez l'option Autres… dans le menu, cela fait apparaître la boîte de dialogue « Styles et mise en forme » à droite de l'écran. Pour afficher cette boîte de dialogue, on peut aussi :

  • utiliser le menu Format → Styles et mise en forme ;
  • cliquer sur le bouton graphique Styles et mise en forme AA à gauche du menu déroulant de même nom ;
  • si une boîte de dialogue est déjà présente sur le côté droit, cliquer sur le titre de la boîte et choisir Styles et mise en forme dans le menu déroulant.

Pour afficher tous les styles disponibles, il faut cliquer sur le menu déroulant Afficher situé en bas de cette boîte et choisir Tous les styles.

Pour mettre un paragraphe ou une partie de texte dans un style donné, il suffit de sélectionner ce style dans la liste choisir la mise en forme à appliquer.

Les styles les plus utiles sont :

  • Code HTML : police à chasse fixe par défaut (Courier New), pour des exemples de code source ;
  • Corps de texte : texte normal ;
  • Liste, Liste 2, Liste 3, … : pour des listes non numérotées, par défaut composée en sommaire
  • Liste à numéros, Liste à numéros 2, Liste à numéros 3, … : pour des listes numérotées, par défaut composée en sommaire ;
  • Liste à puce, Liste à puce 2, … : comme leur nom l'indique, composée par défaut en sommaire ;
  • Titre : titre du document.

De nombreux styles ne sont pas destinés à être choisis par l'utilisateur, mais sont utilisés automatiquement par le traitement de texte, comme par exemple Numéro de page.

Dans cette liste choisir la mise en forme à appliquer, l'option Effacer la mise en page n'est pas un style ; cliquer dessus fait repasser le texte sélectionné ou le paragraphe en style Normal.

Un petit symbole figure à droite de la liste :

  •  : style modifiant la composition du paragraphe ;
  • a : style modifiant la fonte ;
  • + : cellule de tableau.

Modifier un style[modifier | modifier le wikicode]

Une fois votre document terminé, et seulement à ce moment-là, vous pouvez peaufiner. Si la mise en forme imposée par les styles du traitement de texte ne vous conviennent pas, vous pouvez les modifier. Il faut pour cela afficher la boîte de dialogue « Styles et mise en forme » (voir ci-dessus).

Pour modifier un style :

  • cliquer sur une portion de texte utilisant ce style ;
  • le nom du style apparaît automatiquement en haut de la boîte de dialogue « Styles et mise en forme », dans le champ Mise en forme du texte sélectionné ;
  • lorsque l'on place le pointeur de la souris sur ce champ, une flèche de menu déroulant v apparaît à droite ; cliquer sur cette flèche ;
  • dans le menu déroulant qui apparaît, sélectionner l'option Modifier… ; cela afficher la boîte de dialogue « Modifier le style ».

La première page de cette boîte de dialogue permet de modifier la fonte et la composition générale (justifié, centré, en drapeau). Si vous cliquez sur le menu déroulant Format en bas à gauche, cela permet d'afficher d'autres pages, qui permettent d'utiliser des options plus poussées :

  • Police : tous les paramètres de la fonte ;
  • Paragraphe : permet de toucher aux retraits, blancs (sauts de ligne) et interlignes ;
  • Numérotation : permet de définir le style de numérotation d'une liste, mais aussi la puce d'une liste à puce (par exemple remplacer le • par un –).

Il faut « jouer un peu » avec tous ces paramètres pour se familiariser avec.

Par exemple pour la page Paragraphe :

  • composition en sommaire : dans la zone « Retrait », cliquer sur le menu déroulant De 1re ligne et choisir l'option négatif :, puis mettre une valeur (par exemple 1 cm) dans le champ De : ;
  • composition en alinéa : comme ci-dessus, mais choisir l'option Positif.

Pour la page Numérotation :

  • choisir l'onglet correspondant au type de liste, et dans la page sélectionner l'option qui convient ;
  • pour choisir un autre type de puce, choisir une des options de l'onglet Avec puces, puis cliquer sur Personnaliser ; on peut choisir un des 6 caractères de la liste « Puces à utiliser », mais on peut aussi remplacer un de ces caractères grâce au bouton Caractère.

On peut ainsi introduire une numérotation automatique des titres.

Si l'on se place sur la table des matières, on peut modifier les styles TM1, TM2 et TM3 qui sont les styles utilisés pour afficher cette tables. On ne peut pas sélectionner ces styles directement.

Avec Microsoft Office Word 2007[modifier | modifier le wikicode]

Choix d'un style[modifier | modifier le wikicode]

Autres styles[modifier | modifier le wikicode]

Modifier un style[modifier | modifier le wikicode]


Quelques bonnes habitudes à prendre < | Index | Listes et tableaux >