Initiation à BRL-CAD/Prototypage rapide avec MGED

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche

Interface[modifier | modifier le wikicode]

Fenêtre de commande de MGED sous Microsoft Windows XP
Fenêtre graphique de MGED sous Microsoft Windows XP

MGED comporte deux fenêtres :

  • un interpréteur de commande en ligne (shell), appelée Command Window ;
  • une fenêtre graphique montrant le dessin en cours, appelée Graphics Window.

Le deux fenêtres disposent d'une barre de menus située en haut ; les deux sont équivalentes, elles donnent accès aux mêmes commandes qui donnent les mêmes effets.

Créer un projet[modifier | modifier le wikicode]

Dans la barre de menu d'une des fenêtres, il faut choisir le menu File | New, puis taper le chemin d'accès et le nom du fichier. L'interface ne propose pas pour l'instant de bouton permettant de naviguer jusqu'au répertoire de destination.

Un boîte d'information File Created s'affiche, indiquant que la création s'est bien passée :

The new database C:/.../projet.g was successfully created.
Untitled MGED Database (units=mm)

Il faut cliquer sur le bouton OK pour continuer.

Créer une forme primitive[modifier | modifier le wikicode]

Pour créer une forme primitive, on utilise le menu Create :

  • Arbs : polyèdres
    • Arb8... à Arb4... : voir Concepts de base > Primitives élémentaires par défaut,
    • rpp... (rectangular parallelepiped, parallélépipède rectangle) : crée un cube (similaire à Arb8),
    • Arbn... : crée un cube dont deux sommets opposés sont tronqués (donc un polyèdre à 12 sommets, arb12) ;
  • Cones & cylinders : cônes et cylindres
    • rcc... : cylindre,
    • rec... : cylindre section droite elliptique,
    • rhc... : cylindre de section droite hyperbolique,
    • tec... : cône tronqué de section droite elliptique,
    • tgc... : cône de section droite elliptique variable, les grands axes des sections extrêmes étant perpendiculaires,
    • trc... : cône tronqué de de section droite circulaire ;
  • Ellipsoids : ellipsoïdes
    • ehy... : hyperboloïde de section droite elliptique,
    • ell... : ellipsoïde « dragée »,
    • ell1... : ellipsoïde de révolution « ballon de rugby »,
    • epa... : paraboloïde de section droite elliptique,
    • sph... : sphère.

Dans la boîte de dialogue Enter Primitive Name qui apparaît, il faut entrer le nom de l'objet créé, puis valder avec Apply.

Modifier la vue[modifier | modifier le wikicode]

Par défaut, un clic avec le bouton principal de la souris donne une vue générale (zoom arrière), et un clic avec le bouton secondaire un gros plan (zoom avant). Un clic avec la molette (bouton central) centre la figure : le point où l'on clique devient le centre de l'image affichée.

Si l'on maintient les touches Ctrl+Maj appuyées, on effectue un zoom avant et zoom arrière avec la souris : un glisser-lâcher vers la droite ou le haut provoque un gros plan (zoom avant), un glisser-lâcher vers la gauche ou le bas provoque une vue d'ensemble (zoom arrière).

Si l'on maintient appuyée la touche Maj (shift), on déplace la vue par glisser-lâcher, quel que soit le bouton avec lequel on clique. Si l'on maintient les touches Maj+Alt, on ne translate la figure que selon un seul axe :

  • bouton principal : translation selon l'axe x ;
  • bouton central (molette) : translation selon l'axe y ;
  • bouton secondaire : translation selon l'axe z.

Si l'on maintient appuyée la touche Ctrl, on fait tourner la vue par glisser-lâcher, quel que soit le bouton avec lequel on clique.

Si l'on maintient les touches Ctrl+Alt, on ne fait tourner la figure qu'autour d'un seul axe :

  • bouton principal : rotation autour de l'axe x ;
  • bouton central (molette) : rotation autour de l'axe y ;
  • bouton secondaire : rotation autour de l'axe z.

Le menu View permet d'accéder aux vues standard :

  • Top : vue de dessus ;
  • Bottom : vue de dessous ;
  • Front : vue de face ;
  • Rear : vue arrière ;
  • Right : vue de droite ;
  • Left : vue de gauche ;
  • az35, el25 et az45, el45 sont des vues en perspective : ce sont les angles de rotation de la vue en degrés (azimut et élévation).

Enfin, on peut mettre en rotation continue la vue :

  • en appuyant sur la touche x, on tourne autour de l'axe horizontal de l'écran ; plus on appuie sur la touche, plus la rotation s'accélère ; on ralentit la rotation et on l'inverse avec Maj+x ;
  • avec y et Maj+y, on fait tourner autour de l'axe vertical de l'écran ;
  • avec z et Maj+z, on fait tourner autour de l'axe perpendiculaire de l'écran.

Modifier et déplacer une forme primitive[modifier | modifier le wikicode]

Pour modifier et/ou déplacer une forme primitive, il faut passer en mode édition :

  • dans le menu Edit, sélectionner Primitive Selection... ;
  • la boîte de dialogue Primitive Selection Menu liste les primitives créées ; double-cliquer sur la primitive modifier ; le dessin de la primitive dans la fenêtre graphique apparaît en blanc.

Pour effectuer une modification, il faut aller dans le menu Edit puis sélectionner l'action à faire.

Quel que soit l'option prise, le clic avec le bouton principal ou secondaire a l'effet habituel : modification de l'échelle de vue (zoom avant ou arrière) sans modification de l'objet. Le clic avec des touches enfoncées a un effet similaire à la modification de vue, sauf que l'on modifie la primitive :

  • si l'on maintient les touches Ctrl+Maj appuyées, on agrandit ou on réduit la taille de l'objet ;
  • si l'on maintient appuyée la touche Maj, on déplace l'objet ;
  • si l'on maintient les touches Maj+Alt, on ne translate la primitive que selon un seul axe :
    • bouton principal : translation selon l'axe x,
    • bouton central (molette) : translation selon l'axe y,
    • bouton secondaire : translation selon l'axe z ;
  • si l'on maintient appuyée la touche Ctrl, on fait tourner la primitive par glisser-lâcher, quel que soit le bouton avec lequel on clique ;
  • si l'on maintient les touches Ctrl+Alt, on ne fait tourner la primitive qu'autour d'un seul axe :
    • bouton principal : rotation autour de l'axe x,
    • bouton central (molette) : rotation autour de l'axe y,
    • bouton secondaire : rotation autour de l'axe z.

Par contre, c'est l'effet du clic avec le bouton central (molette) de la souris qui est modifié par l'option.

Lorsqu'il s'agit d'un paramètre numérique, comme l'échelle ou une dimension (par exemple la hauteur), alors :

  • si l'on clique dans la zone supérieur de l'image, le paramètre sélectionné augmente ;
  • si l'on clique dans la zone inférieure de l'image, le paramètre sélectionné diminue ;

MGED affiche un point blanc pour de repérer centre de l'image. Plus la position de la souris est éloignée de la ligne médiane, plus le paramètre varie vite.

Lorsqu'il s'agit d'un vecteur dont on modifie aussi l'orientation, le vecteur suit la position du pointeur de la souris lorsque l'on clique avec le bouton central.

On peut éditer ainsi tous les paramètres. Par exemple, pour un cylindre droit de section circulaire :

  • modifier la hauteur H en bougeant la base (V), l'extrémité (C, D) ;
  • modifier la section (transforme la figure en cône elliptique tronqué) en modifiant A, B, C ou D ;
  • modifier le rayon en restant à section circulaire (Set A,B,C,D).

Pour ce qui est de la rotation de l'axe H (cylindre incliné) ou des faces A, B (troncature en biais), il faut utiliser la combinaison Ctrl et glisser-lâcher.

Un fois les modifications faites, on sort du mode d'édition :

  • en annulant les modifications : menu Edit | Reject ;
  • en validant les modifications : menu Edit | Accept.

Créer une combinaison[modifier | modifier le wikicode]

Pour créer une combinaison, il faut avoir recours à la ligne de commande. Pour définir un objet comb1.s, il faut taper

comb comb1.s ...

Les points de suspension sont replacés par la noms des formes primitives précédées de l'opération qu'on leur attribue (notation préfixée). La première forme primitive est toujours précédée d'un « u ». La deuxième primitive est précédée de :

  • « u » si l'on veut unir les formes, les fusionner ;
  • « - » si l'on veut évider la première forme avec la seconde.

Par exemple, pour fusionner objet1.s et objet2.s :

comb comb1.s u objet1.s u objet2.s

pour enlever objet2.s de objet1.s :

comb comb1.s u objet1.s - objet2.s

Si l'on veut créer une région, on utilise la commande r en lieu et place de la commande comb :

r comb1.r u objet1.s u objet2.s
r comb2.r u objet1.s - objet2.s

Exemple[modifier | modifier le wikicode]

Cuvette dans un cube : vue de face (haut gauche), de dessus (bas à gauche), perspectives (droite)

On veut créer un support pour un objet à fond sphérique, et pour cela enlever une calotte de sphère à un cube. On va dans le menu File | New… et l'on crée la base de données test.g.

On commence par créer un cube et une sphère avec les options du menu Create | Arbs | Arb8 et Create | Ellipsoids | Sph. On donne le nom cube.s au cube et sphere.s à la sphère. Il faut faire un zoom arrière en cliquant sur le bouton principal de la souris pour voir la figure en entier. On remarque que la le centre de la sphère est au milieu du cube ; par ailleurs, la sphère est en rouge alors que le cube est en blanc.

L'étape suivante est de déplacer la sphère. Pour cela :

  • aller dans le menu Edit | Accept : cela sort du mode d'édition du cube ;
  • aller dans le menu Edit | Primitive selection, et dans la boîte de dialogue Primitive Selection qui s'affiche, double-cliquer sur sphere.s ;
  • sélectionner la vue de face avec le menu View | Front ;
  • sélectionner l'option du menu Edit | Translate ;
  • faites un glisser-lâcher en maintenant la touche Maj du clavier enfoncé, jusqu'à ce qu'il ne reste plus qu'environ 1/4 du rayon dans le cube ; ;
  • aller dans le menu Edit | Accept : cela sort du mode d'édition de la sphère ;
  • on se replace à la bonne échelle avec View | Default, puis en perspective avec le menu View | az35, el25.

On crée la combinaison en tapant dans la fenêtre de commande

mged> r support.r u cube.s - sphere.s

la sphère s'affiche alors en pointillés.

Enfin, on génère une image volumique :

  • dans la fenêtre de commande, il faut effacer les objets et ne laisser que la région ; pour cela, taper
mged> B support.r
  • on va dans le menu File | Raytrace ;
  • dans la boîte de dialogue Raytrace Control Panel qui apparaît, on clique sur le bouton Raytrace.

Notes[modifier | modifier le wikicode]



Prototypage rapide avec Archer < > Éléments de géométrie