Programmation JEE/Configurer Eclipse

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche

Eclipse[modifier | modifier le wikicode]

Eclipse-SVG.svg

Eclipse est un environnement de développement intégré (EDI), générique et extensible (site officiel http://www.eclipse.org). Son système de plugins permet d'ajouter des fonctionnalités diverses.

Initialement prévu pour développer en Java, grâce aux plugins il peut maintenant également gérer des projets développés avec d'autres langages de programmation tels que :

  • Le C et le C++ grâce à l'ensemble de plugins CDT (C Development Toolkit)[1] (compilateur non intégré).
  • Le Python via PyDev[2].
  • Avant l'arrivée d'Android Studio, le développement pour Android se faisait avec Eclipse grâce à l'ensemble de plugins ADT (Android Development Toolkit).

Certains IDE sont basés sur Eclipse, et permettent par exemple le développement de logiciel embarqués pour des systèmes temps réel.

Installation de Eclipse[modifier | modifier le wikicode]

La page de téléchargement d'Eclipse permet de récupérer une version déjà adaptée au langage ciblé sur http://www.eclipse.org/downloads/. Mais pour installer un plugin manuellement, il faut :

  • Lancer Eclipse, puis dans le menu déroulant :Help>Software Updates>Find and Install...
  • Cocher Search for new features to install, bouton Next. Bouton New Remote Site..., entrer l'adresse de téléchargement :
Name: Nom du plugin
URL: adresse du plugin, ex : http://www.eclipse.org/cdt/downloads.php
  • Bouton Finish, choisir un miroir proche puis continuer l'installation.

Utilisation de Eclipse[modifier | modifier le wikicode]

L'interface de l'IDE Eclipse est basée sur différentes perspectives. Une seule perspective n'est visible à la fois, et se compose de plusieurs vues. Exemples :

  • La perspective "Java" se compose par défaut de la vue "Package Explorer", de la vue éditeur de code en Java avec un onglet par fichier ouvert, de la vue "Outline" donnant la hiérarchie des éléments composant la classe du fichier ouvert.
  • La perspective "Debug" est ouverte automatiquement au lancement d'une application en mode débogage et se compose par défaut de la vue "Debug" affichant la pile d'appel, de la vue des points d'arrêt nommée "Breakpoints", de la vue éditeur de code en Java avec un onglet par fichier ouvert, de la vue "Outline" donnant la hiérarchie des éléments composant la classe du fichier ouvert.

Chaque vue est une sous-fenêtre qui a un titre et se place dans un cadre particulier de la fenêtre de l'IDE. Plusieurs vues peuvent partager le même cadre, auquel cas, un barre d'onglets permet de basculer entre les vues. Un double clic sur le titre d'une vue provoque l'affichage du cadre qui la contient en pleine fenêtre, réduisant les autres cadres à une icône sur les côtés. Un second double clic restaure les cadres.

Le menu "Window" permet de changer de perspective, et d'ajouter des vues à la perspective courante. Une vue peut également être retirée de la perspective affichée en utilisant la croix à droite du titre de la vue.

Eclipse


Apache Tomcat[modifier | modifier le wikicode]

Sa version Helios se configure facilement pour travailler avec un serveur Apache Tomcat 7.

Pour ce faire, il faut :

  1. Installer Tomcat sans mot de passe. Ne pas le lancer ;
  2. Installer Eclipse For Java EE Developers avec le JRE pour pouvoir l'exécuter ;
  3. Aller soit dans :
    • Window > Preferences > Server > Runtime Environments[3][4] ;
    • ou Window > Show View > Other > Server puis cliquer en bas dans la nouvelle fenêtre[5] ;
    (si Server n'est pas dans la liste, c'est que vous n'avez pas la version d'Eclipse For Java EE Developers)
  4. Ajouter Apache Tomcat en allant chercher le chemin ;
  5. Spécifier le nom à paraître, le chemin du répertoire d'installation de Tomcat sur le disque ;
  6. Laisser le JRE par défaut. Si Eclipse fonctionne, le JRE par défaut suffit.

À l'exécution du projet sous Eclipse ou au débogage, Eclipse chargera le projet dans une instance de Tomcat.

Lancement[modifier | modifier le wikicode]

Pour initier un environnement de développement JEE il faut :

  1. Cliquer droit dans le Project Explorer d'Eclipse ;
  2. Choisir New > Web > Dynamic web project.

N'hésitez pas à faire des tests dans ce répertoire mais ne touchez pas au répertoire Server, ou il faudra recommencer la procédure de configuration de Tomcat s'il est corrompu.

Pour reconfigurer Tomcat dans les préférences, il faudra alors effacer ce répertoire Server.


Références[modifier | modifier le wikicode]