Blender 3D/Les préférences utilisateur

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche
Sommaire: Blender 3D
Page suivante: La fenêtre de vue 3D

A propos des préférences utilisateur[modifier | modifier le wikicode]

Les préférences utilisateur (User preferences) vont influer sur le fonctionnement de Blender de manière générale (ou du fichier ouvert). Jusqu'à maintenant, nous pensions que Blender était par défaut divisé en deux parties : la vue 3D et la fenêtre des boutons. En fait, il y a une partie supplémentaire, masquée, au niveau des menus du haut. Ce sont les préférences utilisateur (User preferences).

Cette partie du Wikilivre a pour but de vous en expliquer les aspects.

Dérouler le panneau des préférences[modifier | modifier le wikicode]

La première fenêtre que nous allons voir en détail est celle des préférences utilisateur. Cette fenêtre est masquée par défaut car nous ne nous en servons que très rarement. Nous ne voyons que l' en-tête de ce panneau qui est en fait le menu principal de Blender en haut de l'écran (encadré ici en rouge).

Blender-user-preferences.png


Pour ouvrir les préférences utilisateurs, il suffit d'étirer la bordure sous le header vers le bas. De cette manière, son contenu apparaît.

Blender-user-preferences-open.png
Le contenu de chaque onglet permet de modifier certaines caractéristiques du logiciel (en fonction de l'onglet sélectionné). Cet espace est encadré ici en bleu.
Les onglets (encadrés ici en rouge) permettent d'accéder à des caractéristiques précises du logiciel.


L'onglet View & Controls[modifier | modifier le wikicode]

Blender-view-controls-panel.png


Boutons display[modifier | modifier le wikicode]

Intéressons-nous tout d'abord à la colonne de boutons intitulée Display (affichage).

  • Option Tool Tips : Permet l'affichage des info-bulles lorsque la souris passe sur une option (cela permet de mieux comprendre une fonctionnalité).
  • Option Object Info : Affiche le nom de l'objet sélectionné en bas à gauche de la vue 3D. Le numéro de l'image en cours est aussi affiché.
  • Option Global scene : Forcer la scène courante à être affichée dans toutes les dispositions d'écran.
  • Option Large Cursors : Utilise les grands curseurs de souris si disponible.
  • Option View Name : Cette option affiche en haut à gauche de la vue 3D le nom de la vue en cours d'utilisation (Top, Front, Right, Left, Back, Bottom, User, Camera). Cela affiche aussi le mode de vue utilisé (Ortho pour Orthographique ou Persp pour perspective). Cette option peut s'avérer assez pratique lorsqu'on débute en 3D pour se repérer et se familiariser avec les différentes vues.
  • Option Playback FPS : Cela permet de connaître le nombre d'images affichées à la seconde ("Frames Per Second") dans la vue 3D par la carte graphique lors de la pré-visualisation d'une animation. Concrètement, il est possible de savoir si notre animation est jouée en temps réel (vitesse normale) ou non. En effet, la pré-visualisation d'une animation s'effectue par la carte graphique qui n'est pas forcément à même d'afficher l'animation en temps réel (plus de notions sur l'animation sont abordées dans le chapitre correspondant).

Options Menus[modifier | modifier le wikicode]

Voyons maintenant les options autour de l'intitulé Menus.

  • Option Open on Mouse Over : Permet l'ouverture des menus par simple passage de la souris au dessus (par défaut, il faut cliquer). Cette option peut vite s'avérer gênante et il est donc préférable de ne pas l'activer.
  • Variable Top Level : Cette valeur spécifie le temps d'attente en 1/10 de seconde avant l'ouverture automatique d'un menu. Elle ne fonctionne que si l'option Open on Mouse Over est activée.
  • Variable Sublevels : Cela indique le temps d'attente en 1/10 de seconde avant l'ouverture automatique d'un sous-menu.

Toolbox click-hold delay[modifier | modifier le wikicode]

Passons aux options Toolbox click-hold delay. Elles influent sur les menus et les mini-panneaux qui peuvent apparaître sur la vue 3D

  • Variable LMB : Dans Blender, LMB veut dire Left Mouse Button (Bouton gauche de souris). Cette valeur spécifie le temps pendant lequel le clic gauche de la souris peut être maintenu avant l'ouverture du menu. Pour bien la comprendre, maintenez le clic gauche enfoncé dans le vue 3D pendant quelques secondes, un menu apparaîtra automatiquement. Vous pouvez donc augmenter ou baisser le temps d'attente (valeur en 1/10 de seconde). On verra plus tard qu'un raccourci clavier permet l'affichage de ce menu.
  • Variable RMB : Cette valeur a le même fonctionnement que LMB mais avec le clic droit.
  • Option Pin Floating Panel : Permet de se rappeler de l'emplacement des mini-panneaux flottant dans la vue 3D. Par exemple, placez votre curseur dans la vue 3D et entrez N. Un petit panneau flottant apparaît. Ré-entrez N pour le faire disparaître. Déplacez ensuite votre souris dans la vue 3D à un autre endroit et entrez de nouveau N. Le panneau est ré-apparu à l'endroit où il avait disparu. Si vous décochez Pin Floating Panel, vous constaterez que le panneau apparaîtra là ou est votre curseur et non à son dernier emplacement.
  • Option Plain Menus : Modifie l'affichage des menus. Cliquez droit dans la vue 3D suffisamment longtemps pour faire apparaître le menu de tout à l'heure. Observez son agencement. Décochez Plain Menus et renouvelez l'opération. Vous constaterez que la disposition du menu aura changé.

Snap to grid[modifier | modifier le wikicode]

Regardons la colonne de boutons Snap to grid (coller à la grille). Cette option permet d'aimanter des opérations sur les objets sur les points d'intersection de la grille. Ainsi, les modifications seront contraintes sur une unité Blender.

  • Option Grab/Move : L'option de déplacement est automatiquement aimantée à la grille.
  • Option Rotate : La rotation d'un objet sera aimantée à la grille
  • Option Scale : L'outil d'échelle sera aimanté à la grille.

Cependant, une autre option dans Blender (qui sera vue lors de la manipulation des objets) permet d'aimanter ponctuellement une transformation sur la grille. Il est donc préférable de laisser ces options contraignantes désactivées et d'utiliser l'outil aimant ponctuel.

View zoom[modifier | modifier le wikicode]

Les options autour de View zoom paramètrent la manière d'agrandir dans la vue 3D.

  • Option Zoom to Mouse Position : Lorsqu'elle est activée, cette fonction indique que le Zoom agit vers l'emplacement du pointeur. En effet, par défaut Blender agrandit vers le centre de la vue 3D en elle-même.

View rotation[modifier | modifier le wikicode]

  • Multi-choix Trackball/Turntable : À rédiger
  • Option Auto Perspective : Cette option permet de passer automatiquement du mode Orthographic au mode Perspective lors de la rotation de la vue 3D et de repasser automatiquement en mode Orthographic sur les vues de bases (dessus, face, coté...). Cela s'avère relativement pratique pour visionner rapidement une perspective réelle.
  • Option Around Selection : En cochant cette case, la rotation de la vue 3D s'effectue autour du centre de l'objet sélectionné. Par défaut, la rotation s'effectue autour du système d'axes de la vue 3D.
Différence entre Orthographic et Perspective dans Blender
A gauche, rotation avec Auto perspective actif, à droite, rotation sans Auto perspective

Select with[modifier | modifier le wikicode]

Cette partie indique avec quel clic de la souris vous sélectionnerez vos objets. Par défaut, on sélectionne les objets avec le clic droit. Cependant, il est vrai que dans les autres logiciels tel que 3D Studio Max ou Maya, la section se fait avec le clic gauche. Il est possible d'inverser le comportement de Blender en cochant Left Mouse (gauche) ou Right Mouse (droit) selon que vous souhaitiez sélectionner vos objets avec le clic gauche ou droit.

Sous ces deux options, une information Cursor with est présente. Cela vous indique avec quel clic vous déplacerez le curseur 3D. Si Right Mouse est coché, ce sera le clic gauche (Left Mouse en face de Cursor with) qui déplacera le curseur 3D. Sinon, c'est l'inverse. Le curseur 3D est un outil propre à Blender qui sera étudié lors de la manipulation des objets.

Options d'émulation des boutons[modifier | modifier le wikicode]

Deux options permettent d'émuler certaines actions :

  • Option Emulate 3 Button Mouse : Si vous utilisez un ordinateur portable ou une souris deux boutons, Blender est capable d'émuler le clic milieu (très important dans la manipulation de la vue 3D). S'il est coché, le clic milieu pourra être émulé par la combinaison ALT+Clic gauche.
  • Option Paste on MMB : Par défaut, lorsque vous maintenez le clic milieu enfoncé en déplaçant votre souris dans la fenêtre d'éditeur de texte, Blender fait défiler le texte. Cependant, si vous faites un peu de développement (Python par exemple), le clic milieu peut se transformer en raccourci coller le texte ce qui évite de passer par les menus.

Le mini-axis[modifier | modifier le wikicode]

Le mini axis de Blender
Le mini-axis

Par défaut, en bas à gauche de la vue 3D, vous constaterez un mini repère. Il est possible de le paramétrer au niveau du bouton Mini Axis.

  • Option Mini Axis : Affiche ou masque le repère.
  • Variable Size : Permet de modifier la taille du mini-repère.
  • Variable Bright : Vous pouvez accentuer ou non la luminosité du repère avec une valeur allant de 0 à 10.

Middle Mouse Button[modifier | modifier le wikicode]

Deux options sont présentes sous Middle Mouse Button qui influeront sur le comportement du clic milieu dans la vue 3D. Par défaut, c'est Rotate View qui est coché ce qui veut dire que lorsque vous effectuerez un clic milieu dans le viewport, la vue tournera. Pour déplacer la vue, il faudra maintenir SHIFT+Clic milieu. Si vous sélectionnez Pan View au lieu de Rotate View, le maintien du clic milieu dans le viewport déplacera la vue. Il faudra donc maintenir SHIFT+Clic milieu pour effectuer la rotation de la vue 3D (c'est le mode de fonctionnement de 3D Studio Max).

Mouse Wheel[modifier | modifier le wikicode]

Ces deux paramètres modifient le fonctionnement de la molette.

  • Option Invert zoom : Cela a pour résultat d'inverser le zoom avec la molette. En tournant la molette vers le haut, la vue 3D sera dé-zoomée. En tournant la molette vers le bas, elle sera agrandie.
  • Variable Scroll Lines : À rédiger

Smooth view et Rotation Angle[modifier | modifier le wikicode]

  • Option Smooth view : Ceci permet de faire une transition animée entre les vues standards (Dessus, Face, Coté, Caméra...). Plus la valeur sera haute, meilleure sera la transition. Cette fonction est pratique pour ne pas perdre ses repères dans l'espace 3D lorsqu'on débute. Par contre, ça utilise plus les ressources de la carte graphique. Une valeur de 600 est correcte.
  • Option Rotation Angle : Spécifie l'incrément de rotation lorsqu'on utilise les touches 4, 8, 6 et 2 pour la rotation du viewport.

3D Transform Widget[modifier | modifier le wikicode]

Le widget est le repère qui se situe sur les objets sélectionnés. Il en existe 3 types : Déplacement, rotation et échelle. Ceux-ci sont abordés en détail dans la partie sur les objets. Les options autour de 3D Transform Widget permettent de modifier leur affichage.

  • Variable Size : Permet d'augmenter ou réduire la taille de Widget (la valeur est spécifiée en 10 pixels)
  • Variable Handle : Modifie la taille des poignées. La valeur est spécifiée en pourcentage de la variable Size précédente.
  • Variable Hotspot : Modifie la taille de la zone cliquable (zone à partir de laquelle le widget est sélectionné par un clic gauche). Plus la valeur est importante, plus on pourra cliquer loin autour du widget pour l'utiliser. C'est en quelque sorte une zone d'erreur.
  • Variable Object Center Size : La taille du centre des objets.

L'onglet Edit Methods[modifier | modifier le wikicode]

Blender-edit-method-panel.png

Champ Add new objects[modifier | modifier le wikicode]

Les deux options dessous Add new objects paramètrent la manière dont sont insérés les nouveaux Objets.

  • Option Switch to Edit Mode : Permet de basculer automatiquement en mode édition lors de l'ajout d'un nouvel objet (voir le chapitre sur le mode édition).
  • Option Aligned to View : Les nouveaux objets sont insérés face au point de vue au lieu d'être alignés sur la grille.

Undo (annuler)[modifier | modifier le wikicode]

Ces informations permettent de paramétrer l'historique d'un fichier.

  • Variable Steps : C'est le nombre d'actions que Blender doit retenir en historique. Plus vous augmenterez cette valeur, plus vous aurez besoin de mémoire pour l'historique.
  • Variable Memory Limit : Ce champ indique la quantité de mémoire à consacrer à l'historique (valeur en Mégaoctets). La valeur 0 signifie qu'il n'y a pas de limite.
  • Option Global Undo : Cela permet d'annuler les opérations en mode objet (voir le chapitre sur le mode objet). Cela crée une copie du fichier dans la mémoire de manière à pouvoir y revenir en utilisant la combinaison de touches CTRL+Z. Bien sûr, cette option prend de la place en mémoire, mais en la décochant, vous ne pourrez annuler que les opérations en mode édition.

Auto Keyframe[modifier | modifier le wikicode]

Ces options paramètrent le comportement de Blender lors de l'ajout d'images clés.

  • Option Auto-Keying Enabled : À rédiger
  • Option Available : Si cette option est cochée, Blender n'ajoutera des clés en mode automatique que sur les courbes déjà existantes. Par exemple, si j'ai réalisé une animation avec ajout de clés manuellement sur le déplacement, avec l'option Available cochée, il sera impossible d'ajouter des clés sur la rotation en mode automatique car la rotation n'aura pas encore de courbe. Il faudra donc créer la courbe au préalable.
  • Option Needed : Avec cette option Blender ne créera les clés en mode automatique que là où c'est nécessaire. Par exemple, si je déplace mon objet en mode clé automatique, Blender ajoutera uniquement les clés de déplacement. Par défaut, il aurait aussi ajouté les clés de rotation et d'échelle.
  • Option Use Visual Keying: À rédiger

Grease Pencil[modifier | modifier le wikicode]

Nouveauté Blender 2.48 Le Grease Pencil
L'option Smooth Stroke
A gauche, un S tracé à la souris sans le Smooth Stroke. A droite, le même S avec le Smooth Stroke actif.

Le Grease Pencil est une nouveauté de Blender 2.48. Il permet de dessiner sur la vue 3D à la main pour réaliser des croquis dans la vue, annoter une forme puisqu'il est possible de dessiner en 2D mais aussi en 3D. Cet outil est relativement pratique pour des projets collaboratifs. De plus, le Grease Pencil est entièrement animable ce qui permet de réaliser des animatics dans la vue 3D. Blender est le seul outil 3D possédant cette fonction.

En plus des animateurs qui peuvent s'en servir pour les poses clés et les courbes d'animation, le Grease Pencil peut aussi être utile dans nombre de cas tel que la planification de la topologie ou du layout, un outil de correction pour les éducateurs...

Voyons les fonctions qui peuvent être modifiées dans le panneau de préférences :

  • Variable Euclidean : Cela spécifie l'espace parcourue par la souris avant d'afficher un nouveau trait. Plus la valeur est faible, plus le trait sera affiché en temps réel et avec précision. Cette option peut être intéressante si vous avez une carte graphique de faible puissance.
  • Variable Manhatten Dist : À rédiger
  • Variable Eraser Radius : Cette valeur spécifie le rayon de la gomme du pinceau.
  • Option Smooth Stroke : Cette option adoucira automatiquement le dessin en arrondissant les courbes dues à l'imprécision des souris (voir le schéma).


Duplicate with object[modifier | modifier le wikicode]

Les options à cocher au niveau de Duplicate with object spécifient à Blender quelles données il faut créer de nouveau pour l'objet dupliqué (= quelles informations seront propres à l'objet dupliqué et lesquelles seront communes aux deux objets).

  • Option Mesh : Lorsque coché, les objets de type Mesh dupliqués généreront un nouveau type d'objet. Si vous décochez cette option, tous vos nouveaux Mesh dupliqués partageront les mêmes caractéristiques de forme. Il seront dupliqués en instance (c'est à dire que si vous en modifiez un, vous les modifiez tous)
  • Option Surface : Idem que pour l'option Mesh mais appliquée aux Surfaces
  • Option Curve : Idem que pour l'option Mesh mais appliquée aux Curves
  • Option Text : Idem que pour l'option Mesh mais appliquée aux Texts
  • Option Metaball : Idem que pour l'option Mesh mais appliquée aux Metaballs
  • Option Armature : Idem que pour l'option Mesh mais appliquée aux Armatures
  • Option Lamp : Idem que pour l'option Mesh mais appliquée aux Lamps
  • Option Material : Si vous cochez cette option, Blender recréera un nouveau matériau (une copie de l'ancien) pour chaque nouvel objet dupliqué. Par défaut, lorsque vous dupliquez un objet, Blender associe le même matériau à l'objet d'origine qu'à l'objet dupliqué
  • Option Texture : Idem que pour l'option Material appliquée aux Textures
  • Option Ipo : Idem que pour l'option Material appliquée aux courbes d'animation

Notez que ces options ne figent pas le mode de fonctionnement de Blender. Il est naturellement possible de casser des liens entre des objets, des matières, des courbes d'animations... ou de les récréer à n'importe quel moment.

L'onglet Language & Font : Traduire l'interface[modifier | modifier le wikicode]

Blender-language-font-panel.png

C'est dans cette partie qu’il va être possible de traduire l’interface de Blender ou de modifier la police par défaut (en cas de problème d'affichage). Par défaut, il n’y a qu’une seule option visible : International Fonts. Si vous cochez cette fonction, de nouveaux boutons apparaissent.

  • Bouton Select Font : Ce bouton ouvre un navigateur qui vous permet de sélectionner un police de caractères spécifique pour remplacer la police par défaut. Cela peut être utile en cas de défaillance de l'affichage des textes dans Blender.
  • Bouton Restore to default : Si vous voulez réinitialiser les paramètres modifiés, il vous suffit de cliquer sur ce bouton.
  • Menu Font Size : Si vous souhaitez agrandir ou réduire la taille des caractères, vous pouvez sélectionner une taille de police dans ce menu.
  • Menu Language : C'est grâce à ce menu que vous pouvez traduire Blender en français. Il vous suffit de sélectionner Language: French dans la liste et de cocher les options Tooltips (traduire les bulles d'aide), Buttons (traduire les boutons) et Toolbox (traduire les boîtes à outils). Blender est le seul logiciel 3D professionnel proposant autant de langues (dont le français). Cependant, ces traductions sont incomplètes (bien que la traduction française soit assez avancée). Par ailleurs, excepté pour les anglophobes les plus acharnés, il est préférable de conserver l'interface en anglais car nombre de fonctionnalités sont intraduisibles (termes techniques) et la majeure partie des tutoriels utilisent la version anglaise de Blender (dont ce wikilivre).
  • Option Use Textured Font : Cette option lisse les polices. Cependant, cela peut devenir gênant (flou) et il peut être préférable de la désactiver.

L'onglet Themes : Modifier les couleurs par défaut[modifier | modifier le wikicode]

Blender-theme-panel.png


Dans le cas ou vous n'apprécieriez pas les couleurs par défaut de Blender et son apparence globale, il est possible de tout personnaliser grâce à l'onglet Themes. Lorsque vous cliquez sur cet onglet, très peu d'options semblent présentes en apparence.

Utiliser un thème existant[modifier | modifier le wikicode]

La version officielle de Blender (série 2.4x) à deux thèmes par défaut enregistrés. Il vous suffit de dérouler le menu Default (le nom de thème par défaut) pour accéder à la liste des thèmes déjà enregistrés dans le fichier de configuration. Vous pouvez alors accéder à Rounded qui est en fait une reprise de l'interface de Modo (logiciel 3D). Les couleurs changent alors complètement ainsi que la forme des boutons.

Installer un thème téléchargé[modifier | modifier le wikicode]

Charger la fenêtre des scripts
Charger la fenêtre des scripts

Si les deux thèmes par défaut ne vous conviennent pas et que vous ne souhaitez pas en créer un de toutes pièces, il vous est possible de les télécharger sur internet. Le site http://www.graphicall.org/themes recense quelques thèmes. Pour pouvoir les installer, téléchargez le fichier Python qui leur est associé.

Placez le fichier .py téléchargé dans le dossier /scripts de votre répertoire .blend de configuration.

  • Sous Linux : dans /home/VOTRE-NOM/.blender/scripts. Affichez les fichiers cachés pour voir le dossier /.blender
  • Sous Windows : dans le dossier scripts du répertoire d'installation (par défaut C:\Program files\Blender Foundation\Blender\.blender\scripts)
  • Sous Mac OS X : Ouvrez le fichier d'application Blender (Clic droit > afficher le contenu du paquet). Placez le script dans Contents/MacOS/.blender/scripts (le dossier .blender n'est visible que si vous activez les fichiers cachés).

Une fois les scripts copiés dans le dossier correspondant, ouvrez Blender et chargez la fenêtre des scripts' (scripts window) à la place de la vue 3D par exemple (voir capture écran, reportez vous au chapitre Système de fenêtres de Blender pour plus d'information sur le chargement de fenêtres).

Dans la fenêtre des scripts, rendez vous dans le menu Scripts (accessible au niveau de l'en-tête de la fenêtre). Si vous allez dans le sous menu Themes, votre thème téléchargé devrait apparaître. Si ce n'est pas le cas, sélectionnez Update Menus et renouvelez l'opération. Une fois que vous aurez sélectionné le nouveau thème, il prendra la place de l'ancien.

Créer son propre thème/personnaliser un thème existant[modifier | modifier le wikicode]

Sous le menu des thèmes se trouve un bouton Add. En cliquant dessus, vous créerez une copie du thème en cours d'utilisation que vous pourrez nommer puis éditer. Il est aussi possible d'éditer les thèmes existants (à l'exception du thème par défaut).

La première boîte de texte vous permet de définir le nom de votre nouveau thème (par défaut après avoir cliqué sur Add, la valeur est New user theme).

Sous la boîte texte, un premier menu déroulant vous indique quelle fenêtre vous éditez (il est possible de changer les couleurs de chaque fenêtre de Blender indépendamment les unes des autres). Vous trouverez aussi dans ce menu UI and buttons qui édite l'apparence des menus et des boutons et Bone and color set qui modifie les presets de couleurs par défaut des armatures.

Sous ce premier menu se situe un second menu qui vous indique quel élément de la fenêtre vous éditez. Il y a des éléments génériques tel que Header, Panel, Text, Background... mais aussi des éléments propres à la fenêtre sélectionnée dans le premier menu (Grid pour la vue 3D, RVK Sliders pour l'éditeur d'action...). Lorsque vous avez sélectionné Bone and color set dans le premier menu, ce second menu est remplacé par une variable Color set qui spécifie le numéro du preset sur lequel vous travaillez.

La troisième colonne vous permet de sélectionner la couleurs ou le type correspondant à l'élément sélectionné dans le second menu.

Enfin, en dernière position, un outil vous permet de copier une couleur dans le cache et de la coller ultérieurement pour un autre élément (pratique pour uniformiser une interface). Blender avant et après un nouveau thème

Changer le thème des icônes[modifier | modifier le wikicode]

Depuis Blender 2.43, il est possible de modifier les icônes par défaut de l'interface. Dans un premier temps, téléchargez une image de thème icônes pour Blender (Andrzej Ambroż ( alias Jendrzych) a réalisé plusieurs thèmes assez aboutis sur le forum BlenderArtists http://blenderartists.org/forum/showthread.php?t=84971). Ce sont en fait des grandes images au format PNG qui contiennent toutes les icônes de Blender.

Créez un dossier /icons dans le répertoire de configuration /.blender (référez vous au titre Installer un thème téléchargé de ce même chapitre pour connaitre l'emplacement du dossier /.blender. Placez l'image téléchargée dans le dossier nouvellement créé.

Dans l'onglet Themes du panneau des préférences utilisateur, sélectionnez l'élément UI and Buttons dans le premier menu déroulant et Icon File dans le second. Vous n'avez plus qu'à sélectionner votre image dans le menu déroulant apparu à droite. Si votre image ne paraît pas dans ce menu, vérifiez que c'est une image PNG pour Blender, qu'elle est placée dans le bon dossier et relancez Blender de nouveau.

Future fonctionnalité de Blender 2.50 Le future thème icône par défaut

L'interface de Blender sera intégralement repensé pour la future version majeure, la 2.50. Pour cette occasion, un des sets d'icônes de Andrzej Ambroż a été retenu pour remplacer les vieilles icônes Blender. Le développement de ces icônes sera donc lié au projet Blender.


Supprimer un thème[modifier | modifier le wikicode]

Si vous souhaitez supprimer un thème de votre liste, cliquez sur Delete sous le bouton Add.

Les contributions sur ce Wikilivre[modifier | modifier le wikicode]

Ce Wikilivre est rédigé par plusieurs utilisateurs. De ce fait, il se peut que les thèmes d'interface ne soient pas les mêmes sur certaines pages que sur d'autres car le contributeur peut avoir changé son interface. Cependant, les noms des fonctions restent les mêmes et c'est l'important.

L'onglet Auto Save : Paramétrer les sauvegardes[modifier | modifier le wikicode]

Blender-auto-save-panel.png


Blender est capable de créer des fichiers temporaires de Backup et d'enregistrer plusieurs versions d'un même fichier. C'est naturellement pratique en cas de plantage du système ou de Blender (récupération des données perdues) ou en cas de fichiers altérés (travailler sur une version antérieure du fichier). C'est totalement automatique une fois configuré.

  • Variable Save Version : Ceci indique le nombre de version possible d'un même fichier lorsque vous enregistrez un fichier manuellement. Par exemple, si vous passez la valeur à 3, Blender créera le fichier courant (monFichier.blend) mais aussi 3 versions d'historique au cours des sauvegardes (monFichier.blend1, monFichier.blend2, monFichier.blend3). Le fichier le plus récent étant monFichier.blend et le plus vieux monFichier.blend3. En fait, Blender créera une copie supplémentaire à chaque enregistrement d'un fichier.
  • Option Auto Save Temp Files : En cochant cette option, Blender créera un fichier temporaire de Backup enregistré automatiquement. Pour spécifier le temps entre chaque sauvegarde automatique du fichier Backup, modifiez la variable Minutes juste sous l'option.
  • Bouton Open Recent : Si un jour, Blender ou votre système plante, peu de travail sera en fait perdu (si vous avez activé Auto Save Temp Files avec une valeur Minutes raisonnable). Il vous suffira de cliquer sur ce bouton pour réouvrir la dernière sauvegarde.
  • Variable Recent Files : Spécifie le nombre de fichiers à placer dans l'historique du menu File > Open Recent.
  • Option Save Preview Images : en cochant cette option, Blender enregistrera dans le fichier les aperçus tels quels, les matériaux, les rendus Viewer des nodes, les textures... Le point positif est qu'à la prochaine ouverture de Blender, les aperçus n'auront pas besoins d'être calculés lorsque vous consulterez les panneaux se servant d'aperçus. Le point négatif est que les fichiers seront plus lourds car ils stockeront des images.

L'onglet System & OpenGL : Les paramètres graphiques[modifier | modifier le wikicode]

Blender-system-openGL-panel.png


L'éclairage OpenGL de la Vue 3D (Solid OpenGL lights)[modifier | modifier le wikicode]

Les option d'une lampe OpenGL
Les options d'une lampe OpenGL

Blender vous laisse la liberté de paramétrer l'éclairage de la vue 3D en mode solide (plus d'informations sur les modes dans les chapitres à venir). Ces options ne s'appliquent qu'à la vue 3D et non au rendu final de l'image.

Blender vous laisse la possibilité de paramétrer 3 lampes virtuelles dans le viewport que vous pouvez activer ou désactiver. Chaque colonne paramètre une lampe virtuelle (voir capture écran).

  • En cochant Light, vous activez la lampe correspondante.
  • En faisant un Cliquer-glissé avec le Clique gauche de la souris sur la petite sphère, vous déplacez de manière interactive l'orientation de la lampe.
  • En modifiant les couleurs en bas de chaque colonnes, vous éditez la couleur émise par la lampe.

Les options du système[modifier | modifier le wikicode]

Ces options se trouvent au niveau de la colonne System.

  • Variable Prefetch frames : À rédiger
  • Variable MEM Cache Limit : Cette valeur spécifie la limite en mégaoctets du cache pour le séquenceur
  • Variable Frameserver Port : Le port du serveur lors de rendus réseau
  • Option Disable Game Sound : Désactive le son pour les jeux
  • Option Filter File Extensions : À rédiger
  • Option Hide dot file/datablock : Cela masque les fichiers et dossiers débutant par un point (.) dans le navigateur de fichier Blender. En effet, sous Linux, les fichiers cachés débutent par des points mais Blender les affiche par défaut dans son navigateur.

Les options OpenGL[modifier | modifier le wikicode]

Le mipmapping
A gauche, l'option Mipmaps désactivée, à droite, l'option Mipmaps activée

Ces options se trouvent dans la dernière colonne de ce panneau (OpenGL)

  • Variable Clip Alpha : À rédiger
  • Option Mipmaps : Active le mipmapping dans le viewport. Le mipmapping est un procédé qui démultiplie les textures pour éviter l'effet de pixelisation brouillée engendré par l'étirement ou les rétrécissements d'une texture par la carte graphique. Cette option augmente donc la qualité visuelle des textures dans la vue 3D mais prend des ressources supplémentaires sur la carte graphique.
  • Menu GL Texture Clamp : Ce menu permet d'imposer une limite de taille aux textures pour être affichées dans la vue 3D. Cela permet une certaine économie des ressources pour les petites configurations graphiques.
  • Variable Time Out : À rédiger
  • Variable Collect Rate : À rédiger

Les autres options[modifier | modifier le wikicode]

  • Option Auto Run Python Scripts : En cochant Enable by Default, vous autorisez les fichiers .blend à exécuter automatiquement des scripts Python (plus d'informations sur les scripts dans la section consacrée). Cela peut être dangereux si vous utilisez des fichiers téléchargés dont vous ne connaissez pas la source.
  • Option Color range for weight paint : En cochant ColorBand vous éditez le dégradé affiché dans la vue 3D en mode weight paint. Une fois coché, il vous suffit d'éditer les couleurs de chaque curseur de la bande de couleur. (Plus d'information sur ces modes dans la section consacrée).
  • Option Audio mixing buffer indique la qualité du son lors d'un aperçu.
  • Option Emulate Numpad : Cela est utile pour les ordinateurs portable. Cette option permet d'émuler les claviers numériques à partir des touches 0 à 9 du clavier alphabétique.

L'onglet File paths : Modifier les chemins des fichiers par défaut[modifier | modifier le wikicode]

Blender-file-paths-panel.png


Les options de l'onglet File Paths sont très intéressantes dans un environnement de production ou sur des projets à plusieurs. Elles permettent d'orienter directement l'infographiste dans un dossier précis en fonction du type de fichier demandé. Par exemple, l'explorateur de texture pointera automatiquement vers un dossier /textures. Pour changer un chemin, il suffit d'utiliser l'icône d'exploration Blender-browse-button.png situé à droite de chaque champ

  • Chemin YFexport : Emplacement des fichiers XML du moteur de rendu Yafray (voir la partie sur le rendu et sur Yafray pour plus d'informations)
  • Chemin Fonts : Dossier à pointer par défaut lors de l'utilisation de l'explorateur de polices de caractères
  • Chemin Render : Dossier à pointer par défaut lors de l'utilisation de l'enregistrement d'un rendu
  • Chemin Textures : Idem que pour le chemin fonts mais avec l'explorateur de textures
  • Chemin Python Scripts : L'emplacement par défaut où rechercher les scripts Python. C'est là que le menu des script python lancera sa recherche de scripts. Le premier petit icône Blender-refresh-pyton-menus.png permet de rafraichir ce menu.
  • Chemin Tex Plugins : Idem que pour le chemin fonts mais avec l'explorateur de plugins texture
  • Chemin Sounds : Idem que pour le chemin fonts mais avec l'explorateur de sons
  • Chemin Seq Plugins : Idem que pour le chemin fonts mais avec l'explorateur de plugins du séquenceur
  • Chemin Temp : C'est le dossier où seront stockés les fichiers temporaires (le Backup par exemple).
  • Option Relative Paths Default : En cochant cette option, les fichiers (exemple : les textures) seront par défaut adressés avec un chemin relatif (chemin évalué depuis le dossier du fichier Blender). Par défaut, Blender importe les fichiers avec des chemins absolus mais il est possible par la suite de choisir pour chaque fichier si on veut l'importer en relatif ou en absolu. Cette option est très utile si vous êtes amené à changer de place vos fichiers de production (sur clé USB ou envoyés via internet par exemple).

Sauvegarder sa configuration par défaut[modifier | modifier le wikicode]

Save default settings dans le menu file
Save Default Settings dans le menu File

Une fois que vous avez modifié votre configuration Blender, si vous ré-ouvrez Blender, toutes vos options auront été réinitialisées. Cela vient du fait qu'il faut indiquer à Blender que cette configuration est celle que vous utiliserez par défaut.

Pour cela, une fois que vous avez modifié certaines options, allez dans File > Save Default Settings (ou utilisez la combinaison de touches CTRL+U). Cette opération créera un fichier .B.blend dans votre répertoire de configuration. Ce fichier contient tous les paramètres utilisés lors du Save Default Settings. Cela comprend bien évidemment l'agencement des fenêtres, le thème, les options cochées dans les préférences utilisateurs mais aussi les objets insérés dans la scène, le options cochées dans les autres panneaux, les textures créées. En fait, c'est la scène entière qui servira de fichier par défaut.

Évitez de charger votre scène par défaut d'objets inutiles, de textures et matières, de courbes d'animations... en effet, le fichier .B.blend sera la scène de départ de tous vos futurs projets.

Restaurer la configuration d'origine[modifier | modifier le wikicode]

Si vous souhaitez ré-initialiser votre configuration pour retrouver celle de l'installation, rendez vous dans File > Load Factory Settings.

Ou se trouve le fichier de configuration[modifier | modifier le wikicode]

Le fichier de configuration .B.blend se trouve stocké à la racine de votre dossier personnel (Mes documents sous Windows, /home/MON-UTILISATEUR/ sous Linux).

Si vous souhaitez exporter votre configuration vers un autre poste ou une autre session, il vous suffit de copier ce fichier dans le dossier utilisateur de la session en question. De même si vous souhaitez créer une copie de votre configuration (un backup), vous n'avez qu'à copier ce fichier dans un autre dossier de sauvegarde.

Sommaire: Blender 3D
Page suivante: La fenêtre de vue 3D