Blender 3D/Modéliser un bonhomme en pain d'épice

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche


Dans ce didacticiel, vous apprendrez à réaliser un bonhomme de pain d'épice simple. Plus tard, dans un autre didacticiel, vous animerez ce bonhomme en pain d'épice.

Nous allons utiliser tout ce dont nous avons parlé jusqu'ici, y compris l'extrusion, la subdivision et le rendu. Nous parlerons également d'éclairage basique.

Modélisation[modifier | modifier le wikicode]

Note: si au cours de ce didacticiel, vous avez des problèmes à cause d'un nombre trop important de sommets superposés (ce qui crée des formes étranges lors des déplacements), nettoyez votre modèle. Pour cela, sélectionnez tous les sommets (AKEY) puis supprimez les doublons via WKEY → Remove Doubles.

Tout d'abord, lancez Blender. Vous devriez obtenir un cube dans la vue 3D (déplacez-vous avec MMB ou CTRL + MMB). Assurez-vous d'être en mode orthogonal (NUM5).

  • Sélectionnez le cube en effectuant un clic droit dessus. Pour mémoire, lorsqu'un objet est rose, il est sélectionné;
  • appuyez sur TAB, cela vous permet de passer de l'Object Mode à l'Edit Mode. Vous devriez voir des points roses. Les points roses sont ce que l'on appelle des sommets (vous savez que vous êtes en Edit Mode, si vous voyez ces points). Lorsque vous sélectionnez un sommet avec RMB, il devient jaune;
  • sélectionnez tous les sommets (AKEY une ou deux fois selon que vous avez déjà des sommets sélectionnnés ou non), puis cliquez sur l'onglet édition Editing.png dans l'en-tête de la fenêtre des boutons (vous pouvez également appuyer sur F9) pour éditer;
BlenderCubeEdit.png
  • Vous verrez alors un nouveau menu au bas de la page, cliquez sur le bouton 'Subdivide' dans la section 'Mesh Tools' (les sommets doivent toujours être sélectionnés). Votre cube a maintenant plus de sommets. Cet outil est utilisé pour diviser un objet afin de pouvoir produire des modèles plus complexes. Cette option est également accessible via la touche WKEY ou, dans les versions récentes de Blender, en sélectionnant Edit → Edges → Subdivide dans le menu qui apparaît lors d'un appui sur SPACE;
BlenderSubdividedCube.png
  • Appuyez maintenant sur AKEY pour désélectionner tous les sommets. Passez en vue de face (NUM1), appuyez sur BKEY et tracez un carré autour des sommets supérieur et médian gauches ou appuyez deux fois sur BKEY pour faire apparaître un cercle autour de votre pointeur (tous les sommets compris dans le cercle seront sélectionnez lors d'un appui sur LMB);
  • examinez de plus près les sommets sélectionnés en observant le modèle sous un angle différent (en utilisant MMB). Si vous vous rendez compte que vous n'avez sélectionné que deux sommets et non pas six, il y a deux moyens d'y remédier.
    BlenderSelectionModesInSolidMode.png
    Vous pouvez utiliser la touche ZKEY pour passer du mode fil de fer au mode plein ou appuyer sur le bouton 'Limit selection to visible' dans la barre d'outils des modes de sélection. Recommencez l'opération de sélection et constatez la différence;
BlenderGingerBreadManSelectedFaces3D.png
  • Une fois les 6 sommets sélectionnés, appuyez sur EKEY et sélectionnez 'Region'. Cela extrudera les sommets sélectionnés. Alignez les nouveaux sommets sur la ligne grise située une unité à droite (maintenez CTRL enfoncé pour vous aligner sur le quadrillage). Recommencez deux fois afin d'arriver à quelque chose proche de l'image ci-dessous (la capture a été faite depuis la vue de face (NUM1));
ExtrudedCube1.png
  • désélectionnez tout (AKEY);
  • sélectionnez maintenant les six sommets du côté opposé et répétez le processus. Les bras sont maintenant terminés, comme le montre la capture ci-dessous.
ExtrudedCube2.png  BlenderGingerBreadManExtrudedCube3D.png

Passons maintenant aux jambes.

  • Tout d'abord, désélectionnez tous les sommets avec AKEY;
  • sélectionnez les six sommets inférieurs gauches, extrudes-les et placez les entre les deux lignes grises du dessous. Si vous maintenez CTRL enfoncé, vous remarquerez que les deux sommets s'alignent sur la grille et qu'il n'est pas possible de les placer entre deux lignes. En maintenant SHIFT, vous pourrez les déplacer par pas de dixième d'unités (vous pouvez également saisir le nombre 1.5 afin de les extruder sur une unité et demi, si vous choisissez cette option, soyez sûr d'utiliser les chiffres du pavé numérique).
BlenderGingerbreadManLeftLeg01.png  BlenderGingerbreadManLeftLeg02.png
  • Recommencez l'extrusion et alignez les nouveaux sommets sur la troisième ligne grise (vous pouvez encore une fois saisir 1.5). Vous devriez arriver à quelque chose comme ça:
BlenderExtrudedLeg.png
  • Utilisez BKEY pour sélectionner les 12 sommets inférieurs de la jambe et décalez les d'une demi unité vers la gauche avec GKEY. Vous devriez obtenir ce résultat:
Oneleg-ginger.png  BlenderGingerBreadManOneLegGinger3D.png
  • Répétez l'opération pour la jambe droite.
Twoleg-ginger-head.png
  • Utilisez BKEY pour sélectionner les sommets situés au niveau de l'aine (là où les deux jambes se rejoignent);
  • appuyez sur GKEY et descendez d'une demi unité (appuyez sur GKEY, ZKEY et entrez -0.5 - dans les anciennes versions il est nécessaires d'appuyer sur NKEY avant d'entrer -0.5).
Twoleg-ginger-pulled.png  BlenderTwoLegsGingerPulled3D.png
  • Appuyez sur TAB pour sortir de l'Edit Mode (vous n'êtes plus en Edit Mode lorsque les sommets n'apparaîssent plus). Vous êtes maintenant en Object Mode;
  • cliquez avec RMB sur l'objet pour le sélectionnez et appuyez sur SHIFT + SKEY puis cliquez sur Cursor → Selection. Cela permettra de faire en sorte que le cube que vous allez ajouter se placera approximativement où vous le souhaitez;
  • appuyez sur SPACE et sélectionnez Add → Mesh → Cube (dans les anciennes versions, il s'agit de Mesh → Cube);
  • appuyez sur GKEY et placez votre nouveau cube de façon à ce qu'il s'"enfonce" d'un tiers dans le coup du bonhomme pour cela, vous pouvez utiliser GKEY, ZKEY et entrer 1.33).
Twoleg-ginger-head.png

Nous allons maintenant nous rapprocher de l'aspect d'un bonhomme de pain d'épice en rendant notre modèle plus mince.

  • Passez en vue de profil avec NUM3;
  • presssez SKEY pour redimenssionner la sélection puis YKEY pour n'agir que sur l'axe Y et déplacez votre souris vers l'intérieur jusqu'à ce que l'échelle soit d'à peu près 0.3 (utilisez CTRL pour redimensionner par pallier d'un dixième d'unité);
  • souvenez vous que l'axe X est la ligne/flèche rouche, Y le verte et Z la bleue.
BlenderGingerZscaleHead.png
  • En Object Mode, utilisez RMB sur le corps et appuyez sur SKEY puis YKEY pour l'amincir autant que la tête.
Ginger-zscale.png
  • Utilisez MMB pour vous déplacer dans l'expace et examiner votre œuvre.

Cela ne ressemble toujours pas à un bonhomme en pain d'épices, n'est-ce pas ? Il est un peu trop... carré. Pour finir, nous allons adoucir tout ça.

  • Assurez vous d'avoir sélectionné le corps en Object Mode;
  • sélectionnez les options d'édition dans la fenêtre des boutons (ou appuyez sur F9);
  • dans l'onglet 'Modifiers', ajoutez un modificateur 'Subsurf' (vous pouvez également appuyez sur SHIFT + 0);
  • positionnez le nombre de subdivisions en conception à 2 et à 3 en rendu;
  • vous pouvez appuyer sur ZKEY pour basculer entre la vue en fil de fer et la vue pleine.

Note pour les débutants: la façon la plus simple d'avoir une idée de ce à quoi ressemble un objet en 3D est de diviser la vue en quatre fenêtres, en vues NUM7, NUM3, NUM1 et NUM0 de façon à le voir sous tous les angles et à avoir un aperçu de ce qui sera visible lors du rendu.

  • Dans la section 'Link and materials', sélectionnez 'Set Smooth'.
Ginger-smoothbody.png
  • Appuyez sur ZKEY pour repasser en mode fil de fer;
  • recommencez le processus de lissage pour la tête.
Ginger-smoothall.png

Cela ressemble plus à un bonhomme en pain d'épices, non ?

Positionnement de la caméra et rendu[modifier | modifier le wikicode]

Ce guide va vous apprendre comment obtenir intuitivement un rendu de votre scène 3D avec le meilleur angle de vue!

  • Appuyez sur TAB pour passer en Object Mode;
  • appuyez sur NUM0 pour activer la vue caméra;
  • sélectionnez la caméra en cliquant sur le rectangle le plus à l'extérieur avec RMB;
  • appuyez sur GKEY et déplacez votre souris pour ajuster la positione de la caméra (XKEY, YKEY, ZKEY et CTRL peuvent servir);
  • vous pouvez également appuyer sur NUM7 pour passer en vue du dessus et utiliser RKEY pour faire pivoter la caméra et obtenir le meilleur angle;
  • une fois satisfait de la position, appuyez sur F12 pour lancer le rendu.

Si le résultat est un peu sombre, essayez de placer la lampe plus près du bonhomme en pain d'épice.

BlenderGingerRender.png