Du bon usage d'un traitement de texte/L'éditeur de texte

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche

L'édition du texte est la création du texte proprement dite. Nous allons voir ici les touches particulières et les menus facilitant l'édition.

Nous commençons par reprendre les bases. Les personnes utilisant déjà un traitement de texte connaîtront probablement la majorité des éléments présentés, mais certains sont peu connus et permettent de travailler plus rapidement.

Interface graphique[modifier | modifier le wikicode]

La plupart des traitements de texte modernes on une interface graphique qui se décompose en plusieurs parties :

  • tout en haut, une barre de titre, qui indique le nom du document (nom du fichier) ainsi que le nom du traitement de texte ;
  • une barre de menu permettant d'accéder à toutes les fonctions ;
  • une barre d'outils permettant d'accéder aux principales fonctions ; celles-ci figurent sous la forme de boutons imagés ;
  • le document proprement dit, au centre de la fenêtre, encadré de :
    • règles, qui permettent un placement « au millimètre »,
    • barres de défilement, qui permettent d'accéder rapidement à un endroit du document.

Traitement de texte generique.svg

L'image ci-dessous montre l'interface anglaise d'OpenOffice Writer.

OOoWrite.png

Gestion des fichiers[modifier | modifier le wikicode]

Création d'un document[modifier | modifier le wikicode]

Habituellement, lorsque l'on ouvre le traitement de texte, celui-ci affiche une page blanche. Il s'agit d'un document vierge. On peut commencer à créer le document en remplissant cette page blanche, mais le document existera « réellement » à partir du moment où il aura été enregistré. Le traitement de texte crée alors un fichier portant une extension définie, en général .doc (document) avec MS Word jusqu'à la version 2003, .docx (document XML) avec MS Word à partir de la version 2007 et .odt pour LibreOffice Writer (ou .sxw pour les anciennes versions).

Le fait de créer un fichier permet de rouvrir le document, de le réimprimer, de le retravailler. En cas de problème, comme une panne d'électricité ou une erreur informatique, cela permet de retrouver le travail dans l'état du dernier enregistrement[1]. Il faut donc enregistrer le document très tôt et faire des enregistrements réguliers.

Icône Enregistrer

Pour enregistrer un document, on peut :

  • avec la plupart des traitements de texte sauf MS Word 2007, cliquer sur le menu Fichier (File) et choisir l'option Enregistrer (Save) ;
  • avec Microsoft Office Word 2007, cliquer sur le bouton Office Bouton microsoft office 2007.png et choisir l'option Enregistrer ;
  • utiliser le bouton Enregistrer, qui représente en général une disquette ;
  • utiliser de raccourci clavier :
    • sous Microsoft Windows et GNU/Linux : Ctrl+S ;
    • sous MacOS : touche pomme+S.

La première fois, il faut sélectionner le dossier (folder), ou répertoire (directory), dans lequel on enregistre le document, et donner un nom au document ; on n'a pas à s'occuper de l'extension du nom de fichier. L'emplacement (le dossier) et le nom devront être choisis judicieusement pour permettre de retrouver facilement le document.

Le nom doit en général se limiter à des lettres et des chiffres, mais pas de ponctuation. Les systèmes d'exploitation permettent en général d'utiliser des caractères accentués et des espaces ; en cas de problème, on se limitera aux caractères non accentués et on remplacera les espaces par le caractère de soulignement (underscore) « _ » (touche 8 au dessus sur les clavier de compatibles PC, touche à droite de la parenthèse sur les claviers de Macintosh).

L'option Enregistrer sous (Save as) du menu Fichier (ou du bouton Office pour MS Word 2007) permet de changer l'emplacement ou le nom du fichier. On a alors deux documents ayant la même base mais pouvant être développés différemment.

L'option Enregistrer sous permet également de choisir le format du document différent du format par défaut (format .doc pour MS Word, format .odt pour LibO Writer).


Pour plus de détails voir : Du bon usage d'un traitement de texte/Quelques questions préliminaires#Format de fichier.

MS Word ne permet pas de créer directement un fichier PDF ; sous MS Windows, on peut par exemple installer PDFCreator, et imprimer le document en choisissant PDFCreator dans la liste déroulante Imprimante de la boîte de dialogue Impression. Dans un futur proche, les formats Open XML (.odt) et OpenDocument (.odf) devraient régler le problème de compromis entre format complet et format universel.

Retravailler un document[modifier | modifier le wikicode]

Icône Ouvrir

Si l'on veut retravailler un document existant, on peut :

  • naviguer vers le dossier contenant le fichier avec le gestionnaire de fichier (Explorateur Windows ou Finder de MacOS) et double-cliquer sur le fichier en question ;
  • avec deux fenêtres du gestionnaire de fichier : faire glisser l'icône du document sur l'icône du traitement de texte (icône sur le bureau, ou bien dans une autre fenêtre du gestionnaire) ; cette méthode n'est pas garantie pour toutes les configurations ;
  • à partir de la plupart des traitements de texte, sauf MS Word 2007 :
    • utiliser l'option Ouvrir (open) du menu Fichier ;
    • utiliser le bouton Ouvrir, représentant en général un dossier qui s'ouvre ;
    • utiliser le raccourci clavier :
      • sous Microsoft Windows et GNU/Linux : Ctrl+O ;
      • sous MacOS : touche pomme+O.

Pour Microsoft Office Word 2007, le bouton Ouvrir n'est pas présent sur la barre d'outils « Accès rapide » par défaut. Pour le faire apparaître, il faut

  • cliquer sur le bouton Personnaliser la barre d'outils Accès rapide Microsoft word 2007 bouton personnaliser acces rapide.png ;
  • dans la liste, sélectionner Ouvrir.

Microsoft word 2007 personnaliser acces rapide.png

Par ailleurs, il n'y a pas de menu Fichier ; à la place, on utilise le bouton Office Bouton microsoft office 2007.png.

Édition du fichier[modifier | modifier le wikicode]

Pour créer ou modifier un document, il faut que la fenêtre du document soit « au premier plan », ce qui est le cas à la création d'un nouveau document ou à l'ouverture d'un document existant. Sinon, il faut cliquer sur la fenêtre du document, ou sur l'icône qui se trouve en bas de l'écran :

  • dans MS Windows et GNU/Linux, dans la barre de tâches ;
  • dans MacOS X, dans le dock.

Lorsque l'on tape sur une touche, le caractère (lettre, chiffre, signe, espace) apparaît à l'endroit du curseur. Le curseur est une barre vertical clignotante.

Opérations élémentaires[modifier | modifier le wikicode]

Commençons par taper un texte simple, par exemple

Bonjour le monde.

Par défaut, les lettres apparaissent en minuscules. Pour utiliser les capitales[2], il faut appuyer sur la touche Maj (ou shift, ou ) et appuyer sur la lettre en même temps.

Si l'on doit taper plusieurs capitales à la suite, par exemple pour faire un sigle, on peut :

  1. appuyer sur la touche Ver. Maj (ou Caps Lock, ou ) et relâcher la touche ; le voyant de la touche s'allume ;
  2. taper les lettres ;
  3. appuyer à nouveau sur la touche Ver. Maj pour revenir en minuscules (le voyant s'éteint).

Si l'on appuie sur la touche Maj alors que la touche Ver. Maj est active, on insère des minuscules.

 sous Windows 98, une pression sur la touche Maj désactivait la touche Ver. Maj.

Maintenant que nous avons un texte, nous pouvons utiliser les flèches de déplacement du curseur (touches situées en bas vers la droite du clavier) :

  •  : permet de passer au caractère suivant ;
    • en fin de ligne : passe au début de la ligne suivante ;
    • à la fin d'un document : pas d'effet ;
  •  : permet de passer au caractère précédent ;
    • en début de ligne : passe à la fin de la ligne précédente ;
    • au début du document : pas d'effet ;
  •  : passe à la ligne suivante ;
    • le curseur est à la même position sur la ligne, ou à la fin de la ligne si celle-ci est trop courte ;
    • en fin de document : pas d'effet.
  •  : passe à la ligne précédente ;
    • le curseur est à la même position sur la ligne, ou à la fin de la ligne si celle-ci est trop courte ;
    • en début de document : pas d'effet.

Suppression[modifier | modifier le wikicode]

En cas d'erreur, on peut supprimer une ou plusieurs lettres. Les claviers disposent de deux touches à cet effet :

  • la touche Suppr (del), ou  : supprime la lettre située après le curseur ;
  • la touche  : supprime la lettre située avant le curseur.

Les claviers de MacBook (Macintosh portables) ne disposent que de la touche d'effacement vers l'arrière. On peut obtenir un effacement vers l'avant avec la combinaison fn+.

Insertion[modifier | modifier le wikicode]

Le déplacement du curseur permet d'insérer des mots entre les mots déjà tapés, de lettres entre les lettres déjà tapées (par exemple pour corriger un oubli). Par exemple, plaçons le curseur entre « bonjour » et « monde » en appuyant 9 fois sur , et tapons tout  ; on obtient

'

Bonjour tout le monde.

Nous aurions également pu placer le curseur avec la souris : mettre le pointeur de la souris entre « bonjour » et « monde » et cliquer, puis taper ˽tout ou bien tout˽, selon que le curseur se colle au mot précédent ou suivant.

Par défaut, lorsque l'on tape une lettre, cela décale les lettres déjà existantes vers la droite. Les claviers de compatibles PC possèdent une touche Ins (insert) ; si l'on presse cette touche, les lettres tapées remplacent les lettres existantes (elles les « écrasent ») au lieu de les décaler. Pour signaler que l'on en mode « refrappe » (overwrite), les lettres RFP (OVR) s'affichent en noir dans la barre d'état de MS Word (bas de la fenêtre). Il suffit d'appuyer sur cette touche pour se remettre en mode d'insertion (les lettre RFP/OVR redeviennent grises). Dans LibreOffice Writer, la barre d'état contient un signalement des modes « insérer » et « écraser ». Les claviers de Macintosh ne possèdent pas une telle touche.

Si l'on tape un texte suffisamment long, le curseur passe automatiquement à la ligne suivante lorsqu'il arrive en fin de ligne. La position des mots sur la ligne est gérée automatiquement par le traitement de texte. Les espaces sont en général « élastiques » : leur largeur varie selon le contexte, on parle d'espace « justifiante ». On n'utilisera qu'une seule espace à la fois, et pas plusieurs espaces consécutifs. Si l'on veut positionner un mot précisément, on utilisera une tabulation (voir plus loin).

Si l'on appuie sur la touche Retour , cela crée un nouveau paragraphe : on passe à une nouvelle ligne, mais avec un alinéa : grand interligne ou retrait de paragraphe (indentation) selon la configuration.

L'interligne entre les paragraphes est réglé par le style du texte. Si l'on veut un interligne plus grand, il faudra modifier le style, ce que nous verrons plus loin. Mais on ne devrait pas appuyer deux fois sur la touche  : créer un paragraphe vide n'est pas la bonne manière d'introduire un espace vertical.

Caractères invisibles[modifier | modifier le wikicode]

Le texte est composé de caractères. Les caractères sont des signes (lettre, chiffres, ponctuation, guillemets…) visibles, mais aussi parfois invisibles : les espaces et les fins de paragraphes.

Allons donc en fin de ligne et appuyons sur . Nous créons un nouveau paragraphe, vide pour l'instant.

Nous allons maintenant faire afficher les caractères invisibles ; pour cela, on peut au choix :

  • utiliser le bouton de la barre d'outils ; dans MS Word 2007, il se trouve dans l'onglet « Accueil », zone « Paragraphe » ;
  • avec Word:mac : aller dans le menu Word puis Préférences, et dans la zone Caractères non imprimables, cocher Tout ;
  • avec Word 1997 sous Windows : menu Options → Préférences → Caractères non imprimables, cocher Tout ;
  • avec Word 2003 sous Windows : menu Outils → Options, onglet Affichage, zone Marques de format, cocher Tous ;
  • dans d'autre logiciels, il faut aller dans le menu Affichage et choisir Caractères non imprimables.

On obtient alors :

'

Bonjour·tout·le·monde.¶

|

(le trait vertical sur la deuxième ligne figure la position du curseur). On remarque que :

  • les espaces sont figurées par un point centré « · » ;
  • les fins de paragraphe sont figurées par un pied-de-mouche «  ».

L'affichage des caractères invisibles est très utile pour repérer les problèmes, comme les espaces doubles.

Grands déplacements[modifier | modifier le wikicode]

Pour essayer les fonctions suivantes, mieux vaut avoir un long texte. Vous pouvez ouvrir un texte que vous avez déjà tapé, ou bien faire un copier-coller depuis, par exemple, une page Web (pourquoi pas celle-ci) dans le document vierge (voir ci-après).

Nous avons vu que nous pouvions positionner le curseur où nous voulons sur la page affichée. Si le texte est plus long que la hauteur de la fenêtre, on peut utiliser :

  • la barre de défilement vertical (scroll bar, « ascenseur ») située à droite de la fenêtre : cliquez sur cette barre, et montez ou descendez le curseur de la souris tout en maintenant cliqué, et relâchez le bouton de la souris lorsque vous avez atteint l'endroit désiré ;
  • les flèches encadrant cette barre (dans MS Windows) ou situées sous cette barre (dans MacOS X) : cliquez sur la flèche pour faire défiler vers le haut, et sur la flèche pour faire défiler vers le bas ;
  • la molette de la souris :
    • faites tourner la molette, ou bien
    • cliquez sur la molette, bougez la souris vers l'avant ou vers l'arrière, et recliquez sur la molette lorsque l'endroit désiré est atteint ;
  • avec la zone sensitive (touchpad) d'un MacBook, posez deux doigts sur la zone sensitive et déplacez-les vers l'avant ou vers l'arrière.

Une fois l'endroit désiré atteint, cliquez sur l'endroit du texte désiré.

Cependant, ces manipulations vous obligent à saisir la souris, alors que vos doigts sont sur le clavier. On peut effectuer de grands déplacements de curseur avec des touches du clavier, ce qui permet de gagner du temps.

Combinaisons de touches permettant de grands déplacements
Déplacement
aller :
Compatible PC Mac MacBook
en début de ligne (home) touche pomme+
à la fin d'une ligne Fin (end) touche pomme+
en début d'un document Ctrl+ fn+
à la fin d'un document Ctrl+Fin fn+
au début du mot* Ctrl+ Alt+
à la fin du mot* Ctrl+ Alt+
à l'écran précédent** Page haut (PgUp) idem fn+
à l'écran suivant** Page bas (PgDn) idem fn+
* si le curseur est au milieu d'un mot, il s'agit du mot en cours ; s'il est entre deux mots, il s'agit respectivement du début du mot précédent et de la fin du mot suivant.
** il s'agit de la portion de texte affichée à l'écran, indépendamment du découpage en pages imprimées ; les touches Page haut et Page bas représentent en général une flèche, respectivement vers le haut et vers le bas, barrée de deux traits.

Sélection de texte[modifier | modifier le wikicode]

La sélection d'une portion de texte permet d'agir sur toute la portion d'un seul coup. Le texte sélectionné apparaît en inversé, blanc sur fond noir ; on dit parfois « noircir le texte ».

Pour sélectionner, cliquez sur le début du texte à sélectionner, maintenez le clic et bougez la souris vers la fin du texte à sélectionner, et relâchez le clic. Le texte apparaît maintenant en surligné. Il se peut que le logiciel ajuste automatiquement les position pour que la zone débute et finisse sur un mot complet. Vous pouvez également partir de la fin et aller vers le début.

Si le curseur sort de la fenêtre, cela provoque un défilement du texte (scrolling), ce qui permet de sélectionner des portions de texte importantes. Plus le curseur est loin du bord de l'écran, plus le défilement est rapide.

Cependant, le comportement du curseur est parfois difficile à gérer : la sélection automatique d'un mot entier peut être indésirable, et le défilement peut être trop rapide pour la dextérité de l'utilisateur. La meilleur manière de sélectionner un texte est en fait de :

  1. positionner le curseur à une des extrémités du texte ;
  2. appuyer sur la touche Maj tout en cliquant sur l'autre extrémité du texte (Maj+Clic).

Selection texte souris.svg

L'utilisation de la souris oblige à éloigner les doigts du clavier, ce qui peut constituer une perte de temps. On peut sélectionner du texte uniquement avec le clavier :

  1. il faut positionner le curseur à une extrémité du texte, puis
  2. appuyer sur la touche Maj, et maintenir la touche enfoncée tandis que l'on déplace le curseur, avec les flèches de direction (lettre par lettre) ou avec un grand déplacement (début ou fin de mot, de ligne ou de document).

Par exemple, pour sélectionner trois mots, on peut maintenir Maj+Ctrl — sur PC — ou Maj+touche pomme — sur Mac — appuyé et appuyer trois fois sur .

Sélectionnons une portion de texte, et appuyons sur une lettre du clavier, par exemple A : on voit que tout le texte a été remplacé par ce « a ». Ceci illustre un accident fréquent, d'autant plus fâcheux que le texte sélectionné est long. On peut heureusement annuler cette opération :

  • en utilisant le bouton , représentant une flèche tournante dans le sens inverse des aiguilles d'une montre, vers la gauche,
    — ou bien —
  • en utilisant la combinaison de touches Ctrl+Z sur un compatible PC, touche pomme+Z sous MacOS X,
    — ou bien —
  • avec le menu Édition → Annuler.

Si l'on utilise le menu, l'option Annuler comporte généralement le nom de l'opération à annuler (ici « remplacer »). On peut « annuler l'annulation » en utilisant

  • en utilisant le bouton , représentant une flèche tournante dans le sens des aiguilles d'une montre, vers la droite,
    — ou bien —
  • en utilisant la combinaison de touches Ctrl+Y sur un compatible PC, touche pomme+Y sous MacOS X,
    — ou bien —
  • avec le menu Édition → Répéter.

Si l'on utilise le menu, l'option Répéter comporte généralement le nom de l'opération à annuler (ici « remplacer »).

On peut ainsi supprimer une grande portion de texte en appuyant sur les touches de suppression classique, ou bien en utilisant le menu Édition → Supprimer, ou éventuellement en appuyant sur la touche Espace.

On peut mettre tout le texte en italiques, en utilisant le bouton I, et le remettre en romain (lettres droites) en utilisant le même bouton.

Déplacement de texte[modifier | modifier le wikicode]

On peut déplacer une portion de texte qui a été sélectionnée :

  • avec la souris :
    1. cliquer quelque part sur la zone sélectionnée ;
    2. bouger la souris en maintenant le clic ; on voit un curseur se déplacer ;
    3. lâcher le clic lorsque l'endroit visé est atteint (méthode du « glisser-lâcher », drag-and-drop) ;
  • avec le menu contextuel :
    1. cliquer avec le bouton secondaire[3] sur la zone sélectionnée ;
    2. dans le menu qui apparaît (menu contextuel), sélectionner Couper ;
    3. cliquer avec le bouton secondaire à l'endroit visé;
    4. dans le menu qui apparaît (menu contextuel), sélectionner Coller ;
  • avec les boutons de raccourcis
    1. cliquer sur Couper (paire de ciseaux) ;
    2. placer le curseur à l'endroit désiré ;
    3. cliquer sur Coller (planche avec un bout de papier blanc) ;
  • avec les combinaisons de touches
    • pour un compatible PC : Ctrl+X pour couper, et Ctrl+V pour coller ;
    • pour un Mac : touche pomme+X pour couper, et touche pomme+V pour coller ;
  • avec le menu Édition → Couper et → Coller.

Duplication de texte[modifier | modifier le wikicode]

On peut également dupliquer une portion de texte :

  • avec la souris, de façon analogue au déplacement :
    1. cliquer quelque part sur la zone sélectionnée ;
    2. bouger la souris en maintenant le clic et en maintenant la touche contrôle enfoncée ; on voit un curseur se déplacer ;
    3. lâcher le clic lorsque l'endroit visé est atteint (méthode du « glisser-lâcher », drag-and-drop) ;
  • avec le menu contextuel :
    1. cliquer avec le bouton secondaire sur la zone sélectionnée ;
    2. dans le menu qui apparaît (menu contextuel), sélectionner Copier ;
    3. cliquer avec le bouton secondaire à l'endroit visé;
    4. dans le menu qui apparaît (menu contextuel), sélectionner Coller ;
  • avec les boutons de raccourcis
    1. cliquer sur Copier (feuille imprimée en deux exemplaires) ;
    2. placer le curseur à l'endroit désiré ;
    3. cliquer sur Coller (planche avec un bout de papier blanc) ;
  • avec les combinaisons de touches
    • pour un compatible PC : Ctrl+C pour copier, et Ctrl+V pour coller ;
    • pour un Mac : touche pomme+C pour copier, et touche pomme+V pour coller ;
  • avec le menu Édition → Copier et → Coller.

Caractères spéciaux[modifier | modifier le wikicode]

Certains caractères ne figurent pas sur le clavier, notamment :

  • les capitales accentuées : en typographie française, on met les accents aux capitales et majuscules ;
  • les ligatures, comme « æ » et « œ »[4] ;
  • les diacritiques (accents) et lettres particulières des langues étrangères ;
  • les espaces insécables : certains signes ou mots ne doivent pas être séparés par un changement de ligne ou de page, c'est le cas :
    • des signes de ponctuation double (;:! et ?), qui sont liés au mot qui les précède ;
    • des titres abrégés de personnalités (p.-ex. « M. » pour « monsieur ») et les initiales des prénoms, qui sont liés au nom qui les suit ;
    • des nombres écrits en chiffres : les nombres longs sont séparés en groupes de trois par des espaces insécables, et s'ils ont une unité, ils y sont liés.

Si l'on affiche les caractères non imprimables, Les espaces insécables figurent :

  • dans Microsoft Word pour Windows, sous la forme d'un rond « ° » ;
  • dans Word:mac, sous la forme d'un tilde « ~ » ;
  • dans LibreOffice Writer, sous la forme d'un point centré sur fond gris « · ».

Avec un clavier français (AZERTY), on peut insérer les caractères avec un accent circonflexe (minuscules et capitales) en appuyant d'abord sur la touche ^ puis sur la touche de la lettre :

  • ^ puis A donne « â » ;
  • ^ puis Maj+A donne « Â ».

On peut insérer les caractères avec un tréma (minuscules et capitales) en appuyant d'abord sur la touche ¨, c'est-à-dire Maj+^ puis sur la touche de la lettre ;

  • Maj+^ puis A donne « ä » ;
  • Maj+^ puis Maj+A donne « Ä ».

Avec un clavier Windows, on peut mettre un tilde en appuyant d'abord sur AltGr+~, puis sur la lettre (minuscule ou capitale). Avec un clavier Mac, on fait Alt+N puis la letttre.

Si l'on veut mettre le signe tout seul, on utilisera la touches Espace à la place d'une lettre. On ne peut pas mettre simplement d'accent aigu sur une capitale.

Pour insérer un caractère spécial, on peut :

  • utiliser le menu Insertion → Caractères spéciaux :
    • sous Word : l'onglet Symboles permet d'utiliser les caractères imprimables, l'onglet Caractères spéciaux permet d'intégrer des caractères non imprimables comme l'espace insécable ;
    • sous LibreOffice Writer : les caractères sont classés selon l'Unicode[5], avec les mêmes catégories ; on trouvera l'espace insécable à l'emplacement U+00A0, et les signes particuliers (tirets par exemple) dans la catégorie Ponctuation générale choisie dans le menu déroulant sous-ensemble (caractères U+2010 et suivants)
  • utiliser les raccourcis clavier.
Raccourcis clavier des caractères spéciaux pour Word
Caractères Raccourci
Windows
Raccourci
Mac
espace insécable
(°, ~)
Ctrl+Maj+Espace idem
division conditionnelle
(césure, ⌐)
Ctrl+- (touche 6) touche pomme+-
tiret cadratin
(—)
Ctrl+Alt+- (pavé num.) Alt+-
tiret demi-cadratin
(–)
Ctrl+- (pavé num.) Alt+Maj+-

On remarque que MS Word fait la différence entre le signe moins situé en haut du clavier (touche 6), qui permet d'avoir la césure, et celui situé sur le pavé numérique, qui permet d'avoir les tirets.

Raccourcis clavier des caractères spéciaux pour LibreOffice Writer
Caractères Raccourci
espace insécable
(·)
Ctrl+Maj+Espace
tiret non-sécable (-) Ctrl+Maj+- (pavé num.)
division conditionnelle
(césure, )
Mac : touche pomme+-
Windows : Ctrl+- (pavé num.)

Lettres grecques[modifier | modifier le wikicode]

Les lettres grecques sont beaucoup utilisées en mathématiques et en sciences physiques. Il existe deux manière de les obtenir.

La première consiste à utiliser les caractères Unicode [5] pour les lettres grecques : les lettres grecques et coptes (U+0370 à U+03FF) et la liste étendue des lettres grecques (U+1F00 à U+1FFF). Sous OOo Writer, on peut y avoir accès avec le menu Insérer → Caractères spéciaux, et en choisissant respectivement Basic Greek et Greek Extended dans le menu déroulant Subset ; on peut avoir accès rapidement à l'option Greek Extended en cliquant sur le menu et en tapant G et R.

Elles peuvent aussi s'obtenir avec la police Symbol. Certaines équivalences entre lettres romaines et grecques sont évidente pour qui connaît l'alphabet grec :

  • a → α (alpha) ;
  • b → β (bêta) ;
  • d, D → δ, Δ (delta) ;
  • e → ε (epsilon)
  • f → ϕ (phi)
  • g, G → γ, Γ (gamma) ;
  • l → λ (lambda) ;
  • m → μ (mu) ;
  • n → ν (nu) ;
  • p → π (pi) ;
  • z → ζ (dzêta) ;

d'autres le sont moins :

  • c → χ (chi ou khi) ;
  • j → φ (phi, variante) ;
  • q → θ (thêta) ;
  • v → ϖ (pi, variante) ;
  • w, W → ω, Ω (oméga) ;
  • x → ξ (xhi) ;
  • y → ψ (psi).

Spécificités sous Windows[modifier | modifier le wikicode]

Sous Windows, on peut obtenir un caractère de la manière suivante :

  • on appuie sur la touche Alt ;
  • on compose le code décimal du caractère (table Windows, souvent similaire à l'Unicode [5] mais pas systématiquement) sur le pavé numérique du clavier (4 chifffres) ;
  • on relâche la touche Alt.

Voir par exemple les tables supplément Latin-1, latin étendu A et ponctuation générale :

Exemple de codes de caractères
Code Windows Caractère Code Unicode[5]
(déc./hex.)
Noye
0145 536/x218 guill. ouvrant allemand
0146 537/x219 guill. fermant allemand
0147 8220/x201C guill. ouvrant anglais
0148 8221/x201D guill. fermant anglais
0171 « 171/xAB
0187 » 187/xBB
0156 œ 339/x153
0169 © 169/xA9 copyright
0199 Ç 199/xC7
0201 É 201/xC9

Spécificités du clavier Mac[modifier | modifier le wikicode]

Certains symboles courants sont absents du clavier des Macintosh et peuvent s'obtenir avec Alt+lettre ou Alt+Maj+lettre, ou lettre vaut :

  • a, A → æ, Æ ;
  • b → ß ;
  • B → ∫ ;
  • c → © ;
  • d → ∂ ;
  • f → ƒ ;
  • F → · (point médian catalan et grégorien, U+00B7) ;
  • J → Í ;
  • l → ¬ ;
  • L → | (tube) ;
  • m → µ ;
  • M → Ó ;
  • o, O → œ, Œ ;
  • p, P → π, ∏ ;
  • Q → Ω ;
  • r → ® ;
  • S → ∑ ;
  • T → ™ ;
  • u → º ;
  • U → ª ;
  • V → √ ;
  • x → ≈ ;
  • y → Ú ;
  • Z → Å ;
  •  ; → … ;
  • @ → • (puce, U+2022) ;
  • # → Ÿ ;
  • & →  ;
  • é → ë ;
  • - → — (tiret cadratin) ;
  • _ → – (tiret demi-cadratin) ;
  • 0 → Ø ;
  • 2, 3 → „, ” (guillemets anglais) ;
  • è, 7 → «, » ;
  • (, ) → {, } ;
  • 5, ° → [, ].

Rechercher et remplacer[modifier | modifier le wikicode]

Les logiciels permettent de rechercher une chaîne de caractères. Pour cela, on peut utiliser :

  • le menu Édition → Rechercher
  • Sur compatibles PC, le raccourci clavier Ctrl+F ;
  • avec Macintosh, le raccourci clavier touche pomme+F.

Il suffit de taper la chaîne de caractères à rechercher dans le champ Rechercher de la boîte de dialogue qui apparaît, puis de cliquer sur le bouton Suivant. Cela sélectionne la première occurrence de la chaîne trouvée. L'endroit où se trouve le curseur détermine le début de la recherche.

On peut étendre la boîte de dialogue, avec le bouton , ce qui permet d'accéder à des fonctions supplémentaires :

  • rechercher vers le début du document plutôt que vers la fin : dans le menu déroulant affichant tous, choisir vers le haut ;
  • rechercher un type de formatage (la chaîne de caractères peut être vide) : cliquer sur Format ; on pourra ainsi rechercher les passages en italique, d'une couleur donnée… ;
  • inclure des caractères non imprimables ou spéciaux dans la chaîne de caractères : cliquer sur spécial et choisir le caractère à inclure.

Lorsque l'on inclut un caractère particulier, cela met un chapeau suivi d'un caractère dans la chaîne de recherche :

  • les fins de paragraphes : « ^p » (accent circonflexe puis lettre p) ;
  • les tabulations : « ^t » ;
  • les espaces insécables : « ^s » ;
  • les tirets demi-cadratin : « ^= » ;
  • les tirets demi-cadratin : « ^+ ».

Vous pouvez taper vous-même ces caractères.

L'outil de remplacement permet de substituer une chaîne de caractères par une autre. Cela permet par exemple de changer de vocabulaire ou de corriger une erreur systématique. Pour cela, on peut utiliser :

  • le menu Édition → Remplacer
  • avec WinWord, le raccourci clavier Ctrl+Maj+H ;
  • avec Word:mac, le raccourci clavier touche pomme+Maj+H.

Il suffit de taper la chaîne à rechercher dans le champ Rechercher, et la chaîne qui la remplace dans le champ Remplacer. On peut utiliser dans les deux champs les caractères spéciaux et le formatage comme ci-dessus.

Notes[modifier | modifier le wikicode]

  1. les programmes de traitement de texte utilisent en général un fichier temporaire, invisible pour l'utilisateur, qui permet de retrouver le travail fait peu de temps avant le problème même si le document n'a pas été enregistré ; mais mieux vaut ne pas se fier à ce mécanisme
  2. le terme « capitale » désigne une grand lettre, tandis que le terme « majuscule » désigne la règle de grammaire définissant qu'il faut mettre une capitale en début de phrase ou au début des noms propres ; si l'on compose tout un mot en capitales (un titre par exemple), seule la première lettre sera éventuellement une majuscule ; voir l'article de Wikipédia Capitale et majuscule
  3. bouton droit si la souris est configurée pour un droitier ; sur un Mac, on peut utiliser la combinaison Ctrl+Clic
  4. en belle typographie, on lie également certaines successions de lettes comme « st », « ff », « fi » ; toutefois, bien que ces caractères existent en Unicode (FB00 à FB06 : ff, fi, fl, ffi, ffl, st), cela peut tromper le correcteur orthographique (à moins de les ajouter au dictionnaire), on s'en abstiendra donc, du moins avant la phase de relecture
  5. 5,0 5,1 5,2 et 5,3 En 2013, Unicode est le standard le plus aboutit pour gérer la plupart des systèmes d'écritures du monde entier. À ce sujet lire par exemple le wikibooks À la découverte d'Unicode

Voir aussi[modifier | modifier le wikicode]


Quelques questions préliminaires < | Index | Utilisation des styles >