Pouvoir Accéder et Utiliser MATE/Writer, traitement de texte

Un livre de Wikilivres.
Aller à la navigation Aller à la recherche

Modèle:Pouvoir Accéder et Utiliser MATE

Description de Writer[modifier | modifier le wikicode]

Writer est un logiciel de traitement de texte fourni avec MATE. Dans cette leçon, vous allez explorer les éléments de sa fenêtre.

Lancement de Writer[modifier | modifier le wikicode]

Nous vous proposons d’effectuer un premier exercice qui consiste à lancer le programme Writer. Pour lancer un programme dans MATE, vous pouvez passer par le menu principal. Pour ouvrir ce menu, appuyez maintenant sur les touches alt-f1.

Le menu principal s’ouvre dans le coin supérieur gauche de l’écran. Sélectionnez le menu Bureau en appuyant sur la touche flèche bas et faites dérouler le sous-menu en appuyant sur la flèche droite.

Dans le menu déroulé à la droite du menu principal, positionnez votre curseur sur la commande LibreOffice4.2 Writer avec les touches flèche haut et flèche bas et lancez l’application en appuyant sur la touche Entrée.

Les éléments de la fenêtre d’application Writer[modifier | modifier le wikicode]

Maintenant que l’application Writer est lancée, il est possible que la fenêtre ne soit pas en plein-écran. Vous pouvez la maximiser pour faciliter votre travail et ne pas confondre la fenêtre avec d’autres éléments du bureau MATE. Pour ce faire, déroulez le menu système de la fenêtre en appuyant sur les touches alt-barre d’espacement.

Dans le menu système, sélectionnez maintenant la commande Maximiser et appuyez sur Entrée. Si la commande n’apparaît pas, c’est que la fenêtre est déjà maximisée et vous n’avez qu’à appuyer sur échap pour refermer le menu.

Maintenant que la fenêtre Writer est maximisée, voyons ensemble ses éléments. Comme toute fenêtre d’application, la fenêtre Writer comporte une barre de titre avec une case du menu système à sa gauche et les boutons Réduire, maximiser et fermer à sa droite. La case du menu système permet de dimensionner la fenêtre à l’aide du clavier au lieu de la souris, alors que les boutons situés à droite de la barre permettent d’effectuer la même tâche à l’aide de la souris seulement.

Sous la barre de titre, vous retrouvez une barre de menus qui affiche neuf choix : Fichier, édition, affichage, Insertion, Format, tableau, outils, fenêtre et aide. Chacun des menus permet de choisir des commandes reliées à l’application de traitement de texte. Vous pouvez explorer les commandes du menu Fichier à partir de la capture d’écran ci-contre (page 5 du guide tactile).

le menu Fichier

Vous pouvez maintenant explorer les commandes de la barre de menus avec l’ordinateur. Commencez par sélectionner le premier mot de la barre de menus en appuyant sur la touche f10. Ensuite, vous pouvez passer d’un nom de menu à l’autre en appuyant sur la touche flèche droite ou flèche gauche. Pour dérouler un menu et consulter les commandes, appuyez sur la touche flèche bas.

Pour refermer le menu, appuyez sur la touche échap. Le curseur reviendra alors dans la fenêtre du document dans lequel vous êtes en train d’écrire du texte.

Votre curseur se trouve maintenant dans le document vierge qui s’est ouvert lors du lancement de Writer. Ce document prend par défaut le nom Sans nom 1 tant que vous ne lui en attribuez pas un autre. Vous verrez comment attribuer un nom à la leçon suivante intitulée Gestion de documents.[1]

Rédigez quelques mots ou, si vous préférez, entrez la citation suivante de George Sand : « C’était un bon jeune homme, mais très à court d’idée. »

Gestion de documents[modifier | modifier le wikicode]

Dans cette leçon, vous verrez comment ouvrir, enregistrer et imprimer un document. Si vous venez de faire la leçon précédente, Writer et le document dans lequel vous avez travaillé devraient être ouverts. Dans le cas contraire, lancez Writer maintenant en vous référant à la leçon précédente et rédigez une phrase.

L’enregistrement d’un document[modifier | modifier le wikicode]

Vous allez maintenant enregistrer le document dans lequel vous avez travaillé. Pour ce faire, déroulez le menu fichier avec le raccourci clavier alt-f. Ensuite, sélectionnez la commande Enregistrer sous à l’aide de la flèche bas et appuyez sur Entrée. La boîte de dialogue Enregistrer sous s’ouvrira.

Remarque : si vous n’avez pas déjà nommé votre document, la commande Enregistrer agit comme la commande Enregistrer sous. Voici la représentation de la boîte de dialogue ci-contre (page 6 du guide tactile).[2]

la boîte de dialogue Enregistrer de Writer

Le curseur se trouve par défaut dans la zone où vous inscrivez le nom du fichier à enregistrer. Par défaut également, celui-ci est nomé « sans nom 1 ». Vous devrez donner un autre nom à votre document ainsi qu’un chemin d’accès. Dans cet exercice, enregistrez le fichier dans le dossier Documents dans votre dossier personnel. Tapez donc : ~/Documents/votre nom de famille. ~ s’obtient en combinant les touches altGr et la touche associée au chiffre 2 ou e accent aigu. Partout sur MATE, ce signe renvoie à la racine de votre dossier personnel et vous évite de taper /home/votre_non_d’utilisateur. Pour terminer l’opération, appuyez sur la touche Entrée.

Le document devrait maintenant porter votre nom de famille et être enregistré dans le dossier Documents de votre dossier personnel. Notez que vous pourriez continuer à travailler dans le document, puisqu’il est toujours ouvert, et enregistrer régulièrement les modifications en passant la commande Enregistrer du menu Fichier. Le raccourci clavier pour cette commande est ctrl-s. Faites l’exercice en écrivant quelques autres mots sur ce que vous jugez essentiel de retenir de MATE et enregistrez ces modifications.

Vous venez de sauvegarder les modifications apportées à votre document sous le même nom et le même chemin d’accès que vous lui aviez attribué lors du premier enregistrement. Remarquez qu’aucune boîte de dialogue ne s’ouvre car l’opération d’enregistrement se fait automatiquement lorsque le document a déjà été enregistré une première fois.

Enregistrer un document sous un autre nom[modifier | modifier le wikicode]

Il pourrait vous arriver de vouloir enregistrer sous un autre nom le document dans lequel vous travaillez. Cela pourrait vous arriver lorsque vous effectuez des modifications et que vous désirez conserver une version originale du document.

Pour l’exercice, ajoutez encore quelques mots à votre document. Pour l’enregistrer, faites dérouler le menu Fichier à l’aide des touches alt-f et sélectionnez la commande Enregistrer sous avec la flèche bas et appuyez sur Entrée. La boîte de dialogue Enregistrer sous s’ouvrira. Notez que le raccourci clavier pour cette commande est ctrl-maj-s.

À cette étape, vous devez donner un nouveau nom à votre document. Le curseur se trouve dans la zone Nom de fichier. Effacez votre nom et tapez votre prénom. Pour confirmer l’opération, appuyez sur la touche Entrée. Votre document sera enregistré dans le dossier Documents dans votre dossier personnel.

Rappelez-vous qu’un fichier peut être enregistré sous différents types de formats, tels que OpenDocument, Word 2003, Word 2007, rich text Format ou Texte brut. Ces formats se trouvent dans la liste déroulante « Type de fichier » de la boîte de dialogue Enregistrer sous. Accédez à cette boîte à l’aide de la touche tab (page 6 du guide tactile).

la boîte de dialogue Enregistrer de Writer

La création d’un nouveau document[modifier | modifier le wikicode]

Vous pouvez maintenant ouvrir un nouveau document en passant la commande Nouveau qui se trouve dans le menu Fichier. Pour cet exercice, utilisez son raccourci clavier ctrl-n. Suite à cette commande, une nouvelle fenêtre de document vierge s’ouvrira.

Si vous passez par le menu Fichier, vous remarquerez que la commande nouveau présente un sous-menu. Il vous permet de créer un type de document différent d’un document de traitement de texte, parce que LibreOffice comporte, outre Writer, d’autres outils pour créer des feuilles de calcul, des diapositives de présentation, etc. Pour parcourir le sous-menu, vous devez utiliser les flèches haut et bas et pour cet exercice, choisissez Document texte.

L’ouverture d’un document existant[modifier | modifier le wikicode]

Pour ouvrir un document existant, vous pouvez faire dérouler le menu Fichier en appuyant sur les touches alt-f. Ensuite, sélectionnez la commande Ouvrir à l’aide de la flèche bas et appuyez sur la touche Entrée. La boîte de dialogue Ouvrir apparaîtra. Vous pouvez également passer la commande Ouvrir en utilisant le raccourci clavier ctrl-o. Essayez une de ces deux méthodes.

La boîte de dialogue Ouvrir est structurée comme la boîte de dialogue Enregistrer sous. Par défaut, le curseur se trouve dans la zone Nom du fichier. Vous pouvez écrire le chemin d’accès et le nom du document que vous désirez ouvrir, soit ~/Documents/Votre nom de famille et appuyer sur la touche Entrée.

Pour ouvrir un document dont vous ne connaissez pas le nom exact, vous devez parcourir la lisse des dossiers et des fichiers installés sur votre système, qui se trouve dans la boîte de dialogue Ouvrir. Prenons quelques instants pour retracer les quelques dossiers et fichiers qu’il contient.

Tout d’abord, passez la commande Ouvrir du menu Fichier en utilisant le raccourci clavier ctrl-o. La boîte de dialogue Ouvrir s’affichera.

Le curseur se trouve par défaut dans la zone de saisie intitulée Nom du fichier. Vous pouvez également taper le nom d’un dossier dans cette zone. Pour obtenir la liste des fichiers et dossiers du disque dur, tapez / qui représente la racine de votre ordinateur, qui est son tout premier niveau. Si vous tapiez ~, vous accéderiez à la racine de votre dossier personnel que nous verrons au module 3. Appuyez ensuite sur entrée.

Maintenant, appuyez sur maj-tab pour déplacer le curseur sur la liste des fichiers et dossiers du disque dur. Vous pouvez explorer la liste avec la flèche haut et la flèche bas.

Maintenant, sélectionnez le dossier home et appuyez sur entrée. La liste changera pour afficher le contenu du dossier. Il ne contient qu’un dossier portant votre prénom, ouvrez-le à l’aide de la touche entrée. Vous voilà à la racine de votre dossier personnel. À l’aide de la flèche bas, sélectionnez le dossier Documents et appuyez sur entrée pour l’ouvrir.

Remarquez que si vous le vouliez à ce stade, il vous serait possible de faire afficher le niveau hiérarchique supérieur en appuyant sur alt-flèche haut ou retour arrière, la touche au-dessus d'entrée. Pour afficher le niveau suivant, vous sélectionnez le dossier et appuyez sur entrée. Essayez ces commandes et explorez quelques dossiers de votre dossier personnel.

Retournez au dossier Documents et utilisez les flèches pour positionner le curseur sur le document portant pour titre votre prénom. Appuyez ensuite sur Entrée pour ouvrir ce document.

Notez qu’il existe plusieurs façons d’ouvrir un document. S’il s’agit d’un des vingt derniers documents dans lequel vous avez travaillé, vous pouvez l’ouvrir à partir de la commande Derniers documents du menu Fichier. Elle déroule un sous-menu comportant les vingts derniers fichiers que vous avez ouverts. Pour l’exercice, ouvrez le menu Fichier en appuyant sur alt-f et sélectionnez la commande Derniers documents. Déroulez son sous-menu à l’aide de la flèch droite. Choisissez le document désiré, par exemple celui portant votre nom de famille pour titre, et appuyez sur Entrée.

L’impression d’un document[modifier | modifier le wikicode]

Le document ayant votre nom de famille pour titre devrait être ouvert à l’écran. Pour l’imprimer, ouvrez le menu Fichier en appuyant sur les touches alt-f. Sélectionnez la commande Imprimer à l’aide de la touche flèche bas et appuyez sur Entrée. La boîte de dialogue Imprimer apparaîtra. Vous pouvez également utiliser le raccourci clavier ctrl-p. Faites maintenant l’exercice en choisissant la méthode qui convient le mieux.

Assurez-vous que la boîte de dialogue Imprimer soit ouverte. Cette boîte comporte plusieurs fiches. La fiche dont l’onglet s’intitule Général est celle où vous arrivez à l’ouverture de la boîte de dialogue. Cette fiche comporte deux sections : la section imprimante et la section plage et exemplaires. La section Imprimante vous permet de changer d’imprimante ou de commander une impression braille. La section Plage et exemplaires vous permet de spécifier quels pages sont à imprimer. Elle comporte à cette fin un bouton radio qui permet d’imprimer toutes les pages, c’est-à-dire le document entier, ou des pages spécifiées. Le bouton Toutes les pages est sélectionné par défaut. Enfin, dans cette section, vous pouvez modifier le nombre d’exemplaires à imprimer, un seul étant imprimé par défaut. Vous n’avez donc qu’à appuyer sur la touche Entrée pour imprimer une copie du document en entier.

à droite du bouton radio Pages, vous retrouverez une zone de saisie Pages. Elle sert à définir les pages à imprimer. Rappelez-vous que le bouton radio Toutes les pages commande l’impression du document en entier.

Pour spécifier le nombre de copies que vous désirez imprimer, vous devez déplacer le curseur dans la zone de saisie Nombre d’exemplaires à l’aide de tab. Ensuite, vous n’avez qu’à entrer le nombre correspondant au nombre d’exemplaires à imprimer, puis à appuyer sur Entrée.

Vous pouvez maintenant explorer la boîte de dialogue Imprimer. Vous pouvez déplacer le curseur sur les différentes options en utilisant les touches tab et maj-tab. La touche tab sert à sélectionner les éléments dans un certain ordre, tandis que les touches maj-tab servent à les sélectionner dans l’ordre inverse. Utilisez les touches flèches haut et bas pour changer de bouton radio. Après avoir exploré la boîte de dialogue, accédez à la section Imprimante qui comporte une liste des imprimantes accessibles.[2]

Le curseur devrait se trouver sur la zone Imprimante, qui est une liste déroulante listant les imprimantes accessibles. Pour consulter la liste, appuyez sur les touches flèche bas ou flèche haut. Comme toujours, pour confirmer l’utilisation d’une imprimante, vous devez appuyer sur Entrée, si vous avez complété le reste de la boîte de dialogue. Entrée valide la boîte de dialogue et Echap la referme en annulant l’opération.

La section Imprimante est dotée d’un autre élément : le bouton Propriétés. Vous pouvez y accéder en appuyant sur la touche tab puis sur la touche Entrée. Une nouvelle boîte de dialogue s’ouvrira sur la première. Vous pouvez la parcourir avec la touche tab et les flèches de direction.

Dans la boîte de dialogue Propriétés, vous pouvez sélectionner l’orientation de la page : portrait (ou vertical) ou paysage (horizontal).

Pour refermer les boîtes de dialogue propriétés et Imprimer, appuyez sur la touche échap deux fois.

Ceci termine cette leçon dans laquelle vous avez effectué plusieurs exercices de gestion de documents. Vous avez appris entre autres à ouvrir une application, à enregistrer, créer et imprimer des documents. Dans la prochaine leçon, nous vous proposons des exercices sur les tâches de saisie d’un document.

Édition d’un document[modifier | modifier le wikicode]

L’un des avantages de la rédaction à l’ordinateur est la possibilité d’écrire un texte et d’y apporter des corrections au fur et à mesure. Dans un document, vous pouvez déplacer, copier ou supprimer une partie d’un texte ou le texte en entier. Pour ce faire, vous devez d’abord sélectionner la partie du texte ou le texte concerné. C’est ce que nous verrons maintenant.

Assurez-vous de bien avoir ouvert le document portant votre nom de famille dans Writer.

La sélection d’un texte[modifier | modifier le wikicode]

Il est possible de sélectionner un document en entier en utilisant la commande Sélectionner tout du menu Edition, ou son raccourci clavier ctrl-a. Lorsqu’un texte est sélectionné, on dit qu’il apparaît en surbrillance à l’écran. Pour désactiver la sélection du texte, appuyez sur la flèche gauche ou la flèche droite. Le curseur se déplace toujours à la fin du texte.

Pour sélectionner une phrase, vous devez positionner le curseur au début de celle-ci, maintenir la touche maj enfoncée et déplacer le curseur jusqu’à la fin de la phrase à l’aide de la touche Flèche droite. La touche Flèche droite permet de sélectionner un caractère à la fois, tandis que la touche Flèche bas permet de sélectionner une ligne à la fois. Par contre, si votre curseur est déjà sur la dernière ligne du fichier, la flèche bas combinée à la touche majuscule ne la sélectionnera pas. Relâchez ensuite les flèches de direction puis la touche maj.[3]

Notez que vous pouvez sélectionner un mot à la fois plutôt qu’un caractère à la fois en maintenant les touches ctrl et maj enfoncées et en déplaçant le curseur jusqu’à la fin de la phrase à l’aide de la flèche droite. Maintenant, désélectionnez le texte en appuyant sur flèche gauche. Ceci aura pour effet de replacer le curseur à la fin de la uone sélectionnée au préalable. De la même façon, ctrl-maj-flèches haut et bas vous permettent de sélectionner un paragraphe. Ces commandes sélectionnent ou lisent le paragraphe tout en déplaçant le curseur au début ou à la fin du paragraphe.

Enfin, notez que si votre curseur se trouve au milieu d’un document, et que vous désirez le placer rapidement au début, vous pouvez le faire en appuyant sur les touches ctrl-début. De même, pour placer le curseur à la fin d’un document, vous devez appuyer sur ctrl-fin. Notez que vous pouvez sélectionner le texte à partir de la position du curseur dans ce texte jusqu’au début du document en maintenant les touches ctrl et maj enfoncées et en appuyant sur la touche début. De la même façon, vous pouvez sélectionner le texte à partir de la position du curseur dans ce texte jusqu’à la fin du document en maintenant les touches ctrl et maj enfoncées et en appuyant sur la touche fin.

La copie d’un texte[modifier | modifier le wikicode]

Il est possible de copier du texte à un autre endroit dans votre document. Pour ce faire, vous devez d’abord sélectionner un texte et ensuite, vous devez passer la commande Copier du menu Edition avec le raccourci ctrl-c. Ceci a pour effet de copier le texte sélectionné dans la mémoire temporaire, appelée le presse-papiers. Pour cet exercice, sélectionnez la première phrase du document.

Votre phrase devrait être copiée dans le presse-papiers et vous pouvez maintenant la coller à un autre endroit dans votre document. Pour cet exercice, positionnez le curseur à la fin de votre texte, en appuyant sur les touches ctrl-fin, et passez la commande Coller du menu Edition à l’aide du raccourci clavier ctrl-v.

Votre phrase copiée en mémoire devrait maintenant être collée à la fin du document. Notez que vous pouvez copier un mot, une phrase ou un paragraphe.

Le déplacement d’un texte[modifier | modifier le wikicode]

Vous pouvez également déplacer du texte, c’est-à-dire le changer d’endroit. Vous pourrez faire un exercice dans quelques instants, mais pour le moment, retenez la procédure suivante.

Sélectionnez le texte, passez la commande Couper, positionnez le curseur à l’endroit désiré, et passez la commande Coller. Le raccourci clavier pour la commande Couper est ctrl-x. Celui de la commande Coller est ctrl-v.

Remarquez qu’il est possible de déplacer ou de copier du texte dans le document dans lequel vous travaillez ou d’un point à l’autre de MATE. Par exemple, pour déplacer une ligne dans la zone de saisie de la boîte de dialogue Ouvrir de Writer, la procédure est la suivante. Sélectionner le texte, passez la commande Couper, ouvrez la boîte de dialogue Ouvrir, passez la commande Coller. Nous allons maintenant vous guider pour déplacer une phrase vers un autre document.

Tout d’abord, sélectionnez une phrase dans le document courant portant votre nom de famille et passez la commande Couper en appuyant sur les touches ctrl-x.

Assurez-vous d’avoir sauvegardé les modifications du présent document en appuyant sur ctrl-s. Ensuite, vous allez ouvrir un autre document. Pour ce faire, lancez la boîte de dialogue Ouvrir avec le raccourci ctrl-o.

Dans la boîte de dialogue Ouvrir, vous devez taper le nom du document et son chemin d’accès. Par exemple, tapez ~/Documents/Votre prénom puis appuyez sur la touche entrée.

Pour coller votre phrase dans le nouveau document ouvert, positionnez le curseur à l’endroit désiré (par exemple, au début du texte en appuyant sur ctrl-début), et appuyez sur les touches ctrl-v.

La suppression d’un texte[modifier | modifier le wikicode]

Il est également possible de supprimer du texte. Notez toutefois que lorsque vous le faites, le texte n’est pas copié en mémoire dans le presse-papiers. Il est impossible de le coller ailleurs par la suite.

Pour supprimer du texte, sélectionnez une phrase en plaçant le curseur au début de celle-ci. Maintenez ensuite la touche maj enfoncée, déplacez le curseur avec les flèches de direction jusqu’à la fin de la phrase, puis relâchez le tout. Enfin, appuyez sur la touche Supprimer du clavier et la phrase sera effacée du texte.[3]

L’annulation de la dernière action[modifier | modifier le wikicode]

Il nous arrive parfois de faire une action et d’obtenir un résultat inattendu. MATE a donc prévu une commande très utile qui permet d’annuler la dernière action. Par exemple, si vous venez de supprimer une phrase par erreur, vous pouvez récupérer la phrase grâce à la commande Annuler du menu Edition.

Vous pouvez par exemple récupérer la phrase que vous avez supprimée au cours de l’exercice précédent ou annuler la dernière action effectuée depuis. Pour ce faire, passez la commande raccourci ctrl-z.

Le remplacement d’un mot[modifier | modifier le wikicode]

Supposons que vous avez saisi un terme par erreur dans votre texte et que celui-ci se répète à plusieurs endroits. La fonction Rechercher & remplacer est prévue pour faire la recherche de chacune des occurrences du terme erroné dans votre document et le remplacer par le terme correct.

Pour ce faire, positionnez votre curseur dans le document à l’endroit où vous voulez que Writer commence la recherche, par exemple au début du document.

Vous allez passer maintenant la commande Remplacer avec le raccourci ctrl-h. La commande Remplacer se trouve dans le menu Edition au sein de la boîte de dialogue Rechercher.

Dans la boîte de dialogue, inscrivez le texte à rechercher dans la zone de saisie Rechercher le texte, où se trouve déjà le curseur par défaut.

Déplacez maintenant le curseur dans la zone de saisie Remplacer par en appuyant sur la touche tab 3 fois, et inscrivez-y le terme correct.

Enfin, utilisez la touche tab pour positionner le curseur sur le bouton Remplacer tout et appuyez ensuite sur la touche Entrée pour lancer l’opération. Cette commande aura pour conséquence de remplacer, dans tout le texte, toutes les occurrences du mot erroné] par le terme correct.

Une fois le remplacement de tous les termes erronés effectué, une boîte de message s’affiche vous indiquant le nombre d’occurrences traitées. Appuyez sur Entrée pour fermer la boîte et sur échap pour refermer la boîte de dialogue Rechercher & remplacer. N’oubliez pas d’enregistrer les modifications apportées à votre document avec le raccourci ctrl-s.

La recherche d’un mot[modifier | modifier le wikicode]

Si vous voulez simplement trouver l’endroit dans votre texte où vous traitez un sujet particulier, vous pouvez utiliser la commande Rechercher du menu Edition. Writer recherche un mot ou une phrase et identifie toutes les occurrences dans votre document.

Pour ce faire, placez votre curseur à l’endroit où vous désirez débuter la recherche.

Maintenant, faites afficher la boîte de dialogue Rechercher en utilisant le raccourci clavier ctrl-f. La commande Rechercher se trouve dans le menu Edition.

Le curseur se trouve par défaut dans la zone de saisie Rechercher de la boîte de dialogue. Inscrivez le mot ou la phrase qui fera l’objet de la recherche et appuyez sur la touche entrée.

Lorsque le mot ou la phrase a été trouvé dans le document, la boîte de dialogue demeure à l’écran. Si ce n’est pas le mot attendu, appuyez sur f3 pour rechercher l’occurrence suivante. Sinon, vous pouvez la fermer en appuyant sur la touche échap. Ainsi, le curseur se trouve sur le mot ou la phrase recherché.

Si le mot ou la phrase n’a pas été affichée, une boîte de message s’affichera pour vous indiquer que la recherche dans le document est terminée. Appuyez alors sur Entrée pour refermer la boîte de message, puis sur échap pour refermer la boîte de dialogue Recherche.

Si vous apportez des modifications à votre document, enregistrez-les.

Ceci termine cette leçon où vous avez appris à manipuler du texte dans le document et dans MATE. Dans la prochaine leçon, nous verrons comment mettre en forme du texte à travers quelques exercices.

Mise en forme d’un texte[modifier | modifier le wikicode]

Dans cette leçon, vous apprendrez à appliquer à votre texte des présentations de base. En langage courant, on parle de mettre un texte en forme (par exemple, en appliquant un style et une taille de police particuliers).

Cette leçon n’aborde pas la manipulation des styles. Notez toutefois que pour un usage plus sérieux du traitement de texte, vous devez maîtriser cette notion. D’abord parce qu’elle garantit les personnes aveugles que tous les passages identiques d’un document sont mis en forme comme prévu et uniformément. Ensuite car les styles permettent d’accéder à des fonctions plus avancées, comme la table des matières. Enfin car si vous savez que vous voulez écrire un titre sans idée sur la manière dont il devrait être présenté, le style s’en charge pour vous à partir des conventions classiques.

L’insertion de la date et de l’heure[modifier | modifier le wikicode]

Vous pouvez insérer la date et l’heure dans vos textes. Cette fonction pratique vous permet de mieux identifier vos documents et de faciliter leur mise à jour.

Assurez-vous d’avoir ouvert un document et d’avoir positionné le curseur à l’endroit dans le texte où vous voulez insérer ces informations.

Maintenant, faites dérouler le menu Insertion en appuyant sur les touches alt-i. Dans le menu déroulé, sélectionnez la commande Champ et déroulez le sous-menu à l’aide de la flèche droite.

Dans le menu déroulé, choisissez Date ou Heure avec les flèches haut et bas et appuyez sur Entrée pour valider ce choix. Refaites cette opération pour insérer l’heure si vous avez inséré la date.

Le format de date dépend de la configuration de votre ordinateur. Par défaut, il est en français.

Pour conserver ces modifications, n’oubliez pas d’enregistrer avec le raccourci clavier ctrl-s.

La modification de la police[modifier | modifier le wikicode]

Dans un traitement de texte, vous pouvez également modifier le type (ou la famille), le style et la taille de caractères en utilisant la commande Caractère. Ces modifications apparaissent directement à l’écran. Pour faire un exercice de modification de la police, ouvrez un de vos documents si ce n’est pas déjà fait. Assurez-vous qu’il contient du texte et sélectionnez-le à l’aide du raccourci clavier ctrl-a.[3]

Pour choisir la police que vous utiliserez, faites dérouler le menu Format en appuyant sur les touches alt-t. Sélectionnez la commande Caractère et appuyez sur la touche Entrée.

Une boîte de dialogue apparaît. Elle comporte plusieurs fiches ou onglets. Une fois arrivé dans la boîte de dialogue, faites maj-tab et parcourez les onglets disponibles avec flèche droite jusqu'à l'onglet Police. Faites tab pour accéder aux options de cet onglet. Il présente les différentes options, dont les boîtes Famille, style et taille. La première liste déroulante présente les types de police disponibles. La seconde présente les choix de style, comme Normal, Gras, Italique. La troisième offre des choix de taille comme 12, 14 ou 16 points.

Pour passer d’une boîte à l’autre, appuyez sur la touche tab. Si vous voulez consulter le contenu de chacune des listes, utilisez les touches Flèche bas et flèche haut. Sélectionnez les choix qui vous conviennent et appuyez ensuite sur la touche Entrée. La boîte de dialogue Caractère se refermera et le texte sera modifié conformément au choix que vous avez spécifié. Pour désactiver la sélection de texte, vous appuyez sur n'importe laquelle des quatre flèches de direction.[4]

Notez que vous pouvez également modifier la police de caractère pour une partie du document seulement. Vous devez préalablement sélectionner cette partie, puis suivre la procédure de configuration de police que l’on vient d’expliquer. Dans ce cas, les modifications s’appliqueront seulement à la partie sélectionnée.

Enfin, voici quelques raccourcis qui vous seront utiles et appliqueront le formatage des caractères au texte sélectionné :

  • ctrl-i : passer le texte sélectionné en italique ;
  • ctrl-b : passer le texte sélectionné en gras ;
  • ctrl-u : souligne le texte sélectionné.

Retrait et alignement des paragraphes[modifier | modifier le wikicode]

Si vous voulez définir les caractéristiques des paragraphes de votre texte, commencez par le sélectionner, si ce n’est pas déjà fait, à l’aide du raccourci clavier ctrl-a. Ensuite, faites dérouler le menu Format en appuyant sur les touches alt-t. Sélectionnez la commande Paragraphe du menu déroulé et appuyez sur la touche Entrée.

Une boîte de dialogue apparaît. À l'aide de maj-tab, assurez-vous que vous êtes dans l'onglet Retrait. Si ce n'est pas le cas, déplacez votre curseur vers cet onglet avec les flèches gauche et droite. Dans cet onglet, appuyez sur tab pour modifier les valeurs. Entrez les valeurs du retrait précédant le texte, lui succédant, de la première ligne de chaque paragraphe. La valeur par défaut est de 0cm. Pour déplacer le curseur d’une zone de saisie à l’autre, utilisez la touche tab et entrez-y les valeurs désirées ou utilisez les flèches haut et bas pour y modifier les valeurs.

Vous êtes toujours dans la boîte de dialogue Paragraphe. En plus de définir le retrait, vous pouvez en profiter pour définir l’alignement de votre texte, soit à gauche, à droite ou au centre. Pour accéder à la liste de ces options, positionnez votre curseur sur la liste des onglets avec la touche tab. Puis, avec les flèches de direction, choisissez l’onglet Alignement. Dans cette fiche, appuyez sur tab et choisissez à l’aide des flèches haut ou bas le bouton radio que vous désirez. Confirmez la configuration choisie en appuyant sur la touche Entrée. La boîte de dialogue se refermera et le format de vos paragraphes sera modifié conformément à vos choix.

Vous pouvez maintenant désélectionner votre texte à l’aide des flèches de direction. Notez que vous pouvez modifier le retrait pour une partie du document seulement, par exemple pour un seul paragraphe. Vous devez préalablement sélectionner cette zone puis appliquer les procédures que l’on vient d’expliquer. Dans ce cas, les modifications s’appliqueront seulement à la partie sélectionnée.[4]

Enfin, voici quelques raccourcis qui vous seront utiles et appliqueront le formatage des paragraphes au texte sélectionné :

  • ctrl-e : alignement au centre ;
  • ctrl-r : alignement à droite
  • ctrl-l : alignement à gauche

La fermeture de l’application[modifier | modifier le wikicode]

Lorsque votre séance de travail est terminée, fermez l’application Writer en utilisant la commande du menu Fichier. Pour ce faire, faites dérouler le menu Fichier en appuyant sur les touches alt-f et sélectionnez la commande Quitter. Appuyez ensuite sur Entrée. Vous pouvez également utiliser le raccourci als-f4.

Veuillez noter que si vous n’avez pas sauvegardé les modifications apportées à votre document, une boîte de message apparaît pour vous demander si vous désirez enregistrer les modifications. Si oui, sélectionnez le bouton Enregistrer, puisque c’est le bouton sélectionné par défaut. Sinon, sélectionnez le bouton Fermer sans enregistrer. Après avoir enregistré les modifications, MATE refermera writer et le document.

Si l’application Writer est bien fermée, l'écran devrait présenter maintenant le bureau de MATE ou ce cours. À titre d’information, notez que vous pouvez également fermer l’application par une commande du menu système. Pour dérouler le menu, appuyez sur alt-espace. Vous sélectionnez ensuite la commande Fermer du menu en appuyant sur la touche Entrée.

À propos d’autres façons d’écrire du texte[modifier | modifier le wikicode]

Writer est le logiciel de traitement de texte le plus avancé dans l’univers GNU/Linux et il est le seul accessible. Vous en connaissez maintenant les rudiments. D’autres logiciels existent : les éditeurs de texte, qui vous permettent de formater du texte en décrivant les caractéristiques par des commandes. C’est ce que nous évoquerons dans cette leçon.

Les éditeurs de texte[modifier | modifier le wikicode]

MATE est fourni avec un éditeur de texte nommé Pluma. Cet outil vous permet de saisir du texte au kilomètre. Toutefois, les méthodes que vous avez apprises aux leçon 1, leçon 2 et leçon 3 sont utilisables. La structure générale est la même, la touche f10 sert toujours à déplacer le curseur sur la barre de menus et la touche ctrl vous permet d’accéder aux raccourcis clavier. Les options sont présentées dans des boîtes de dialogue à partir de listes, de cases à cocher et de boutons. Ainsi, si vous êtes capable de travailler dans Writer, vous prendrez facilement en main un éditeur de texte.

Par contre, Pluma ne vous permet pas de mettre en forme du texte. Concernant les paragraphes, Pluma vous permet de définir un comportement par défaut, mais pas d’appliquer automatiquement des styles de paragraphe.

Dans MATE, vous pouvez également installer un autre éditeur, proche de Pluma mais plus élaboré : Gedit.

Mettre en forme du texte par description[modifier | modifier le wikicode]

Pour mettre en forme du texte, il existe un système basé sur la description du texte et de sa forme. Ce langage est beaucoup utilisé dans les milieux scientifiques car il facilite la saisie de formules mathématiques ou chimiques. Il permet de rapidement mettre en forme un document comme un rapport, un article ou un livre.

Il s’agit de LaTeX. Vous pourrez regarder son fonctionnement une fois que vous aurez acquis de l’expérience avec MATE. Il consiste à saisir dans l’éditeur de texte des expressions identifiées définissant à quoi va ressembler le texte. Par exemple, pour placer un paragraphe au centre de la page, vous écrirez \center{le texte}.

Puis, vous enregistrez le fichier texte et vous y appliquez un outil qui interprète les marques pour produire un fichier pdf présenté conformément à vos instructions.

Ce langage reste toutefois difficile à apprendre dans toute sa complexité. Il est rigoureux et assimilable à une syntaxe de ligne de commande. Il vous donne toutefois un contrôle plus fort de ce que vous mettez en forme.

Questions et réponses[modifier | modifier le wikicode]

Cette leçon propose un quiz de cinq questions à choix multiples. Les réponses sont dans la section Réponses au quiz. Pour plus d'interaction, se trouve dans cette zone la raison pour laquelle les autres réponses ne sont pas correctes.

Questions à choix multiple[modifier | modifier le wikicode]

  1. Qu’arrive-t-il si vous sélectionnez la commande Enregistrer sous du menu Fichier et si vous appuyez sur Entrée ?
    1. Une boîte de dialogue s’affiche à l’écran
    2. Une boîte de message s’affiche à l’écran
    3. L’enregistrement se fait automatiquement
    4. Le document se ferme
  2. Parmi les fonctionnalités suivantes, laquelle n’est pas offerte dans un éditeur de texte ?
    1. La recherche d’un mot dans un texte
    2. L’annulation de la dernière action effectuée
    3. L’enregistrement d’un document
    4. La mise en forme des caractères
  3. Parmi les choix suivants, lequel permet de déplacer une phrase ?
    1. ctrl-c puis ctrl-v
    2. ctrl-x et ctrl-v
    3. ctrl-z
    4. ctrl-s
  4. Par quelle commande peut-on enregistrer un document sous un autre nom ?
    1. Enregistrer
    2. Ouvrir
    3. Enregistrer sous
    4. Coller
  5. Par quelle commande ferme-t-on l’application Writer ?
    1. Quitter du menu Fichier
    2. Réduire du menu système.
    3. Nouveau du menu Fichier
    4. Fermer du menu Fichier.

Réponses au quiz[modifier | modifier le wikicode]

  1. Réponse 1. L’enregistrement automatique se fait lorsque vous passez la commande Enregistrer et que votre document a déjà été nommé. Le document reste ouvert jusqu’à ce que vous demandiez sa fermeture. La boîte de dialogue Enregistrer sous s’affiche pour vous demander le nom et le chemin d’accès du document que vous souhaitez enregistrer.
  2. Réponse 4. Un éditeur de texte, ou bloc-notes, permet toutes les autres actions mais pas de mettre en forme les caractères.
  3. Réponse 2. ctrl-c ctrl-v permet de copier une phrase, ctrl-z d’annuler la frappe et ctrl-s d’enregistrer le document. Pour déplacer une phrase, il faut la couper-coller avec ctrl-x ctrl-v.
  4. Réponse 3. La commande Enregistrer permet d’enregistrer le document automatiquement sur le support avec lequel vous travaillez. La commande Ouvrir permet d’ouvrir un document et Coller permet de coller du texte qui a été copié ou coupé.
  5. Réponse 1. La commande Fermer du menu fichier ferme le document sans quitter Writer. La commande nouveau permet d’ouvrir un nouveau document. La commande Réduire permet de réduire la fenêtre Writer en bouton sur le tableau de bord. Notez que l’application est toujours active.

Notes et références[modifier | modifier le wikicode]

  1. insertion-t : permet d’obtenir l’heure. Cette commande vous permet d’obtenir l’heure en tout temps sans quitter l’application dans laquelle vous travaillez.
  2. 2,0 et 2,1 entrée deux fois du pavé numérique : permet d’obtenir des informations sur les options d’une boîte de dialogue. Cette commande permet d’obtenir de l’information sur les différentes options que l’on retrouve dans une boîte de dialogue et ce, dans l’ordre dans lequel elles sont présentées lorsqu’on se déplace avec la touche tab.
  3. 3,0 3,1 et 3,2 Entrée du pavé numérique 2 fois : permet de lire le texte sélectionné. Cette commande permet de lire la portion d’un texte que vous aurez préalablement sélectionné. Son comportement varie selon les applications, mais c’est son fonctionnement dans le traitement de texte.
  4. 4,0 et 4,1 insertion-f : informe sur la famille, le style et la taille du caractère courant ainsi que sur son alignement. Notez que le caractère courant est le caractère sur lequel se trouve le curseur d’insertion, ou focus.