Programmation algorithmique/Maths 1

Un livre de Wikilivres.
Sauter à la navigation Sauter à la recherche
Algorithmique
Algorithmique
Sommaire
Modifier ce modèle

Calcul de suites[modifier | modifier le wikicode]

Suite récurrente niveau 1[modifier | modifier le wikicode]

On veut évaluer le N-ième terme de la suite définie par :

  • U0=1
  • Un+1=3.Un+8
  • Paramètres en entrée : l'entier N
  • Paramètres en sortie : l'entier U
  • Spécifications : U doit être égal à UN.
  • Algorithme :
0/ début suite-1
1/ écrire ("n=")
   lire (n)
2/ U<-1 
  pour i de 1 a (n-1) faire :
  U<- 3*U+8
  fin pour
3/ fin suite-1

Suite récurrence niveau 2[modifier | modifier le wikicode]

On veut évaluer le N-ième terme de la suite définie par :

  • U0=1
  • Un+1=3.Un+n+4
  • Paramètres en entrée : l'entier N
  • Paramètres en sortie : l'entier U
  • Spécifications : U doit être égal à UN.
  • Algorithme :
u,n,i : Entier

u := 1
pour i de 0 à n - 1
   u := 3*u + i + 4
fin Pour

Suite récurrence niveau 3[modifier | modifier le wikicode]

On veut évaluer le N-ième terme de la suite de Fibonacci définie par :

  • U0=1
  • U1=1
  • Un+2=Un+1+Un
  • Paramètres en entrée : l'entier N
  • Paramètres en sortie : l'entier U
  • Spécifications : U doit être égal à UN.
  • Algorithme :
u,v,w,n,i : entier

v := 1
w := 1
si u=0 alors 
     u := w
sinon 
     si u = 1 alors
           u := v
     sinon 
           pour i de 2 à N - 2
                u := v+w
                w := v
                v := u
          fin pour
     fin si
fin si

Suite récurrence niveau 4[modifier | modifier le wikicode]

On veut évaluer le N-ième terme de la suite définie par :

  • U0=1
  • U1=17
  • Un+2=(n+4)*Un+1+2.Un+n
  • Paramètres en entrée : l'entier N
  • Paramètres en sortie : l'entier U
  • Spécifications : U doit être égal à UN.
  • Algorithme :
u,v,w,n,i : Entier

v := 17
w := 1

si u = 0 alors 
     u := w
sinon 
     si u := 1 alors 
           u=v
     sinon 
           pour i de 2 à N - 2
                u := (i + 4)*v + 2*w + i
                w := v
                v := u
           fin pour
     fin si
fin si

Calcul de somme[modifier | modifier le wikicode]

Somme des N premiers entiers[modifier | modifier le wikicode]

  • Paramètres en entrée : l'entier N
  • paramètres en sortie : l'entier S
  • Spécifications : S doit être égal à la somme des N premier entiers
  • Algorithme :
n,s,i : Entier

s := 0
pour i de 1 à N
     s := s + i
fin pour

Calcul polynomial[modifier | modifier le wikicode]

Évaluation d'un polynôme par l'algorithme de Horner[modifier | modifier le wikicode]

  • Paramètres en entrée : Un tableau de N+1 réels TABLEAU REEL a[0..N] et un réel X.
  • Paramètres en sortie : le réel P
  • Spécifications : P doit être égal à
  • Algorithme :
a[0..N] : tableau de réel
x, i, p : réel

p := 0
pour i de 0 à n
   p := p*x + a[n - i]
fin pour