Pouvoir Accéder et Utiliser Writer/Utiliser les outils de Writer

Un livre de Wikilivres.
Aller à la navigation Aller à la recherche


Utiliser et créer un tableau

Writer est doté de fonctionnalités visant à vous assister et à accélérer votre travail dans un texte. Par exemple, au lieu de rechercher ligne à ligne un mot mal écrit, vous pouvez utiliser l'outil Rechercher & remplacer, afin d'en localiser rapidement toutes les occurrences et éventuellement, les remplacer d'un bloc ou individuellement.

Vous pouvez également, si vous avez un texte avec un nombre de mots à respecter, obtenir des statistiques instantanées à partir de la commande Statistiques.

Le correcteur orthographique identifie les erreurs qui vous auraient échappé. Vous avez également la possibilité de créer du publipostage en quelques secondes.

Enfin, dans le cas de documents confidentiels, vous avez la possibilité d'insérer un mot de passe. Nous étudierons d'ailleurs également comment signer votre document électroniquement.

Rechercher, remplacer et utiliser le navigateur[modifier | modifier le wikicode]

Dans cette leçon, vous allez apprendre comment rechercher un ou plusieurs mots, comment remplacer un ou plusieurs mots, comment naviguer rapidement dans un document.

Rechercher un ou plusieurs mots[modifier | modifier le wikicode]

En utilisant la commande Rechercher du menu Edition, vous ouvrirez la boîte de dialogue Rechercher. Si vous souhaitez trouver dans votre texte l'endroit où vous traitez un sujet particulier, Writer fera la recherche d'un mot ou d'une phrase et identifiera toutes les occurrences dans votre document.

Pour ce faire, ouvrez le document Lettre.odt situé dans le dossier Exercices et placez votre curseur au début de ce document.

  1. Assurez-vous que votre curseur est placé à l'endroit précis où vous souhaitez débuter la recherche. Maintenant, faites afficher la boîte de dialogue Rechercher en utilisant le raccourci clavier ctrl-f. Vous pouvez également utiliser le menu Rechercher à partir du menu Edition.
  2. Le curseur se trouve par défaut dans la zone de saisie Rechercher de la boîte de dialogue Rechercher. Inscrivez le mot ou la phrase qui fera l'objet de la recherche. Dans le cadre de cet exercice, recherchez le mot « signature » dans le document ouvert à l'écran et appuyez sur la touche Entrée.
  3. Lorsque le mot ou la phrase a été retrouvé dans le document, la boîte de dialogue Rechercher demeure à l'écran. Le curseur de votre fenêtre de document se place au début de la première occurrence du mot recherché. Appuyez sur la touche échappe pour retourner à votre document et vous éclairer sur le contexte de l'occurrence. Pour passer à l'occurrence suivante, vous devez recommencer les étapes 1 et 2.!ref name="orca37"/> Si le mot ou la phrase n'a pas été retrouvé, une boîte de dialogue s'affichera pour vous indiquer que la recherche du document est terminée et que Writer souhaite recommencer la recherche depuis le début du document. Appuyez alors sur la touche échappe deux fois pour fermer cette boîte de message.

La boîte de dialogue Rechercher & remplacer permet également de faire le même type de recherche que celui pratiqué au précédent exercice. Mais elle permet également de remplacer des mots, comme nous le verrons par la suite, et d'affiner vos critères de recherche. Pour l'ouvrir, appuyez sur le raccourci clavier ctrl-h ou activez la commande Rechercher & remplacer du menu Edition.

Une case à cocher Plus d'options vous permet d'opter pour des critères spécifiques. Par exemple, vous avez la possibilité de définir des critères de recherche basés sur le style, le formatage des caractères. Si vous cochez la case Plus d'options, puis la case Styles de paragraphe, la zone de saisie contiendra tous les styles que contient le document. Vous pourrez alors en choisir un en spécifiant ou non du texte. Si aucun texte n'est spécifié, la recherche ne se fera que sur le style choisi.

De même, si vous faites une recherche sur un mot tel que « découverte » en tapant « verte », une case à cocher appelée Mots entiers uniquement ne sélectionnera pas le mot comportant les mêmes lettres comme le mot « verte ».

La case à cocher Plus d'options vous donne également accès au bouton Format. Avec le bouton Format, vous pouvez rechercher dans votre document des polices spécifiques, des mots en gras ou en italique, ou du texte surligné. Par exemple, vous pourriez décider de chercher les mots en style gras à partir de la boîte de dialogue Format. Writer rechercherait alors toutes les expressions en gras. Gardez le document ouvert pour effectuer le prochain exercice.

Remplacer un ou plusieurs mots[modifier | modifier le wikicode]

Vous avez certainement noté que dans le document Lettre.odt, l'appel sous forme « monsieur, Madame » comporte une erreur. Effectivement, la première lettre du mot « Monsieur » devrait être en majuscule. La fonction Remplacer est prévue pour faire la recherche de chacune des occurrences du terme erroné dans votre document et pour la remplacer par le terme correct.

Dans cet exercice, le terme à rechercher sera « monsieur » que vous remplacerez par « Monsieur ». Voici comment procéder en utilisant la fonction Rechercher & remplacer :

  1. Positionnez votre curseur au début du document à modifier. Appuyez sur les touches de raccourci ctrl-h pour ouvrir la boîte de dialogue Rechercher & remplacer. Vous pourriez également passer cette commande par la commande du même nom du menu Edition.
  2. Dans la boîte de dialogue Rechercher & remplacer, inscrivez le terme à remplacer dans la zone de saisie intitulée Rechercher où se trouve le curseur par défaut. Dans le cadre de cet exercice, inscrivez le mot « monsieur ».
  3. Déplacez maintenant le curseur dans la zone de saisie Remplacer par en appuyant autant de fois que nécessaire sur la touche tab. Inscrivez à cet endroit le terme correct, soit « Monsieur ».
  4. Appuyez sur la touche tab pour déplacer le curseur jusqu'au bouton Remplacer et appuyez sur Entrée. Votre terme à remplacer sera sélectionné et remplacé dans votre document. Puis, votre curseur se positionnera sur l'occurrence suivante.
  5. Dans le cadre de cet exercice, vous avez trois termes à remplacer. Vous pouvez donc utiliser le bouton Tout remplacer pour remplacer toutes les occurrences du mot erroné par le mot correct. Nous vous conseillons cependant d'être prudent avec cette commande. En effet, le remplacement s'effectuerait dans tous les cas même si certains mots ne devraient pas être remplacés. Par exemple, si vous décidiez de remplacer la première lettre d'un mot, ici en majuscule, ce mot commencerait toujours par une majuscule dans votre document. Il est possible cependant que ce changement ne soit pas nécessaire (en milieu de phrase par exemple). Une fois le remplacement de tous les termes effectué, une boîte de message s'affiche vous indiquant le nombre de remplacements effectués. Appuyez sur la touche Entrée pour fermer cette boîte de message, puis la touche échappe pour fermer la boîte de dialogue Rechercher & remplacer.

N'oubliez pas d'enregistrer ces modifications à votre document en appuyant sur les touches ctrl-s.

Utiliser le navigateur[modifier | modifier le wikicode]

Le navigateur est un outil vous permettant d'accélérer votre déplacement dans votre document. Il a un intérêt surtout pour des documents assez longs, où vous n'avez pas forcément envie d'atteindre un endroit précis avec les touches pgdn, pgup, ou la recherche d'un mot.

Vous avez deux façons de naviguer dans votre document : par « élément remarquable » ou par page.

Le premier mode de navigation s'appuie notamment sur les styles et le plan de votre document. Vous y accédez à l'aide de la touche f5. Votre curseur se positionne dans une liste où vous pouvez choisir les éléments à parcourir. Elle se présente sous la forme d'une arborescence. Par exemple, pour suivre la hiérarchie du document et le parcourir ainsi comme une table des matières, choisissez de naviguer de titre en titre. Attention, cela ne fonctionne que si vous avez hiérarchisé votre document à l'aide des styles comme expliqué au module 3.

D'autres éléments permettent le même type de navigation. Par exemple, vous pouvez demander à afficher la liste des tableaux, des images, des repères, des liens hypertextes, des index, des commentaires.

Une fois que vous avez choisi les types d'éléments dans lesquels vous souhaitez naviguer, appuyez sur la touche flèche droite pour entrer dans la catégorie et vous accédez à la liste des éléments correspondants, par exemple, des images. Les images, les tableaux ou les cadres apparaissent avec le titre que vous leur avez donné.

Si vous choisissez de naviguer de titre en titre, vous accédez immédiatement au titre principal du document. Puis, apparaît la hiérarchie que vous avez définie sous la forme d'arborescence. Pour entrer dans un niveau de titre, appuyez sur la touche flèche droite.

Si vous estimez que l'arborescence n'est pas cohérente, c'est que vous avez mal hiérarchisé votre document. Le navigateur de Writer vous permet dans ce cas de la redéfinir tout en parcourant l'arborescence. C'est un moyen très simple de redéfinir une hiérarchie qui ne vous convient pas. Pour effectuer cette modification, appuyez sur maj-tab pour atteindre la barre située sur la gauche de l'arborescence et déplacez-vous parmi les commandes qu'elle offre avec les touches flèche droite et flèche gauche. Vous trouverez ainsi le bouton Abaisser d'un niveau et Réhausser d'un niveau. Dans le premier cas, vous abaisserez le titre courant d'un niveau, en faisant ainsi un titre de niveau inférieur, comme un sous-titre. Dans le second cas, vous effectuerez le mouvement inverse.

Une fois que vous avez atteint le titre, éventuellement après avoir réaménagé les titres de votre document, l'image, le tableau ou l'élément sur lequel vous souhaitez vous rendre, appuyez sur la touche Entrée. Votre curseur se positionne sur le premier caractère ou au tout début de l'élément. C'est une façon de parcourir rapidement le document par ses éléments remarquables.

Notez que la boîte de dialogue ne se referme pas mais disparaît derrière la fenêtre de document. Vous pouvez donc y réaccéder à tous moments à l'aide de la touche f6 pressée autant de fois que nécessaire, qui vous amènera dans la zone du navigateur. Pour faire disparaître la boîte de dialogue, appuyez de nouveau sur la touche f5.

Ceci illustre de nouveau l'importance de travailler avec des styles quand on veut utiliser toute la puissance d'un outil de traitement de texte.

Le second mode de navigation mis à votre disposition par le navigateur de Writer est la navigation par page. Voici comment procéder pour atteindre une page :

  1. Appuyez sur les touches ctrl-maj-f5 pour ouvrir le navigateur en mode Page.
  2. Dans la zone de saisie intitulée Numéro de page, inscrivez le numéro de la page à atteindre. Dans le cadre de cet exercice, inscrivez le chiffre 2.
  3. Appuyez sur la touche Entrée pour atteindre la page 2 du document Lettre.odt. Cette fois, la fenêtre du navigateur s'est automatiquement refermée.[1]

Dans la leçon suivante, vous allez apprendre à utiliser l'outil Statistiques.

Utiliser l'outil statistique[modifier | modifier le wikicode]

Writer peut examiner votre document à partir de la commande Statistique. Vous disposez de trois façons pour obtenir ce type d'information. Vous pourrez ainsi compter les pages, les mots, les paragraphes, les lignes, les objets et les caractères de votre document. Vous pourrez même compter le nombre de mots et de caractères contenus dans un bloc de texte que vous avez sélectionné et le comparer avec le nombre total d'éléments du document.

Dans cette leçon, vous verrez comment lire les statistiques de base de votre document, comment lire les statistiques de base de votre bloc de texte sélectionné et comment lire les statistiques détaillées de votre document.

Lire les statistiques de base du document[modifier | modifier le wikicode]

Il est possible que vous ayez besoin de connaître exactement le nombre de mots d'un devoir ou le nombre de pages d'un document. À tout moment, Writer vous permet de lire le nombre total de pages du document, le nombre de mots et le nombre de caractères. Pour ce faire, il vous suffit de lire la barre d'état.[2]

Elle présente les informations toujours dans le même ordre : tout d'abord, elle affiche le numéro de la page sur laquelle vous vous trouvez. Puis, après une barre oblique, le nombre total de pages. Ensuite, elle indique le nombre de mots. Enfin, après une virgule, elle vous donne le nombre de caractères.

Lire les statistiques de base de votre sélection[modifier | modifier le wikicode]

Les informations contenues dans la barre d'état restent globales. Vous pouvez donc les affiner à votre sélection. Voici comment procéder :

  1. Sélectionnez le bloc de texte que vous souhaitez analyser. Dans le cadre de cet exercice, sélectionnez la ligne Monsieur, Madame.
  2. Appuyez sur les touches alt-o pour ouvrir le menu Outils. À l'aide de la touche flèche bas, sélectionnez la commande Statistique. Appuyez alors sur la touche Entrée pour afficher la boîte de message.
  3. Consultez la boîte de message.[3] Elle se présente en deux colonnes : à gauche, les statistiques relatives au bloc de texte sélectionné, à droite, celles globales du document. Vous verrez ainsi que 2 mots sont sélectionnés, comprenant 17 caractères en incluant les espaces et 16 caractères en les excluant. Pour comparer ces valeurs à celles du document, observez la colonne de droite.
  4. Appuyez sur Entrée pour activer le bouton Fermer et refermer la boîte de dialogue.

Lire les statistiques détaillées de votre document[modifier | modifier le wikicode]

Dans le cadre de cet exercice, assurez-vous que le document Lettre.odt est affiché à l'écran. Si ce n'était pas le cas, ouvrez-le à partir du dossier Exercices.

  1. Assurez-vous d'être dans le document à comptabiliser. Writer ne tiendra compte que du document courant au cas où le document serait ouvert. Appuyez sur les touches alt-f pour ouvrir le menu Fichier.
  2. À l'aide de la touche flèche bas, sélectionnez la commande Propriétés. Appuyez sur la touche Entrée pour ouvrir la boîte de dialogue Propriétés.
  3. Dans la boîte de dialogue Propriétés, choisissez l'onglet Statistiques.
  4. Consultez l'onglet Statistiques de la boîte de dialogue Propriétés.[3]
  5. Appuyez sur la touche Entrée pour fermer la boîte de dialogue Propriétés.

Vous allez, dans la leçon suivante, utiliser le correcteur d'orthographe.

Utiliser le correcteur d'orthographe[modifier | modifier le wikicode]

Le correcteur d'orthographe repère les mots mal orthographiés ou ne figurant pas dans le dictionnaire de Writer et propose des suggestions.

Dans cette leçon, vous allez comprendre le correcteur d'orthographe, utiliser le correcteur d'orthographe et vérifier l'orthographe au cours de la frappe.

Comprendre le correcteur d'orthographe[modifier | modifier le wikicode]

La vérification de l'orthographe débute là où vous avez placé le curseur dans le document. Lorsque vous démarrez une vérification d'orthographe en passant par le menu Outils ou en appuyant sur la touche de fonction f7, la boîte de dialogue Orthographe s'affiche. Voici à quoi ressemble cette boîte de dialogue (reportez-vous à la page 13 du guide tactile ou branchez votre module tactile si vous êtes non voyant).

la boîte de dialogue du vérificateur d'orthographe

Dans cette boîte de dialogue, vous trouverez une première section contenant une zone de saisie intitulée « Absent du dictionnaire » dans laquelle vous pourrez corriger directement l'erreur. Votre curseur sera placé sur le premier caractère du mot contenant l'erreur. À côté de cette zone de saisie, il y a une zone de liste dans laquelle vous sont éventuellement fournies plusieurs suggestions de réponses aux erreurs repérées. Dans le cas contraire, la mention « Pas de suggestion » sera indiquée dans cette zone.

Pour accepter une suggestion, appuyez sur la touche tab pour vous rendre dans la zone de liste et sélectionnez dans la liste des suggestions le mot de votre choix. Lorsque vous sélectionnez une suggestion, le curseur se placera par défaut sur le bouton Corriger. Il suffit maintenant d'appuyer sur la touche Entrée pour apporter la modification souhaitée. Si le changement que vous souhaitez n'apparaît pas dans la liste des suggestions, vous avez la possibilité de le corriger dans la zone de saisie « Absent du dictionnaire ». Rendez-vous ensuite au bouton Corriger avec la touche tab et appuyez sur la touche Entrée.

Si vous souhaitez ajouter un mot au dictionnaire personnalisé, rendez-vous sur le bouton Ajouter au dictionnaire et appuyez sur la touche Entrée. Votre ajout sera enregistré dans le dictionnaire personnel.

Si vous souhaitez ne pas tenir compte des suggestions du vérificateur d'orthographe, appuyez sur la touche tab pour vous rendre au bouton Ignorer. Si vous souhaitez que ce mot ou cette phrase soient systématiquement ignorés au cours de la session de vérification, utilisez le bouton Tout ignorer. Enfin, le bouton Tout corriger corrige toutes les mêmes occurrences d'un mot ou d'une phrase.

Utiliser le vérificateur d'orthographe[modifier | modifier le wikicode]

Dans l'exercice suivant, vous allez appliquer le correcteur d'orthographe au document Lettre.odt. Assurez-vous que le document est ouvert à l'écran. Si ce n'était pas le cas, ouvrez-le à partir du dossier Exercices. Positionnez le curseur au début du document.

  1. Appuyez sur les touches alt-o pour ouvrir le menu Outils. Appuyez sur la touche Entrée pour lancer le correcteur d'orthographe, le curseur étant par défaut sur la commande Orthographe. Notez que vous pouvez également appuyer sur la touche de fonction f7.
  2. Votre curseur est situé sur le bouton Corriger. Pour identifier la première erreur rencontrée, allez dans la zone de saisie Absent du dictionnaire avec la touche tab.
  3. Votre curseur se place sur la première lettre du mot erroné : « letre ». si ce n'est pas le cas, il est probable que le correcteur ait rencontré d'autres erreurs que celle dans le mot qui nous intéresse. Dans ce cas, sélectionnez avec tab le bouton Ignorer et appuyez sur Entrée pour l'activer. Refaites cette étape jusqu'à atteindre le mot « letre ».
  4. À l'aide de la touche tab, rendez-vous dans la zone Suggestions et choisissez la bonne orthographe, soit « lettre ».
  5. Après avoir sélectionné le mot bien orthographié, appuyez sur tab pour placer le curseur sur le bouton Corriger. Il suffit maintenant d'appuyer sur la touche Entrée pour modifier l'orthographe du mauvais mot.
  6. Appuyez sur échappe pour fermer la boîte de dialogue Orthographe.

Vous pourriez continuer ainsi jusqu'à ce qu'une boîte de message apparaisse vous indiquant que vous avez corrigé votre document complet. Si vous aviez commencé la vérification quelques lignes après le début du document, Writer vous aurait proposé de recommencer la vérification depuis le début.

Vérifier l'orthographe au cours de la frappe[modifier | modifier le wikicode]

Il existe une autre méthode pour vérifier votre texte, à partir du menu contextuel.[4]

Si votre lecteur d'écran est configuré pour vous indiquer les erreurs d'orthographe pendant la lecture du texte, vous pourriez rapidement rencontrer une faute d'orthographe. Le lecteur d'écran base son annonce sur l'affichage par Writer d'un soulignement rouge sous les mots erronés.

Lorsque vous en rencontrez un au cours de votre lecture mot à mot, vous pouvez le corriger sans ouvrir le correcteur d'orthographe. Pour ce faire, positionnez votre curseur sur le mot erroné et ouvrez le menu contextuel avec maj-f10 ou la touche Application de votre clavier. Les premiers éléments sont les suggestions de Writer, suivies des commandes Ignorer et ajouter. Choisissez la solution qui vous convient.

Voici un exercice pour tester cette technique, rapide si vous souhaitez corriger un texte tout en le saisissant.

  1. Lisez le document jusqu'au mot « initials ». Positionnez ensuite le curseur sur une des lettres de ce mot.
  2. Ouvrez le menu contextuel à l'aide des touches maj-f10 ou de la touche Application de votre clavier.
  3. Corrigez l'erreur avec la suggestion « initiales » proposée par Writer. Pour choisir cette suggestion, utilisez la touche Flèche bas et, une fois sur le mot, appuyez sur Entrée.

Fermez le document Lettre.odt en enregistrant les modifications.

Vous pourriez choisir de ne pas avoir de correction orthographique. En passant par le menu Outils, ouvrez le menu Langue. Puis, à l'aide de la flèche droite, ouvrez le sous-menu intitulé Pour tout le texte. Appuyez alors sur la flèche droite une nouvelle fois puis, dans la liste des langues, choisissez Aucune (pas de vérification) avec la flèche bas et appuyez sur Entrée pour confirmer votre choix. Notez que le choix vaut seulement pour le document sur lequel vous travaillez. Il vous permet aussi de changer la langue du correcteur si votre document n'est pas en français.

Nous allons dans la leçon suivante découvrir les outils d'aide à la rédaction.

Utiliser des outils d'aide à la rédaction[modifier | modifier le wikicode]

Quand vous saisissez de longues portions de texte dans votre document, vous vous apercevrez peut-être que vous commettez des fautes de frappe dont certaines ont pourtant été corrigées. Cela vient du fait que la fonctionnalité Autocorrection est activée. Cette caractéristique de Writer corrige les fautes les plus fréquentes. Par exemple, si vous saisissez « acalmie » à la place de « accalmie », Writer va reconnaître la faute et va la corriger automatiquement dès que vous ajoutez un espace ou un nouveau paragraphe. Vous pouvez personnaliser l'autocorrection afin qu'elle reconnaisse les fautes d'orthographe les plus fréquentes. Vous pouvez également supprimer toutes les entrées que vous ne souhaitez pas que la fonction Autocorrection modifie. Vous pouvez en outre la personnaliser afin qu'elle reconnaisse des abréviations ou des codes que vous créez pour automatiser la frappe de certains mots comme votre nom de famille.

Vous avez également la possibilité, dans Writer, de rechercher un synonyme à partir d'un mot sélectionné.

Avant de commencer la leçon, assurez-vous que Writer est lancé et qu'un document est ouvert. Dans le cas contraire, lancez Writer et créez un nouveau document.

Dans cette leçon, vous verrez comment configurer l'autocorrection et utiliser le dictionnaire des synonymes.

Configurer l'autocorrection[modifier | modifier le wikicode]

  1. Appuyez sur les touches alt-o pour ouvrir le menu Outils.
  2. À l'aide de la touche Flèche bas, sélectionnez la commande Options d'Autocorrection et appuyez sur la touche Entrée pour ouvrir la boîte de dialogue.
  3. Avec maj-tab puis les flèches droite ou gauche, rendez-vous dans l'onglet « Remplacer ». Puis faites tab pour entrer dans cet onglet.
  4. Votre curseur se trouve dans la zone de saisie Remplacer. C'est dans cette zone que vous taperez le mot qui devra être reconnu comme mot à changer. Dans le cadre de cet exercice, tapez le mot « vuos ».
  5. Appuyez sur tab pour amener maintenant le curseur dans la zone de saisie Remplacer par. Dans cette zone, vous saisirez le ou les mots qui remplaceront celui précédemment indiqué. Dans le cadre de cet exercice, tapez « vous ».
  6. Maintenant, appuyez sur tab jusqu'au bouton « Nouveau » et activez-le avec la touche entrée.
  7. Appuyez sur la touche tab pour vous rendre au bouton OK et appuyez sur la touche Entrée pour ajouter votre autocorrection et fermer la boîte de dialogue.

Afin de mettre en pratique l'exercice précédent, créez d'abord un nouveau document en appuyant sur les touches ctrl-n puis tapez le mot « vuos » suivi d'un espace. Remarquez que le mot s'est transformé en « vous ».

Utiliser le dictionnaire des synonymes[modifier | modifier le wikicode]

Afin de rechercher le synonyme d'un mot, vous allez ouvrir le document Fable.odt dans le dossier Exercices. Ensuite, placez votre curseur sur une des lettres du mot « commère » dans la deuxième ligne de la fable et voici comment procéder pour en obtenir un synonyme :

Assurez-vous que votre curseur se trouve sous une des lettres du mot dont vous devez trouver le synonyme. Appuyez sur les touches maj-f10 pour ouvrir le menu contextuel. Appuyez sur la touche flèche bas pour sélectionner la commande Synonymes. Puis, appuyez sur la touche flèche droite pour ouvrir son sous-menu. La liste des synonymes constitue ce sous-menu. La liste inclut les synonymes du mot selon les sens du mot. Par exemple vous aurez le synonyme du mot employé au sens figuré, celui du mot employé familièrement et celui du verbe conjugué.

Si votre mot n'est pas dans le dictionnaire, le sous-menu ne contiendra que la commande pour ouvrir la boîte de dialogue Dictionnaire des synonymes, mais rien d'autres.

Si vous appuyez sur Entrée, votre mot sera remplacé par son synonyme choisi.

Afin de mettre en pratique les explications de cette leçon, vous allez remplacer le mot « commère » par un de ses synonymes. Voici comment procéder.

  1. Appuyez sur les touches maj-f10 pour ouvrir le menu contextuel.
  2. Appuyez sur la flèche bas pour sélectionner la commande Synonymes. Appuyez sur flèche droite pour ouvrir le sous-menu correspondant.
  3. Appuyez sur flèche bas pour sélectionner le mot « bavarde ». Appuyez sur Entrée pour remplacer « commère » par ce synonyme.

Fermez le document Fable.odt sans enregistrer les modifications. Dans la prochaine leçon, vous allez utiliser un outil vous aidant à publiposter une lettre.

Préparer un publipostage[modifier | modifier le wikicode]

Cette leçon est sans doute la plus complexe de ce cours et nous vous invitons à la sauter si vous ne pratiquez jamais cet usage.

Le publipostage consiste, à partir d'une lettre, à remplacer une de ses parties par des éléments, qui se trouvent dans un autre fichier. Par exemple, sur un document où est inscrit « Monsieur », vous pouvez demander que soient créées autant de copies que de destinataires et qu'à chaque copie, après « Monsieur », figure le nom du destinataire. Plus encore, vous pouvez décider d'écrire le texte d'une lettre et souhaiter y inscrire les coordonnées de votre correspondant de manière automatique.

Vous allez pratiquer le premier cas d'utilisation, parce qu'il est plus accessible que l'autre et conduit, en fin de compte, à un résultat identique et accessible.

Pour une telle opération, nous allons utiliser le fichier Publipostage.odt, qui est la lettre-type, et le fichier Répertoire.ods. Il s'agit d'un tableau contenant les coordonnées de cinq destinataires du courrier type.

Dans cette leçon, vous apprendrez comment préparer le document type, préparer la base de données, appliquer le publipostage.

Préparer le document type[modifier | modifier le wikicode]

Votre document type contient ce que vous souhaitez envoyer à vos destinataires. Rédigez-le intégralement en appliquant la mise en forme que vous souhaitez.

Préparer la base de données[modifier | modifier le wikicode]

La base de données peut être de plusieurs types. Le plus facile à mettre en place reste cependant un tableau, créé avec un outil de tableur. Pour notre exercice, le fichier créé a été fait dans Calc, le tableur fourni avec LibreOffice.

Ouvrez le document Répertoire.ods et examinez sa structure pour voir comment les informations sont réparties. Le titre des colonnes est indispensable sur la première ligne et leur organisation vous sera fort utile, même si certaines restent vides. Refermez-le ensuite avec ctrl-f4.

Appliquer le publipostage[modifier | modifier le wikicode]

Votre document Publipostage.odt devrait être affiché à l'écran. Nous allons générer maintenant autant de documents que nécessaire, contenant chacun le nom du destinataire. Voici comment procéder.

  1. Dans le document Publipostage.odt, positionnez le curseur après le mot Madame et avant la virgule. Inscrivez un espace.
  2. Appuyez sur les touches alt-i pour dérouler le menu Insertion. Puis, à l'aide de la flèche bas, sélectionnez la commande Champs. Dans le sous-menu, choisissez Autres.
  3. Dans la boîte de dialogue, sélectionnez l'onglet Bases de données. Vous retrouvez alors une boîte de dialogue similaire à celle de renvoi.
  4. Dans la liste déroulante Type, sélectionnez le type Champ de mailing.
  5. À l'aide de la touche tab, sélectionnez le bouton Parcourir et activez-le. Choisissez alors le fichier Répertoire.ods.
  6. Dans la liste déroulante Sélection, un nouvel élément apparaît intitulé Répertoire. Ouvrez-le à l'aide de la flèche droite.
  7. Appuyez de nouveau sur la flèche bas puis la flèche droite, afin de faire apparaître le titre des colonnes contenues dans le fichier créé avec le tableur.
  8. Dans cette liste, choisissez la ligne intitulée « Nom » et appuyez sur Entrée pour l'insérer. Si vous aviez souhaité insérer les adresses, les codes postaux et les villes, vous auriez appuyé sur la touche Entrée sur chacune des lignes contenant les titres des colonnes correspondant à l'adresse, au code postal et à la ville. Vous êtes en effet libre d'insérer autant d'éléments que vous le souhaitez.
  9. Appuyez sur tab jusqu'au bouton Fermer et activez-le à l'aide de la touche Entrée.
  10. De retour dans votre document Publipostage.odt, vous pouvez maintenant lire, après le mot « Madame », <Nom>. Quand votre curseur passe dessus avec les flèches gauche et droite, vous ne pouvez pas le parcourir caractère par caractère, car c'est un mot spécial. Seule votre aide technique vous permettra d'épeler le mot contenu dans ce champ. Par contre, vous pouvez le déplacer comme n'importe quel mot et insérer du texte avant ou après. Si vous avez inséré pluesieurs champs, pour une adresse par exemple, vous pouvez les disposer comme bon vous semble (sur plusieurs lignes, etc).[3]
  11. Appuyez sur les touches alt-o pour dérouler le menu Outils et sélectionnez la commande Assistant Mailing. Appuyez sur Entrée pour ouvrir la boîte de dialogue.
  12. Le premier écran de cet outil vous demande de sélectionner le document de base. Comme vous êtes déjà dans le fichier Publipostage.odt, et le bouton radio Utiliser le document actif étant sélectionné, appuyez sur Entrée.
  13. L'écran suivant vous propose de créer une liste de diffusion de messages électroniques ou de courriers papier. Dans le cadre de cet exercice, choisissez le bouton radio Lettre, sélectionné par défaut, et appuyez sur Entrée.
  14. L'écran suivant permet de rajouter des adresses. Il ne vous est pas utile car vous avez déjà inséré les champs qui vous intéressent. Il constitue la seconde méthode de publipostage, mais sa stabilité reste faible et son accessibilité également. Sélectionnez le bouton Suivant et appuyez sur Entrée.
  15. L'écran suivant vous permet d'insérer des formules de salutation automatiques. Comme votre document est déjà totalement rédigé, passez-le en appuyant sur la touche Entrée.
  16. L'écran suivant permet d'indiquer le nombre de destinataires voire de les filtrer. Dans le cadre de cet exercice, inscrivez 5 dans la zone de saisie du destinataire. Appuyez ensuite sur Entrée.
  17. Passez également l'écran suivant qui ne vous apportera rien, l'essentiel du formatage ayant été fait par vous préalablement.
  18. Le dernier écran vous permet de décider de la forme que prendra le publipostage. Vous pouvez décider d'imprimer tous les documents générés, de les envoyer en pièces jointes d'un message électronique, ou simplement de les enregistrer. Dans le cadre de cet exercice, vous allez enregistrer les documents finaux sur votre ordinateur. Sélectionnez donc Enregister les documents fusionnés et appuyez sur la touche tab.
  19. Le bouton radio où se positionne votre curseur vous permet de décider d'enregistrer votre résultat dans plusieurs fichiers ou de les regrouper dans un seul. Il peut être plus facile pour gérer l'impression que vous créiez plusieurs fichiers, un par lettre. Si vous créez un courrier pour des centaines de personnes, cela sera également plus efficace à l'enregistrement et plus souple en cas de problème ou de besoin d'intervention de votre part pendant l'impression. D'un autre côté, en sauvegardant toutes vos lettres dans un fichier, il vous suffira d'imprimer le fichier pour imprimer toutes vos lettres, parcequ'elles sont organisées correctement par le traitement de texte. L'autre méthode vous obligera à sélectionner vos fichiers et à lancer l'impressioin à partir du gestionnaire de fichiers. Dans le cadre de cet exercice, sélectionnez le bouton radio Enregistrer comme document unique. À l'aide de la touche tab, sélectionnez ensuite le bouton Enregistrer les documents et appuyez sur Entrée.
  20. Vous voici dans une boîte de dialogue similaire à celle Enregistrer sous. Nommez votre fichier Lettres imprimables et enregistrez-le dans le dossier Exercices. Appuyez sur Entrée pour fermer la boîte de dialogue.
  21. Après quelques secondes, la boîte de dialogue du dernier écran de l'assistant mailing réapparaît. Sélectionnez le bouton terminer à l'aide de la touche tab et appuyez sur Entrée.
  22. Ouvrez maintenant le document Lettres imprimables.odt du dossier Exercices. En parcourant le fichier, vous constaterez qu'il contient autant de pages que de destinataires, en l'occurrence cinq, et que chacune contient le nom adéquat après monsieur, Madame.

Dans la prochaine leçon, vous apprendrez à protéger votre document. Fermez le document Lettres imprimables.odt à l'aide des touches ctrl-f4.

Protéger un document[modifier | modifier le wikicode]

Vous pouvez, si vous le souhaitez, limiter l'accès à un document. Voici comment procéder

  1. Dans Writer, appuyez sur les touches ctrl-n pour créer un nouveau document.
  2. Dans le document à protéger, appuyez sur les touches alt-f pour dérouler le menu Fichier de la barre de menus. Puis, à l'aide de la flèche bas, sélectionnez la commande Propriétés. Appuyez sur Entrée pour ouvrir la boîte de dialogue Propriétés.
  3. La boîte de dialogue Propriétés comporte plusieurs onglets. Rendez-vous sur celui intitulé Sécurité.
  4. L'onglet Sécurité comporte deux cases à cocher et un bouton pour soumettre ou non l'accès du document à un mot de passe. La première case à cocher, appelée « Ouvrir en lecture seule » empêche toute personne de modifier le document en n'autorisant que sa lecture. La deuxième case à cocher, appelée Enregistrer les modifications, permet aux de relecteurs de modifier le document mais affiche tous les changements en surbrillance de manière à ce que l'auteur puisse les repérer facilement. Si un document est protégé par les révisions, vous ne pouvez pas désactiver le suivi des modifications, ni accepter ou rejeter une modification. Enfin, le bouton Protéger ouvre une boîte de dialogue vous demandant le mot de passe que vous souhaitez utiliser pour protéger le document. Entrez le mot de passe de votre choix et confirmez-le, puis appuyez sur Entrée.
  5. De retour à la boîte de dialogue Propriétés, appuyez sur le bouton OK pour valider vos changements.

Enregistrez votre document dans le dossier Exercices sous le nom de secret.odt et fermez-le.

Dans la prochaine leçon, vous allez apprendre comment signer électroniquement votre document.

Signer votre document[modifier | modifier le wikicode]

Quand vous transmettez ou diffusez un document électroniquement, vous êtes un acteur de l'information. Il est donc essentiel que ce que vous transmettez puisse être authentifié par vos destinataires. C'est particulièrement le cas quand vous effectuez des démarches administratives importantes.

Pour ce faire, vous devez disposer d'une signature électronique, ou d'un certificat. Celui-ci indique à vos destinataires que vous êtes l'auteur authentique d'un document. Créer un tel outil est une tâche complexe, nous vous recommandons de vous rapprocher d'une personne ressource pour obtenir de l'aide. Sous GNU/Linux, vous utiliserez l'outil GPG et pouvez trouver un grand nombre de tutoriels sur Internet pour vous aider à le faire.

Pour commencer, il vous faut une signature électronique, appelée aussi clé ou certificat. Nous vous suggérons de faire appel à une personne ressource pour mettre en place un tel certificat. Vous pouvez mettre en place le vôtre, mais il vaut mieux en demander un à une institution reconnue pour les délivrer, qu'on appelle autorité de certification. Cela donne une authenticité plus rapide et immédiate à votre signature électronique. Dans un deuxième temps, vous allez indiquer à Writer où se trouve votre signature électronique. Enfin, vous allez l'appliquer.

Indiquer à Writer sa signature électronique[modifier | modifier le wikicode]

Avant de signer des documents, vous devez définir une signature, c'est-à-dire un fichier d'extension .pub, contenant votre clé publique. C'est cette clé publique avec laquelle vous signez. Dans le cadre du prochain exercice, nous supposons que votre clé se situe à la racine de votre dossier personnel dans un document cle.pub. Voici comment ajouter cette signature à vos clés dans Writer.

  1. Appuyez sur les touches alt-o pour ouvrir le menu Outils. Puis, à l'aide de la flèche bas, sélectionnez la commande Options et appuyez sur la touche Entrée pour ouvrir la boîte de dialogue.
  2. Dans l'arborescence des onglets, choisissez avec la flèche bas celui intitulé LibreOffice. Ouvrez-le avec la touche flèche droite.
  3. Sélectionnez l'onglet Sécurité à l'aide de la touche flèche bas. Dans cet onglet, avec la touche tab, sélectionnez le bouton Certificat et appuyez sur Entrée. Une nouvelle boîte de dialogue s'ouvre. Elle contient la liste de vos clés, qui est pour l'instant vide. En effet, vous pouvez signer différemment selon votre document et son importance.
  4. À l'aide de la touche tab, sélectionnez le bouton Ajouter et appuyez sur Entrée pour ouvrir la boîte de dialogue correspondante.
  5. Votre curseur se trouve dans une zone de saisie où vous pouvez taper le chemin vers le fichier contenant votre clé. Dans le cadre de cet exercice, tapez ~/
  6. Enfin, validez les boîtes de dialogue en appuyant sur le bouton OK autan de fois que nécessaire.

Signer un document[modifier | modifier le wikicode]

Voici les étapes à suivre pour aposer votre signature électronique et certifier que vous êtes l'auteur d'un document.

  1. Appuyez sur les touches alt-f pour dérouler le menu Fichier.
  2. À l'aide de la flèche bas, sélectionnez la commande Signatures numériques et appuyez sur Entrée pour ouvrir la boîte de dialogue. Si votre document n'a pas été enregistré, Writer vous demandera de le faire avant de poursuivre.
  3. La boîte de dialogue présente les signatures du document. Pour ajouter la vôtre, choisissez Signer le document avec la touche tab.
  4. À l'aide de la flèche bas, choisissez la signature qui vous convient. Appuyez sur Entrée pour la sélectionner.

Questions et réponses[modifier | modifier le wikicode]

Cette leçon vous présente une liste de cinq questions à choix multiples. La bonne réponse se trouve dans la section #Réponses. Pour plus d'interaction, se trouve dans cette zone la raison pour laquelle les autres réponses ne sont pas correctes.

Questions à choix multiples[modifier | modifier le wikicode]

  1. À quoi sert la commande Rechercher de Writer ?
    1. à rechercher un document ou un dossier
    2. à rechercher les erreurs orthographiques dans un document
    3. à rechercher une page ou une section
    4. à rechercher un mot, un caractère ou une mise en forme
  2. Quelle commande permet de lancer l'assistant de création d'un publipostage ?
    1. La commande Champs du menu Insertion
    2. La commande Nouveau du menu Fichier
    3. La commande Ouvrir du menu Fichier
    4. La commande Renvoi du menu Insertion
  3. Quelle touche doit être utilisée pour lancer le correcteur orthographique ?
    1. La touche f7
    2. La touche maj
    3. La touche f2
    4. La touche f12
  4. À quoi sert la signature électronique d'un document ?
    1. à y apposer votre nom
    2. à lui donner un style personnalisé
    3. à l'authentifier comme étant de vous
    4. à le protéger contre les modifications externes
  5. Quel type d'information n'affiche pas la fonction statistique du menu outils de Writer ?
    1. Le nombre de tableaux
    2. Le nombre de mots
    3. Le nombre de pages
    4. Le nombre de caractères

Réponses au quiz[modifier | modifier le wikicode]

  1. La commande Rechercher de Writer ne sert pas à rechercher un fichier ou un dossier, ni à rechercher les erreurs orthographiques d'un document, ni à rechercher une page ou une section. Elle sert plutôt à rechercher un mot, un caractère ou une mise en forme d'un document. Référez-vous à la leçon 1 pour réviser les différentes possibilités de cette fonction de Writer.
  2. La commande Champ du menu Insertion permet effecitvement de lancer, grâce à la commande Autre champ du sous-menu, l'assistant de publipostage. La commande Nouveau du menu Fichier sert plutôt à créer un nouveau document. Ouvrir sert à en ouvrir un. La commande Renvoi affiche une boîte de dialogue similaire mais dans un autre onglet, et sert à insérer un renvoi vers un autre élément du document. Référez-vous à la leçon 5 pour réviser les notions sur le publipostage.
  3. La touche f2 sert à saisir une nouvelle formule. En appuyant sur la touche f7, vous lancez le correcteur d'orthographe. La touche f2 sert à ouvrir la barre de formule. La touche f12 bascule l'activation de la numérotation automatique. Référez-vous à la leçon 3 pour revoir les notions sur le vérificateur d'orthographe.
  4. La signature électronique ne permet pas d'indiquer votre nom, ou du moins tel n'est pas son usage décisif, ni à empêcher toute modification externe du document. Elle ne permet pas de personnaliser le style d'un document. Elle sert plutôt à garantir que vous êtes bien l'auteur d'un document. Référez-vous à la leçon 7 pour réviser les notions sur la signature électronique.
  5. La fonction statistique du menu Outils de Writer n'affiche pas le nombre de tableaux. Cette information se trouve dans la boîte de dialogue Propriétés, onglet Statistiques. Par contre, elle affiche le nombre de mots, de pages et de caractères. Référez-vous à la leçon 2 pour revoir les caractéristiques de cette fonction.

Notes et références[modifier | modifier le wikicode]

  1. Insertion-entrée deux fois du pavé numérique : permet d'obtenir l'information présentée sur la dernière ligne d'une fenêtre. Par exemple, cette commande permet de lire l'information présentée sur la barre d'état d'une fenêtre d'application lorsque celle-ci est affichée.
  2. Insertion-entrée deux fois du pavé numérique : permet d'obtenir l'information présentée sur la dernière ligne d'une fenêtre. Par exemple, cette commande permet de lire l'information présentée sur la barre d'état d'une fenêtre d'application lorsque celle-ci est affichée.
  3. 3,0 3,1 et 3,2 7 8 9 4 5 6 1 2 3 : déplace le curseur de balayage. Ces commandes permettent de déplacer le curseur de balayage d'Orca et le pointeur à travers, notamment, une boîte de dialogue. Elle vous permet donc de l'explorer librement sans vous soucier du curseur.
  4. Voir l'attribut Erreurs d'orthographe des préférences.
Erreur de référence : La balise <ref> nommée « orca37 » définie dans <references> n’est pas utilisée dans le texte précédent.